Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > General Talk And Support

General Talk And Support General talk and peer-to-peer support about BS.Player and other video and audio multimedia players.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 25th April 2004
Junior Member
BS.Player Newbie
 
Join Date: Mar 2004
Posts: 7
Rep Power: 0
nagad is an unknown quantity at this point
Default AutoRun with BSplayer v 1.00 RC1 Build 807

When I make AutoRun CDs with earlier version of bsplayer there is no problem. But with the version I wrote in the Subject line of this post, no matter what I do, the progrem starts but it says closded and doesn't auto play the movie.
In the cd root directory I put these files:
bsplay.exe
bsrendv2.dll
BSPlayer.xml
bspfilters.sam
bsplay.exe.manifest
autorun.inf
BSplayer.ini (or .bsi)
movie.avi
sub.sub
The folders: Skins, Sdk, Plugins and lang.

My Autorun .inf looks like this:
[AUTORUN]
OPEN=bsplay.exe "BSplayer.ini"
icon=autorun.ico

My BSplayer.ini looks like this:
[Main]
Version=1.00
NumberCDs=2
CD=1

[Movie]
Title=Indiana Jones And The Raiders Of The Lost Ark
Directory=.
FName=Indiana Jones And The Raiders Of The Lost Ark_Cd1.avi
FName2=Indiana Jones And The Raiders Of The Lost Ark_Cd2.avi

[Subtitles]
Directory=.
Sub1=Indiana Jones And The Raiders Of The Lost Ark_Cd1.sub
Font=177;David;30;1;16777215
FontColor=00FFFFFF
BackColor=00000000
SubPos=-106

[Options]
PanScan=0
FullScreen=1
Skin=Showtime v1.4 PH.bsz
Lang=HEBREW
Aspect=Original
RunHD=0

Is there anybody who can explain why the player runs automaticlly but it doesn't play the movie automaticlly as the earlier version does. I want the CD runs automaticlly without using programs like HW_BSplayer_Autorun etc, just the .inf file and the BSplayer.ini (or .bsi).
What is wrong? Am I doing something wrong, or I'm missing something?

Please help.
Reply With Quote
  #2 (permalink)  
Old 25th April 2004
DragonFighter's Avatar
Senior Member
BS.Player Power User
 
Join Date: Apr 2004
Location: Hellas
Age: 35
Posts: 195
Rep Power: 0
DragonFighter is an unknown quantity at this point
Default

Ok. Let me tell you which files/folders aren't necessary:

Files: BSplayer.xml, BSplayer.sam, bsplay.exe.manifest
Folders: Sdk, Plugins

The below info isn't necessary too:
FName2=Indiana Jones And The Raiders Of The Lost Ark_Cd2.avi

Other comments:

The below info:
Font=177;David;30;1;16777215
FontColor=00FFFFFF
BackColor=00000000
SubPos=-106

... must change into something like this:
Font=177;David;30;1;3D3344
FontColor=00FFFFFF
SubPos=-106

And this:
[Options]
PanScan=0
FullScreen=1
Skin=Showtime v1.4 PH.bsz
Lang=HEBREW
Aspect=Original
RunHD=0

into this:
[Options]
PanScan=0
FullScreen=1
Skin=Showtime v1.4 PH
Lang=HEBREW
RunHD=0

P.S.: You can use HWmaker in order to make operational ini/bsi files. It isn't obligatory if you use HWmaker, to use HWlauncher (aka HW_BSplayer_Autorun.exe).
However, what is the reason and you don't use HWlauncher?
__________________
HWmaker
Please read BSPeter's Help2Help topic
Reply With Quote
  #3 (permalink)  
Old 26th April 2004
Junior Member
BS.Player Newbie
 
Join Date: Mar 2004
Posts: 7
Rep Power: 0
nagad is an unknown quantity at this point
Default It doesn't work

Thank you for the quick answer, but it doesn't work.

I did exectly as you wrote, but only the player runs automticlly without playing the movie. What should I do to tell the player to play the movie according to the settings I wrote in the bsplayer.ini (or .bsi).

Thanks again.
Reply With Quote
  #4 (permalink)  
Old 26th April 2004
DragonFighter's Avatar
Senior Member
BS.Player Power User
 
Join Date: Apr 2004
Location: Hellas
Age: 35
Posts: 195
Rep Power: 0
DragonFighter is an unknown quantity at this point
Default

I see... Well, I can guess what the problem is..
What method do you choose to check if the movie is loaded or not?
Do you burn a cd?
If you don't, you MUST have the files into a folder with no spaces!
P.e: C:\DivX_Movies\Indiana_Jones\
Then run BSplay.exe through the command line of windows.
Use path\BSplay.exe "BSplayer.ini" option.

The autorun.inf should be:
OPEN=bsplay.exe "BSplayer.ini" as you said before. I was wrong about that: OPEN=bsplay.exe. :oops:

Note: Update into built 808 as it fixes a bug with ini/bsi files :!:
__________________
HWmaker
Please read BSPeter's Help2Help topic
Reply With Quote
  #5 (permalink)  
Old 26th April 2004
Junior Member
BS.Player Newbie
 
Join Date: Mar 2004
Posts: 7
Rep Power: 0
nagad is an unknown quantity at this point
Default Thanks again

Well, I'm glad to write that I did as you wrote, to update to build 808, and now every thing works well.
Reply With Quote
  #6 (permalink)  
Old 18th May 2004
Kordo's Avatar
Member
BS.player Regular User
 
Join Date: May 2004
Posts: 55
Rep Power: 0
Kordo is an unknown quantity at this point
Default

I've just grabbed this BSCDmaker and it work like a treat. Very easy to use.

http://www.geocities.com/bscdautoplay/
Reply With Quote
  #7 (permalink)  
Old 21st May 2004
bscd's Avatar
Member
BS.player Regular User
 
Join Date: Apr 2003
Location: Finland
Posts: 78
Rep Power: 0
bscd is an unknown quantity at this point
Default

...Thanks, I'm glad you find it useful :D
Reply With Quote
Reply

Tags
100, autorun, rc1

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 08:11 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19