Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   General Talk And Support (http://forum.bsplayer.com/general-talk-support/)
-   -   Playing Mov files (http://forum.bsplayer.com/general-talk-support/5575-playing-mov-files.html)

John Blaze 30th September 2004 04:05 AM

Playing Mov files
 
How can i get bsplayer to play mov files?

Garet_Jax 30th September 2004 08:31 AM

You get QuickTime with keygen.
Also you can use quicktime alternative
(refer to that topic: http://forum.bsplayer.org/viewtopic.php?t=3042&start=15 )

But IMHO quicktime alternative sucks (quality!!!)

grendizer 1st July 2006 01:15 AM

And what would be a good alternative to Quicktime Alternative? :shock:
I have problems with Quicktime playback too.

Tizio 1st July 2006 08:49 AM

I'm able to play the two (2) quicktime files I have on my PC with BSplayer+Quicktimealternative.. I remember that some month (years?) ago everythings was fine, then were been released some QuickTimeAlternative versions that didn't worked with many QT files. Now it seems that it's working again, but if you say you can't play your files....I don't know...

If you have some clip to upload we can test it.. maybe an audio codec isssue? Some files can't be played if the audio codec doesn't handle the audio stream properly..

grendizer 1st July 2006 01:40 PM

Is the audio of Quicktime files handled by Quicktime Alternative as well?

Here is an exact description of my problem:

- Using Bsplayer, when I try to read *.mov files burnt on a dvdr, it does not play nicely. The video stops every seconds, during half a second, and then keeps playing for one second, then stops again... and so on.
- When I read the same *.mov file burnt on a dvdr, with MPC or VLC: not problem at all! (but it seems VLC does not use Quicktime Alternative. For MPC: I'm not sure).
- Now if I copy the MOV file on the hard drive, when I try to read it with BsPlayer, it plays much better, but not perfectly. It seems there are still some little jerks in the playback of the MOV file.
- When I read the same *.mov file from the hard drive, with MPC or VLC: not problem at all.

Any clue about that? I hope I won't have to install the Quicktime player :?

Tizio 1st July 2006 02:52 PM

Could it be related to the file buffer feature?
Maybe try to increase the buffer size in BSplayer preferences (with CD-ROM option selected). I tried only with short clips, so I don't have problems..

If you want to know what audio filter is used to decode the video look at BSplayer's Filters menu section (right-click -> Options -> Filters -Z Advanced)

adicoto 1st July 2006 04:28 PM

Grendizer, QT container is same as avi. You have a splitter, a decoder for video part and a decoder for audio part. Basically video stream is MPEG4 nowadays, but audio stream have different codecs than windows. Anyway, nowadays audio streams are AAC too. So, like Tizio wrote in an eariler post, can you point us to a such video file for testing ?

In program files\quick time alternative\QTSystem you'll find the filters (.QTX extension) and in the root directory you'll find QuickTime.ax, wich is the splitter.

grendizer 2nd July 2006 12:13 AM

Ok I will try to answer question, it would be cool to sort this out.

First, when I go to options > filters > advanced, I cannot see any audio codec used. Quicktime Alternative is used. Here is the screenshot.
http://david.saber.free.fr/bazaar/pr...s_advanced.jpg

Then, when I render the mov file with Graphedit, I get a very strange graph. Here is the screenshot:
http://david.saber.free.fr/bazaar/pr.../graphedit.jpg
I do not understand anything in this graph. I don't get what is "color space converter", and I don't get how the input of the graph can send the audio directly to the output : "default direct sound device". Where is the splitter?? And why is Quicktime Alternative not showing up in this graph?

When copied to the hard drive, the mov file plays smoothly in BsPlayer.

This problem happens with EVERY mov file, but if you want to test the file, here it is:
http://david.saber.free.fr/bazaar/problems/lo_a.mov
Perhaps you could try to burn it to a CDRW to check if it plays badly.

One other note: the problem is ALMOST the same in Windows Media Player 10. The difference is that in BsPlayer, the video and sound is jerky. In WMP, the video is jerky, but the sound runs OK.

Now about the buffer options, I can't access them, the tab is not clickable! I don't understand why??
http://david.saber.free.fr/bazaar/pr...r_disabled.jpg

Thanks both for your help. 8)

Tizio 2nd July 2006 12:51 AM

1 Attachment(s)
Mmm :?
I finished now in testing your file and.. I've not burned it to a CDRW, but only played it on my HDD.. the strange thing is that QTAlternative didn't want to parse the file and play it.. but Nero parser/filter payed the file (audio included)

If you want to try this filters I have attached a copy of them.
Register them and tell if you were able to play your file without problems..

adicoto 2nd July 2006 06:30 AM

1 Attachment(s)
To do the things more interesting here are my results. File playing OK on the hard drive using.....Gabest MP4 splitter. No QT alternative, no Nero decode.

Now, let's search for the sound.

adicoto 2nd July 2006 06:40 AM

1 Attachment(s)
Now there is sound OK.

adicoto 2nd July 2006 06:51 AM

Bug about device confirmed. Just put the file on a USB flash memory (from wich I can play smoothly XviD avis) and the file was played poorly, many stops, even with an 256 MB buffer activated.

Tizio 2nd July 2006 10:48 AM

Only an answer.. what have you done to achieve audio for that file (since in the post before it wasn't playing) :)
Thanks :wink:

adicoto 2nd July 2006 10:55 AM

First time, the file was playing using Gabest MP4 splitter. Second time, using QuickTime source from QT alternative (you may see the path). So, guess what have I done :D

grendizer 2nd July 2006 01:34 PM

2 Attachment(s)
PROBLEM FIXED!!! Thanks guys :D

After I registered the filters given by Tizio, I don't have any problems reading this mov file from a dvd-rw.

Here is the filters > advanced dialog in BsPlayer: 2nd image below.
And here is the Graphedit graph: 1rst image.

And now, some questions to make all things clear:
- It seems that Quicktime Alternative is not very good, is it best to use another alternative for Quicktime?
- What software does install the Nero Quicktime filters?
- What software does install the Gabest MP4 splitter?
- In the graph, where is the splitter? Is the Quicktime source also a splitter?
- What is the "EQ" filter that appears in BsPlayer's advanced filters dialog?

adicoto 2nd July 2006 02:36 PM

Quote:

Originally Posted by grendizer
PROBLEM FIXED!!! Thanks guys :D

After I registered the filters given by Tizio, I don't have any problems reading this mov file from a dvd-rw.

Here is the filters > advanced dialog in BsPlayer: 2nd image below.
And here is the Graphedit graph: 1rst image.

And now, some questions to make all things clear:
- It seems that Quicktime Alternative is not very good, is it best to use another alternative for Quicktime?
- What software does install the Nero Quicktime filters?
- What software does install the Gabest MP4 splitter?
- In the graph, where is the splitter? Is the Quicktime source also a splitter?
- What is the "EQ" filter that appears in BsPlayer's advanced filters dialog?

1. If it works, better use something else
2. Nero Burning Rom (c:\program files\common files\ahead\DSfilter)
3. regsvr32.exe (or register via BSPlayer)
4. It's the splitter
5. It's the Equalizer

grendizer 2nd July 2006 03:30 PM

So for Gabest MP4 splitter, it comes with Media Player Classic, but only works in MPC? If I want to use it via DirectShow I must register it, correct?

adicoto 2nd July 2006 03:44 PM

Yes.

Tizio 2nd July 2006 04:13 PM

Finally you solved your problem :wink:
Glad to know I was part of it :D

grendizer 2nd July 2006 11:06 PM

8)

I would like to try the Gabest MPEG4 splitter instead of the Nero one. So I need to register it.
I searched in Gspot's list of installed codecs, BsPlayer codec's list and DXMan, but couldn't find anything that is named like that. Also in the Media Player Classic folder in Program files, there is no codec. What is the name of it and where can I find it?


All times are GMT +1. The time now is 05:08 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20