Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > General Talk And Support

General Talk And Support General talk and peer-to-peer support about BS.Player and other video and audio multimedia players.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 17th October 2004
Junior Member
BS.player Regular User
 
Join Date: Sep 2004
Location: Sweden
Posts: 21
Rep Power: 0
Dennis_Olof is an unknown quantity at this point
Default TV-picture "Zooming" in when in TV-mode problem :/

Hi.

I though I had this fixed but after installing SP2 on XP it seems to have come back, guess my "fix" wasnt 100% good.

I have a GF4 card and the latest drivers from Nvidia (not upgraded, but did a re-install of XP not to long ago). Anyway.

What I can understand this problem is a general problem on the Nvidia drivers.

http://forums.snapstream.com/vb/arch...p/t-19196.html

Everything works fine but when I switch to TV mode and run BSplayer (this it not the problem) and then start a movie and make it "full screen" the picture (windows desktop) gets "zoomed in" and the startbutton it just outside the tv-screen edges. I can goto a fast menu on the Nvidia icon and
get hold of the screen configurations, there I can select "standard" and the picture is fine again.

The problem is that this accours all the time it keep zooming in. Its verry irritating that the Nvidia driver cant remember this setting or what ever the problem is. I want the standard size of the picture to remain regardless of what im doing on the TV-screen.

And yes, im not using dual view and I use 640*480 becaus I cant see what im doing on the TV otherwise.

I have been using TV tools, different versions before but this problem has been around for a while now. So my guess is that Nvidia has problems.

My question is, anyone know how to fix this, or force the Nvidia to stick to the "template" or saved settings file or how it works in order to stop if from "zooming" in when in TV mode.

I can seem to find a solution to this problem.

Dual view might work but of what I can tell the playback aint 100% smooth with this, maby becaus my card is a GF4 ? but im not going to get a new one.

Anyone got any ideers on this problem ?

:?
Reply With Quote
  #2 (permalink)  
Old 20th October 2004
Junior Member
BS.player Regular User
 
Join Date: Sep 2004
Location: Sweden
Posts: 21
Rep Power: 0
Dennis_Olof is an unknown quantity at this point
Default I fixed it my self by doing this

Well, well, well seems I solved this problem with some help from someone else in here.

It is NOT the Nvidia drivers that are bad, it's bsplayer doint funny things.

If you are using standard settings in BS Player, change this

Goto prefrences -> video -> video rendering. The standard option used here is "overlay mode 1" and by switching to "forece RGB mode" BS player now dont mess up the settings or whatever it's doing.

Now I can play anything in fullscreen, go back to smaller window to navigate on the computer (when in TV mode) and then resume video and goto full screen.

Before the desktop got "zoomed in" which made the desktop icons and startbutton get just outside the TV-screen.

So I guess this problem has been around for a while in BS Player. And I think this proves it's something wrong with the way "overlay mode 1" and how BS player brings the video to full screen, that zooms the picture.

This problem can't be tested on ordinary computer screen because you cant zoom the picture since you cant get to the settings as you can when you are in TV-mode

Hope this helps some other persons that have this problem too. This problem probably will happend regardless if you use TV-tools or not etc.

But im not sure.

:?
Reply With Quote
  #3 (permalink)  
Old 23rd October 2004
Junior Member
BS.player Regular User
 
Join Date: Sep 2004
Location: Sweden
Posts: 21
Rep Power: 0
Dennis_Olof is an unknown quantity at this point
Default This works too.

By using VRM-9 this option allso avoids the "zoom in bug" in BSplayer when in TV mode :]

Good to know, but seems BS Player team dont know about this problem.

Though all others should know

:?
Reply With Quote
  #4 (permalink)  
Old 22nd November 2005
Junior Member
BS.Player Newbie
 
Join Date: Jul 2005
Posts: 4
Rep Power: 0
Guzo is an unknown quantity at this point
Default

I've found the solution!
And it works 100% sure!

First, open regedit (Start > Execute > Regedit or c:\windows\regedit.exe)
make a backup (file > exporting)

In regedit, search for "videoborder"

You'll find some keys like that :
NVZORAN.525@60Hz.videoborder
NV36ZORAN.525@60Hz.videoborder
NV36ZORAN.625@60Hz.videoborder
NVZORAN.625@50Hz.videoborder
....
(the name depends on your nvidia graphic card but it's always followed by ".videoborder")

The set number should be 01 00 00 00
But some of them have this number : 00 00 00 00
If so, modify the number and correct it so that a "1" appears on the second number : 01 00 00 00 like it should be.

once again the correct answer is for example...
NV36ZORAN.525@60Hz.videoborder = 01 00 00 00

Close regedit when every key has a one in it.
Reboot you're computer for the changing to take effect.

Then you can open your videos in full screen, it'll never zoom in like it used to!
It's fixed, finally!!!!
Good luck and happy viewing!
Reply With Quote
  #5 (permalink)  
Old 5th January 2006
Junior Member
BS.Player Newbie
 
Join Date: Sep 2005
Posts: 3
Rep Power: 0
RutgerB is an unknown quantity at this point
Default

I tried your proposed solution Dennis_Olof but I did not manage, however Guzo's solution worked like a charm, thnx alot, was searching for a solution for this for a long time!
Reply With Quote
  #6 (permalink)  
Old 2nd January 2007
Junior Member
BS.Player Newbie
 
Join Date: Sep 2005
Posts: 3
Rep Power: 0
RutgerB is an unknown quantity at this point
Default

Well recently I've gotten a new videocard, an Ati this time, and the problem is back again.
However I cannot find the "videoborder" reg entry.

Anyone any idea on how to solve this? I already submitted a ticket at Ati, so I hope they'll come up with a solution.
Reply With Quote
Reply

Tags
tvmode, tvpicture, zooming

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 01:23 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20