Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > General Talk And Support

General Talk And Support General talk and peer-to-peer support about BS.Player and other video and audio multimedia players.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 26th December 2004
AR AR is offline
Junior Member
BS.Player Newbie
 
Join Date: Dec 2004
Location: Lisbon
Posts: 4
Rep Power: 0
AR is an unknown quantity at this point
Default How to do subtitles appear on the position defined in *.BSI?

I'm using BSPlayer Pro 1.02 build 812, and I always like to create *.bsi files for my movies to set certain options.

The problem is that on this new versions of bsplayer the subtitles position always stays on Auto position, even when I define SubPos=-118 on the *.BSI file I use to load the movie.

This is very annoying because I like the subtitle just below the movie, and not on the bottom of the screen.

On the older versions like 0.8 the subtitles always started where I defined.

So does anyone knows a way I can disable the auto subtitles position on bsplayer forever?
Or a way so that the subtitles appear on the position that I define on the BSI file?

Here's an example of the *.BSI files I'm working with:


[Movie]
Title="Fellowship of the ring-CD1"
Directory="/"
FName="Fellowship.of.the.ring-CD1.avi"
[Subtitles]
Directory="/Extended.edition.DVDRip.AC3.XviD-MDX"
Sub1=Portugues 1|1Fellowship of the Ring CD1.srt
Sub2=Portugues 2|2Fellowship Of The Ring Extended(AC3) CD1.SUB
Sub3=Portugues 3|3Lord Of The Rings CD1.sub
Font=1;Arial;35;0;16777215
FontColor=00FFFFFF
BackColor=
SubPos=-118
DefaultSub=1
[Options]
FullScreen=1
ExitAtEnd=1


Thank you
Reply With Quote
  #2 (permalink)  
Old 26th December 2004
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 51
Posts: 5,150
Rep Power: 27
adicoto is on a distinguished road
Default

See in the xml file, IIRC in BSPlayer 1 the position is defined a little different than in old BSPlayer.
Reply With Quote
  #3 (permalink)  
Old 26th December 2004
AR AR is offline
Junior Member
BS.Player Newbie
 
Join Date: Dec 2004
Location: Lisbon
Posts: 4
Rep Power: 0
AR is an unknown quantity at this point
Default

I edited the xml file, and changed the string <SubAutoPos type="int">1</SubAutoPos> to <SubAutoPos type="int">0</SubAutoPos>

but when I load the *.bsi file it still remains the check on "Auto position" option.

If I remove the check manualy, the subtitles stay where I want them.

While reading the ini_files.html i saw this line:
SubPos is subtitle position, if it's <=0 or not defined then subtitles will be positioned automatically

Damn, I always want to place the subtitles in less than zero positions.
Reply With Quote
  #4 (permalink)  
Old 26th December 2004
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 51
Posts: 5,150
Rep Power: 27
adicoto is on a distinguished road
Default

<SubAutoPos type="int">0</SubAutoPos>
<SubPos type="int">4294928407</SubPos>

This is my setting, with the subtitle right in the middle of the black border of my last movie i've seen on TV-out. Positioned manually, with shift+arrow.
Reply With Quote
  #5 (permalink)  
Old 27th December 2004
AR AR is offline
Junior Member
BS.Player Newbie
 
Join Date: Dec 2004
Location: Lisbon
Posts: 4
Rep Power: 0
AR is an unknown quantity at this point
Default

Mine had a different value in SubPos type, and I put just like yours.
But it happened the same. When I load the *.bsi file with setting SubPos= -118, BSPlayer stayed in Auto position, located almost at the bottom of the screen.

After lanching BsPlayer a few times I noticed that the string <SubAutoPos type="int">0</SubAutoPos> changed to 1, but I reverted it back to 0, and made the *.xml file Read Only.

Thanks for your help. I guess that I'll have to positionate the subtitles manually on most of the movies or change back to BsPlayer 0.8 until they fix the problem.
Reply With Quote
  #6 (permalink)  
Old 7th January 2005
artam's Avatar
Member
BS.player Regular User
 
Join Date: Apr 2004
Posts: 98
Rep Power: 16
artam is on a distinguished road
Default

I foud that if there is no version iformation in the [Main] section of *.bsi file (i.e. deleting the line Version=xxxx), the subtitles will be shown at the negative position below video frame correctly.

Tried on ATI R9000 with display clone mode, remember, TV must be set as primary display, else the video frame will black. Will not work in overlay mode (theater).
Reply With Quote
Reply

Tags
bsi, defined, position, subtitles

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 05:41 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20