Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   General Talk And Support (http://forum.bsplayer.com/general-talk-support/)
-   -   how to change the resolution in desktop mode ? (http://forum.bsplayer.com/general-talk-support/6407-how-change-resolution-desktop-mode.html)

bigblue06 16th May 2005 11:36 AM

how to change the resolution in desktop mode ?
 
Hi,

Does anyone know how to change the resolution on an avi file in desktop mode ?

I want to do that with the commands lines.

I cant' use the command '-deskmode" with the other commands "-res=800X600X32-60" and "-ar=4:3" ...

help pliz
:-(

BSPeter 16th May 2005 12:08 PM

Though I don't really know, I personally would think it logical that in desktopmode only the existing resolution of the desktop would/could be used. Different aspect-ratios should work though.
:wink:

bigblue06 16th May 2005 12:30 PM

My desktop is in 1280X1024 (32 bits colours and 60Hz).

my movie file is in 1024 X 464 (the World of warcraft Intro).

if I switch in desktop mode I have 2 bigs black band at the top and the botom of the video.

If i manually switch on to "movie mode" (shortcut M) and i switch after on desktop mode (shortcut D) the vid?©o is in fullscreen on my desktop ant it's look very good.

I just want to do the same witch command lines (change the resolution of the movie on 1280X1024 or switch to "movie mode" and after that, switch on the desktop mode.

BSPeter 16th May 2005 04:02 PM

What happens if you use "-pan" (for pan&scan mode) as an alternative for movie mode?
:wink:

bigblue06 16th May 2005 04:44 PM

don't work.
i've already test it.
:-(

if i type :

bsplayer.exe c:\video.avi -pan -deskmode
or
bsplayer.exe c:\video.avi -deskmode -pan

I have exactly the same result ...
the movie launch as desktop mode but the video stay at the same (it's not in fullscreen)


the player can switch on "movie mode" and the player can change the video resolution but I think that the developers of bsplayer are forget to expand that possibilities for the desktop mode...
:-(

It's possible to do that manually (pressing the keys "M" then "D") but we can't do that by commands lines for do the same automatically (with a simple batch) ...

what a pity, if there the possibility to do that, Bsplayer was really powerfull...


Actually I've resize my vid?©o on 1280X1024 with virtualdub and I recompress it after.
the problem : I lost the quality of the movie ...
:-(


the batch is very simple and it work good if the vid?©o is at the correct resolution :

start c:\progra~1\bsplay~1\bsplayer.exe D:\movie.avi -deskmode -hide


If anyone have other idea (I'm french, sorry for my english ...)

BSPeter 16th May 2005 05:07 PM

Hmmm, strange!
I've tested making a Windows-shortcut on my desktop with as "target":
"C:\Program Files\Webteh\BSplayer\bsplayer.exe" "D:\Movies\New\Test.avi" -pan -deskmode -hide
and when I doubleclick on it, it does exactly what you expect !!
:?

bigblue06 16th May 2005 05:24 PM

I've just take the test and it dont work ...

on your shortcup if you delete the "-pan" I think you have the same result.
Your video is in 16:9 or 4:3 ?
I think you fiole is in 4:3 ratio

and the option "pan" is different of "movie mode".

- "span" resize the movie but crop the movie also
- "movie mode " resize the movie and nothing is croping.

BSPeter 16th May 2005 08:32 PM

I've meanwhile downloaded wowintro.avi and tested with that (at the same desktop-resolution as you use). The only possible way to get that movie on a "screen-filling"desktop without cropping (in either panscan or movie mode) is to distort its ratio to 4:3.
I changed the "target" in my windows-shortcut into:
"C:\Program Files\Webteh\BSplayer\bsplayer.exe" "D:\Movies\New\wowintro.avi" -ar=4:3 -pan -deskmode -hide
Could you test on your system (with and/or without -pan).
:wink:
P.S.: Perhaps also check settings of the several "remember"-options like concerning "movie window size" and "movie window position".

bigblue06 16th May 2005 10:47 PM

Hehe BSpeter

it's works, "a little" ...

on the bsplayer shorcut if we type the command "-deskmode" it disable the commands "-pan" , "-ar" and "-fs".
I test it and it the same if we do that manually with the player.

for example :

"C:\Program Files\BSplayerPro\bsplayer.exe" "C:\video.avi" -pan -deskmode -hide

here the command "-pan" is disable because of the command "deskmode"



we must launch at first the player then select the options "remember the windows size" and "remember zoom position".
then play the movie and select the ratio 4:3
finally close the player

if we lanch the shortcut (C:\Program Files\BSplayerPro\bsplayer.exe" "C:\video.avi" -deskmode -hide) the movie is resize correctly on the length but not on the width ...

I don't know why but it miss a small band vacuum at the bottom of the desktop ...

If we do the same operation manually with the player we have exactly the same result ... (movie 4:3 then desdesktop mode on)

it's work correcly only when we switch on "movie mode" and then switch on the desktop mode... (but we don't know how th di that with command lines ...)

what do u think ?

BSPeter 16th May 2005 11:25 PM

Under "Preferences" > "General" I've both "remember-boxes" unchecked (=deselected).
Under "Preferences" > "Video" the only box I've checked/selected is "Borderless Play window"
Under rightclick > Video and its sub-options: nothing is selected.
My Windows-shortcut works exactly as intended by you (provided BSPlayer is not active when doubleclicking on that shortcut).
:wink:
(without the "-pan" bit in the commandstring there only remains a narrow band at top and bottom)
What video-rendering do you use (I use Overlay Mode 1). Further what codec/filter does BSPlayer use for playback?
(rightclick > Options > Filters > Advanced)
I'm using DivX and under its "Quality settings" I've selected "Maintain Original" with respect to Aspect Ratio and at the right I've checked all boxes except "Yuv Extended Mode".

bigblue06 17th May 2005 05:24 PM

hi BSpeter !

I test and it don't work ...
I'm test on my second computer and it work perfectly ...

I uninstall bsplayer from my 1st computer and r?©intall it and now all works good !

"C:\Program Files\BSplayerPro\bsplayer.exe" "C:\video.avi" -ar=4:3 -pan -deskmode -hide

effectively like you tell "pan" remove the band at the bottom of the desktop.
:-)

so there's never problem, it's just because of my first instalation of bsplayer ...
:-(

thank you a lot !


neverdeless I think there is a bug with the hide command.
if there's the command "deskmode" AND "hide" on the shortcut, the command "hide" hide the player (good), add the bsplayer icon on systray (good too) but bsplayer icon stay also on the taskbar (no good)...

If I remove "-hide" on my shortcut and I rediuce manually the player it's OK (that's hide the player, and bsplayer on systray et remove bsplayer from the taskbar)

It's the same on my 2 computer

have u got the same thing ?


All times are GMT +1. The time now is 10:41 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20