Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > General Talk And Support

General Talk And Support General talk and peer-to-peer support about BS.Player and other video and audio multimedia players.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 16th May 2005
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 8
Rep Power: 0
bigblue06 is an unknown quantity at this point
Default how to change the resolution in desktop mode ?

Hi,

Does anyone know how to change the resolution on an avi file in desktop mode ?

I want to do that with the commands lines.

I cant' use the command '-deskmode" with the other commands "-res=800X600X32-60" and "-ar=4:3" ...

help pliz
:-(
Reply With Quote
  #2 (permalink)  
Old 16th May 2005
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 28
BSPeter is on a distinguished road
Default

Though I don't really know, I personally would think it logical that in desktopmode only the existing resolution of the desktop would/could be used. Different aspect-ratios should work though.
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #3 (permalink)  
Old 16th May 2005
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 8
Rep Power: 0
bigblue06 is an unknown quantity at this point
Default

My desktop is in 1280X1024 (32 bits colours and 60Hz).

my movie file is in 1024 X 464 (the World of warcraft Intro).

if I switch in desktop mode I have 2 bigs black band at the top and the botom of the video.

If i manually switch on to "movie mode" (shortcut M) and i switch after on desktop mode (shortcut D) the vid?©o is in fullscreen on my desktop ant it's look very good.

I just want to do the same witch command lines (change the resolution of the movie on 1280X1024 or switch to "movie mode" and after that, switch on the desktop mode.
Reply With Quote
  #4 (permalink)  
Old 16th May 2005
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 28
BSPeter is on a distinguished road
Default

What happens if you use "-pan" (for pan&scan mode) as an alternative for movie mode?
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #5 (permalink)  
Old 16th May 2005
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 8
Rep Power: 0
bigblue06 is an unknown quantity at this point
Default

don't work.
i've already test it.
:-(

if i type :

bsplayer.exe c:\video.avi -pan -deskmode
or
bsplayer.exe c:\video.avi -deskmode -pan

I have exactly the same result ...
the movie launch as desktop mode but the video stay at the same (it's not in fullscreen)


the player can switch on "movie mode" and the player can change the video resolution but I think that the developers of bsplayer are forget to expand that possibilities for the desktop mode...
:-(

It's possible to do that manually (pressing the keys "M" then "D") but we can't do that by commands lines for do the same automatically (with a simple batch) ...

what a pity, if there the possibility to do that, Bsplayer was really powerfull...


Actually I've resize my vid?©o on 1280X1024 with virtualdub and I recompress it after.
the problem : I lost the quality of the movie ...
:-(


the batch is very simple and it work good if the vid?©o is at the correct resolution :

start c:\progra~1\bsplay~1\bsplayer.exe D:\movie.avi -deskmode -hide


If anyone have other idea (I'm french, sorry for my english ...)
Reply With Quote
  #6 (permalink)  
Old 16th May 2005
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 28
BSPeter is on a distinguished road
Default

Hmmm, strange!
I've tested making a Windows-shortcut on my desktop with as "target":
"C:\Program Files\Webteh\BSplayer\bsplayer.exe" "D:\Movies\New\Test.avi" -pan -deskmode -hide
and when I doubleclick on it, it does exactly what you expect !!
:?
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #7 (permalink)  
Old 16th May 2005
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 8
Rep Power: 0
bigblue06 is an unknown quantity at this point
Default

I've just take the test and it dont work ...

on your shortcup if you delete the "-pan" I think you have the same result.
Your video is in 16:9 or 4:3 ?
I think you fiole is in 4:3 ratio

and the option "pan" is different of "movie mode".

- "span" resize the movie but crop the movie also
- "movie mode " resize the movie and nothing is croping.
Reply With Quote
  #8 (permalink)  
Old 16th May 2005
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 28
BSPeter is on a distinguished road
Default

I've meanwhile downloaded wowintro.avi and tested with that (at the same desktop-resolution as you use). The only possible way to get that movie on a "screen-filling"desktop without cropping (in either panscan or movie mode) is to distort its ratio to 4:3.
I changed the "target" in my windows-shortcut into:
"C:\Program Files\Webteh\BSplayer\bsplayer.exe" "D:\Movies\New\wowintro.avi" -ar=4:3 -pan -deskmode -hide
Could you test on your system (with and/or without -pan).

P.S.: Perhaps also check settings of the several "remember"-options like concerning "movie window size" and "movie window position".
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #9 (permalink)  
Old 16th May 2005
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 8
Rep Power: 0
bigblue06 is an unknown quantity at this point
Default

Hehe BSpeter

it's works, "a little" ...

on the bsplayer shorcut if we type the command "-deskmode" it disable the commands "-pan" , "-ar" and "-fs".
I test it and it the same if we do that manually with the player.

for example :

"C:\Program Files\BSplayerPro\bsplayer.exe" "C:\video.avi" -pan -deskmode -hide

here the command "-pan" is disable because of the command "deskmode"



we must launch at first the player then select the options "remember the windows size" and "remember zoom position".
then play the movie and select the ratio 4:3
finally close the player

if we lanch the shortcut (C:\Program Files\BSplayerPro\bsplayer.exe" "C:\video.avi" -deskmode -hide) the movie is resize correctly on the length but not on the width ...

I don't know why but it miss a small band vacuum at the bottom of the desktop ...

If we do the same operation manually with the player we have exactly the same result ... (movie 4:3 then desdesktop mode on)

it's work correcly only when we switch on "movie mode" and then switch on the desktop mode... (but we don't know how th di that with command lines ...)

what do u think ?
Reply With Quote
  #10 (permalink)  
Old 17th May 2005
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 28
BSPeter is on a distinguished road
Default

Under "Preferences" > "General" I've both "remember-boxes" unchecked (=deselected).
Under "Preferences" > "Video" the only box I've checked/selected is "Borderless Play window"
Under rightclick > Video and its sub-options: nothing is selected.
My Windows-shortcut works exactly as intended by you (provided BSPlayer is not active when doubleclicking on that shortcut).

(without the "-pan" bit in the commandstring there only remains a narrow band at top and bottom)
What video-rendering do you use (I use Overlay Mode 1). Further what codec/filter does BSPlayer use for playback?
(rightclick > Options > Filters > Advanced)
I'm using DivX and under its "Quality settings" I've selected "Maintain Original" with respect to Aspect Ratio and at the right I've checked all boxes except "Yuv Extended Mode".
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #11 (permalink)  
Old 17th May 2005
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 8
Rep Power: 0
bigblue06 is an unknown quantity at this point
Default

hi BSpeter !

I test and it don't work ...
I'm test on my second computer and it work perfectly ...

I uninstall bsplayer from my 1st computer and r?©intall it and now all works good !

"C:\Program Files\BSplayerPro\bsplayer.exe" "C:\video.avi" -ar=4:3 -pan -deskmode -hide

effectively like you tell "pan" remove the band at the bottom of the desktop.
:-)

so there's never problem, it's just because of my first instalation of bsplayer ...
:-(

thank you a lot !


neverdeless I think there is a bug with the hide command.
if there's the command "deskmode" AND "hide" on the shortcut, the command "hide" hide the player (good), add the bsplayer icon on systray (good too) but bsplayer icon stay also on the taskbar (no good)...

If I remove "-hide" on my shortcut and I rediuce manually the player it's OK (that's hide the player, and bsplayer on systray et remove bsplayer from the taskbar)

It's the same on my 2 computer

have u got the same thing ?
Reply With Quote
Reply

Tags
change, desktop, mode, resolution

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 02:09 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20