Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   General Talk And Support (http://forum.bsplayer.com/general-talk-support/)
-   -   aspect ratio (solved) and AVI open problem (SOLVED!) (http://forum.bsplayer.com/general-talk-support/7735-aspect-ratio-solved-avi-open-problem-solved.html)

Digiface 6th August 2006 04:32 AM

aspect ratio (solved) and AVI open problem (SOLVED!)
 
when i open .mkv file or dvd ,aspect ratio is not right (it's shrinked). i have to go aspect ratio settings and click original and then it will be right. i have keep aspect ratio checked. this problem is only with .mkv files and one DVD-R file that i got. is there any solution for this? i have MatroskaSplitter/FFDShow installed and BS.Player 2.10.

J7N 6th August 2006 11:42 AM

Re: aspect ratio
 
What aspect ratio (SAR & DAR) does ffdshow show for your files?

Matroska container includes a few numeric fields that suggest the player the dimensions it is supposed to scale the video display. Are these values correct in your MKVs?

Are you using ffdshow to decode MPEG-2 (dvds)?

Digiface 6th August 2006 12:17 PM

i just opened one .mkv file and SAR was 1/1 and DAR 80/34. FFDSHOW decodes this because it's XviD. well,it's seems to be that FFDShow can't somehow show right resolution for .mkv files,because it shows that res. is 640x344,while right is 640x480. clicking "original" on BSP aspect ratio setting fixes that.

EDIT: just opened another .mkv and yes,FFDShow show wrong vertical res. for .mkv's.

and i use just GPL MPEG2 decoder to DVD files.

J7N 6th August 2006 12:44 PM

I'm sorry, I dunno what's the problem then. "Original" is supposted to return to the picture dimensions that ffdshow reports under "Info & Debug" ignoring any custom SAR (pixel ratio).

Any chance I could acquire the file that doesn't work (unmodified)?

Digiface 6th August 2006 12:46 PM

don't you have any mkv files on yourself?

J7N 6th August 2006 12:54 PM

I have and they work properly (except when VirtualDubMod sets wrong SAR).

Digiface 6th August 2006 12:58 PM

what matroska decoder/splitter do you use?

J7N 6th August 2006 01:07 PM

Gabest's Matroska Splitter (which of course does not resize video) v1.0.2.9.

FFdshow 20060522 rev2546 SSE2 for decoding XViD and H264.

Digiface 6th August 2006 01:16 PM

is it same as this http://www.free-codecs.com/download/...a_Splitter.htm

BTW,why you don't use FFDshow to decode DivX? just curious...

EDIT: just noticed that bsplayer shows wrong resolution on it's main player window. FFdshow and Gspot show different (i guess right) resolution. i mean every video file.

J7N 6th August 2006 02:20 PM

Yes, I should have said M$ MPEG-4 (DIV3..), MPEG-4 ASP (XviD, DivX), H.264, WMA and MPEG-2 occasionaly. ;)

Just played all my Matroska videos. Nothing went wrong.

Quote:

FFdshow and Gspot show different (i guess right) resolution.
You said the res wasn't correct in ffdshow's dialog. 80/43=640/344

Digiface 6th August 2006 02:40 PM

yes i thought so,but Gspot shows same resolution for a file than FFDshow,so i guess that is then right res. but BSP show different. only vertical width is different. i don't know anything about those DAS & DAR. :?

J7N 6th August 2006 02:55 PM

ffdshow -> Info & Debug * should show the resolution of the stream you input, the assumed pixel dimensions (SAR) and the resulting horizontal/vertical ratio (DAR).

SAR 1/1 means pixels are square shaped. Any other value means that the image must be scaled (resampled) during display as it is in most cases impossible to change pixel ratio.

If Info & Debug shows "XVID" as the input FourCC, it is the real resolution of your file. If the fourCC is an uncompressed type such as "YV12" or "DIB*" it could mean that another filter that resizes the picture is active (unlikely).

Have you tried to play completely different unrelated Matroska files?

Digiface 6th August 2006 02:58 PM

1 Attachment(s)
it's same with example avi.

and i found just another problem; BSPlayer won't like to open some avi file anymore. i tried some random files and only happens with that one file. with MPC it opens fine. i tried to figure out what's different in this one file and only things i noticed with Gspot,is that there's no metadata on file and stream type is different,"rec list something". EDIT: well,some other file with no metadata opened fine,so that cannot be reason.

here's that file Gspot info picture:

BSPeter 6th August 2006 04:23 PM

Did you notice GSpot tells in the north-east quarter of its window that you're missing XviD-codec (but you're probably using FFDShow?) so could you please let us know what the info is if you click on [Render] (in GSpot's bottom frame) and then (after "Rendering Successful") you 'click for details' at the bottom of GSpot's window?
:wink:

Digiface 6th August 2006 04:35 PM

1 Attachment(s)
yes i'm using FFDshow. here's new picture

J7N 6th August 2006 10:46 PM

Perhaps the AVI structure is bad (the file might be incomplete). BSPlayer cannot open such files while MPC and VideoLAN can be used fine to preview them even while they're being written to. If it is so then remux the file in Matroska or recreate the AVI index block (VideoLAN, VirtualDubMod).

Regarding Tizio's post below:
I truncated one of my AVI files in the middle of its index block and tried to play the video. BSPlayer v1.36 refused to open it. BSPlayer v2.10.939 tried to open it but crashed as soon as I pressed Play.

Tizio 7th August 2006 12:02 AM

I never had problems with BSplayer and avi files with corrupted structures..
Only very little problem I had with avi files with partial correct structure and last part missing. BSplayer was able to fully reindex the avi only by a small percentage, but the file was playable anyway :wink:

It's strange if the file is corrupted in the structure part but the error is on the movie size since the movie size is stored in the first part of the file while the structure/index is in the latter (if by structure you mean the P frames etc. index) :?

Digiface 7th August 2006 02:29 AM

that file used to open fine with older BSPlayer,but now with 2.10 it won't open. when i try to open it ,BSPlayer hangs and even makes explorer.exe to restart and after that video starts to play. but if i right click tray window (before explorer.exe restart) and choose "close",then window pop up and says that file cannot be found.

so i think that it might be somekind of bug in BS.player 2.10 with certain files,while MPC opens it fine. i have tried with random files and so far only had problem with this one file.

EDIT: MPC ja VLC plays that file fine,but example BSPlayer and WMP won't. what's is happened to that file? it used to open fine. can defragment damage files?

EDIT: i check file with AVImedic and it says there was 0.1Mb (49Kb) of fake data. and files that work have none fake data.

Tizio 7th August 2006 11:24 AM

Are you able to restore that portion of fake data?
Does the program tell you if the problem is in the index portion of the file (most probably it's there) or in the middle of the file?

If it's in the index part, you can use DivFix to rebuild the movie index (if AVImedic hasn't a similar option) :wink:

Tizio 7th August 2006 11:24 AM

Quote:

Originally Posted by J7N
Regarding Tizio's post below:
I truncated one of my AVI files in the middle of its index block and tried to play the video. BSPlayer v1.36 refused to open it. BSPlayer v2.10.939 tried to open it but crashed as soon as I pressed Play.

I'll try to make the same thing :wink:


All times are GMT +1. The time now is 02:36 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20