Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > General Talk And Support

General Talk And Support General talk and peer-to-peer support about BS.Player and other video and audio multimedia players.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 14th September 2007
Junior Member
BS.player Regular User
 
Join Date: Jul 2007
Posts: 16
Rep Power: 0
greenice is an unknown quantity at this point
Default Unable to play an .avi file...

Intel Pentium 4 - 2.8GHZ – Hyper Threading FSB 800MHZ – 1MB Cache
Motherboard Intel D865 Perl
Memory 1 GB DDR 400MHZ – Dual Channel 2 x 512MB
Video Nvidia G Force 4 FX 5200 256MB DDR
Windows XP Pro SP2
BSPlayer Professional v2.23.953

Downloading an episodic TV Series I now have a playback issue with one
of the last chapters installed; it's an .avi file and it just wont play (Screen opens and stays blank black, no image or sound). Maybe the file is bad or corrupted, but before deleting (and having to throw away all the downloading time spent) I would like to know if there is a fix. I've checked each and every one of the previous chapters installed and the only difference I can see with the file in question is a splitter filter. Whereas all previous files play correctly and in "Options" - "Filters" all show the AVI Splitter (quartz.dll - located in C\:Windows\System32) as one of the filters, the file with the issue shows a Nero MP4 Splitter Filter
located in Program Files-Common Files-Ahead-DSFilter. Could this be the
problem?
Appreciate your advice.
Reply With Quote
  #2 (permalink)  
Old 15th September 2007
J7N's Avatar
J7N J7N is offline
Senior Member
BS.Player Power User
 
Join Date: Feb 2006
Location: Cyberspace
Posts: 762
Rep Power: 0
J7N is an unknown quantity at this point
Default Re: Unable to play an .avi file...

I see 2 choices here:
1) uninstall the Nero filters
2) transmux your video file into Matroska, so that Nero filters wouldn't touch it.
Reply With Quote
  #3 (permalink)  
Old 15th September 2007
Junior Member
BS.player Regular User
 
Join Date: Jul 2007
Posts: 16
Rep Power: 0
greenice is an unknown quantity at this point
Default

Ok, thanks for your reply J7N.
I would go for the first alternative. However, why do the Nero filters interfere with this particular episode?; they do not interfere with previous or subsequent episodes or any other avi file. What could possibly be the reason?
Reply With Quote
  #4 (permalink)  
Old 15th September 2007
J7N's Avatar
J7N J7N is offline
Senior Member
BS.Player Power User
 
Join Date: Feb 2006
Location: Cyberspace
Posts: 762
Rep Power: 0
J7N is an unknown quantity at this point
Default

I have no way of telling for sure without the ability to see your system (I don't have Nero filters and have no intention to install them, if even on a test system), or the video file.

I think your system is detecting some bit of MPEG-4 inside your [perhaps completely valid] AVI file. This is very unlikely, but maybe your AVI has AAC audio, or Mp3 that somebody by mistake has muxed into an MP4. Examination with a hex editor would shed some light on this.

It has happened before that MPEG-2 video and MP3 audio, which in reality were part of a movie, were detected by the system as elementary streams. Files got played back with sporadic noise, where the container metadata or other streams were interleaved.
Reply With Quote
  #5 (permalink)  
Old 16th September 2007
Junior Member
BS.player Regular User
 
Join Date: Jul 2007
Posts: 16
Rep Power: 0
greenice is an unknown quantity at this point
Default

Thanks again for your reply J7N.

Just to tell you, that I unregistered the Nero MP4 Splitter and "Lo n' Behold" I got the darned file to play. What shows up now in BSP Options - Filters, is an Avi Parser?

The fact is, that I never did install Nero filters, these must have come with the Nero Premium Reloaded suite I installed some time ago.

In any case, many thanks for your help.

Cheers
Reply With Quote
  #6 (permalink)  
Old 16th September 2007
J7N's Avatar
J7N J7N is offline
Senior Member
BS.Player Power User
 
Join Date: Feb 2006
Location: Cyberspace
Posts: 762
Rep Power: 0
J7N is an unknown quantity at this point
Default

:D

That is correct. Nero installs a bunch of system components even if all the user wants is optical disc recording. There are special Lite versions of Nero (of course unauthorized by Ahead).
Reply With Quote
Reply

Tags
avi, play, unable

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 02:07 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19