Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > General Talk And Support

General Talk And Support General talk and peer-to-peer support about BS.Player and other video and audio multimedia players.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 30th April 2008
Junior Member
BS.Player Newbie
 
Join Date: Apr 2008
Posts: 6
Rep Power: 0
test45 is an unknown quantity at this point
Default [FIXED] Capture only as .BMP

An attempt to do a image capture within BSPlayer results in the generation of a .bmp regardless of the "Image Format" option (it's set to .jpg but .bmp files are generated).

Is there anyway to force the generation of .jpg files (.bmp offers little quality increase and creates files which are several MB in size which isn't ideal).
Reply With Quote
  #2 (permalink)  
Old 30th April 2008
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 22
Tizio will become famous soon enough
Default

Can't confirm, I have the correct behavior on my PC
Are you sure you set the correct extension?
And the string used to generate the captured image?
__________________
BSP SkinMaker (v1.07) the one and only Skin Editor for BSplayer
BSP Definitions Manager (v1.02)
BS.Player's FAQ (by BSPeter) | Italian language file (v2.57 build 1051)
Reply With Quote
  #3 (permalink)  
Old 30th April 2008
Junior Member
BS.Player Newbie
 
Join Date: Apr 2008
Posts: 6
Rep Power: 0
test45 is an unknown quantity at this point
Default

Thanks for the quick reply. Are the settings files fully removed upon an uninstal (could it be that the settings file is damaged in some way which means that certain settings aren't retained).

The string is the default one, the only config settings changed is the directory where the file is saved to.

Config settings

The generated file (filetype is stated as .bmp and the filesize of 3.51 MB rather than the normal ~150KB suggests this is true).

'
Reply With Quote
  #4 (permalink)  
Old 1st May 2008
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 22
Tizio will become famous soon enough
Default

Sorry for the late reply..
You can delete the settings file manually, I'm not sure if they will be deleted after an uninstall process :P

The settings file (BSplayer.xml) is locate either in BSplayer installation directory (usually C:\Program Files\Webteh\BSplayer\) or in user data folder (C:\Documents and Settings\USER_NAME\Application data\BSplayer\)
Delete or rename BSplayer.xml and then start BSplayer. This way your settings will be resetted to the default values. I hope this way your problem get fixed

You can also use a little utility made by me to do the previous tasks: http://bsplayer.com/forum/viewtopic.php?p=32777#32777
__________________
BSP SkinMaker (v1.07) the one and only Skin Editor for BSplayer
BSP Definitions Manager (v1.02)
BS.Player's FAQ (by BSPeter) | Italian language file (v2.57 build 1051)
Reply With Quote
  #5 (permalink)  
Old 1st May 2008
Junior Member
BS.Player Newbie
 
Join Date: Apr 2008
Posts: 6
Rep Power: 0
test45 is an unknown quantity at this point
Default

Removing the App Data files didn't appear to help.

Everything appears to work okay under Windows XP, it's just in Vista which this is occuring.

Given that there's a error message about the video overlay redering upon installation I tried changing the rendering mode.

Switching away from the default EVR rendering sees the generation of .jpg files. Is there a fixable reason for this (are further codecs needed or does EVR only save .bmp?)?

I've tried a few of the others but playback appears more unstable with them (capturing causes the video to hang briefly). Is there a specific rendering mode to switch to if EVR causes problems?
Reply With Quote
  #6 (permalink)  
Old 1st May 2008
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,155
Rep Power: 27
adicoto is on a distinguished road
Default

Overlay mixer could offer you a good playback quality under Vista.
Reply With Quote
  #7 (permalink)  
Old 1st May 2008
Junior Member
BS.Player Newbie
 
Join Date: Apr 2008
Posts: 6
Rep Power: 0
test45 is an unknown quantity at this point
Default

Overlay causes Vista to default to it's basic mode (rather than the Aero interface) which suggests theres some kind of conflict. Captures in any of the rendering modes with overlay in it are just black so they can't be used.

The best one I've found so far appears to be "Internal Renderer RGB Mode". It looks like this causes big lags in video playback if captures are taken though (so with each snapshot the video hang for a second which really affects playback).
Reply With Quote
  #8 (permalink)  
Old 3rd May 2008
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 22
Tizio will become famous soon enough
Default

Internal Overlay Mixer (default) had always worked fine for me, in WinXP and WinVista.
Now I can't test its behavior under WinVista since I now use WinXP only. If someone with WinVista can test this and confirm the bad behavior we can add this to bugs report
__________________
BSP SkinMaker (v1.07) the one and only Skin Editor for BSplayer
BSP Definitions Manager (v1.02)
BS.Player's FAQ (by BSPeter) | Italian language file (v2.57 build 1051)
Reply With Quote
  #9 (permalink)  
Old 14th May 2008
Junior Member
BS.Player Newbie
 
Join Date: Apr 2008
Posts: 6
Rep Power: 0
test45 is an unknown quantity at this point
Default

I'm still struggling with this.

I don't know wether it's just my settings but I've yet to find a combination of settings which enables captures to be performed which result in .jpg file and little playback lag.

From the rendering list in my BSPlayer, the bottom bunch (EVR, VMR 7 / 9) all result in .bmp files despite .jpg specified as output in the settings).

The top bunch (Internal renderer) seem a little more stable. With tweaking some are almost there (Internal Renderer Overlay), however this seems to be lost when YV12 format, YUY2 format and Disable YV12 format are deselected (which tends to be needed otherwise the default capture colouring is really desaturated).
Reply With Quote
  #10 (permalink)  
Old 15th May 2008
Junior Member
BS.player Regular User
 
Join Date: Oct 2007
Posts: 21
Rep Power: 0
markweng is an unknown quantity at this point
Default

I have the same 2 problem.
1: JPG format is valid only for internal rendering mode, not for vmr/evr.
2: I prefer internal rendering overlay, but default preset - "convert captured image in software for yv12/yuy2" will be wrong color. This option must be disable for my case.
Reply With Quote
  #11 (permalink)  
Old 18th May 2008
Junior Member
BS.Player Newbie
 
Join Date: Apr 2008
Posts: 6
Rep Power: 0
test45 is an unknown quantity at this point
Default

You can manually adjust colours in BSPlayer video colours changing the brightness and making them more palatable (though I'm not sure whether this filters down to screen captures).

As far as I can tell there's not easy work around to this unfortunately (all the rendering options have some issue in terms of captures when used under Vista).

The solution for the moment appears to be to use the software under XP (which doesn't seem to have the same issues with rendering modes such as overlay). It's a hassle (if you dual boot then you keep having to switch over to XP whenever you want to watch a video) but perhaps the issue will be resolve in future builds of the application (I'd imagine more people might speak up when Vista is adopted by more people).
Reply With Quote
  #12 (permalink)  
Old 19th June 2008
Junior Member
BS.Player Newbie
 
Join Date: Nov 2004
Posts: 2
Rep Power: 0
rewn is an unknown quantity at this point
Default

ugh, just upgraded to Vista and my dear old screen shot capture isn't working, well it is, but BMP only.

Is there any resolution to this ?!
Reply With Quote
  #13 (permalink)  
Old 19th June 2008
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 22
Tizio will become famous soon enough
Default

Can you Ico-man reproduce/confirm this? (I can't access to Vista at the moment)
Especially the statement stated byu markweng

Is it a bug or algorithm limitation?
__________________
BSP SkinMaker (v1.07) the one and only Skin Editor for BSplayer
BSP Definitions Manager (v1.02)
BS.Player's FAQ (by BSPeter) | Italian language file (v2.57 build 1051)
Reply With Quote
  #14 (permalink)  
Old 22nd June 2008
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 22
Tizio will become famous soon enough
Default

Ok, it was a bug already fixed almost one month ago :oops: (I didn't saw the beta relese :P )
At the moment it's available as a beta release and the fix will be available to non Pro users as soon as the new version is released

An extract from latest v2.29.965 beta changelog
Code:
- capture frame to JPG format didn't work with VMR and EVR renderer (BMP was used instead), fixed
Thank DragonFighter for releasing the language file for v2.29.965, this way I found out that a new beta has been released :D
__________________
BSP SkinMaker (v1.07) the one and only Skin Editor for BSplayer
BSP Definitions Manager (v1.02)
BS.Player's FAQ (by BSPeter) | Italian language file (v2.57 build 1051)
Reply With Quote
Reply

Tags
bmp, capture

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 11:03 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20