Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Subtitles (http://forum.bsplayer.com/subtitles/)
-   -   HOW DOES BS PLAYER PLAY ARABIC SUBTITLES ??? :P:P (http://forum.bsplayer.com/subtitles/12266-how-does-bs-player-play-arabic-subtitles-p-p.html)

Drift4King 20th July 2011 05:01 AM

HOW DOES BS PLAYER PLAY ARABIC SUBTITLES ??? :P:P
 
I have version 1.58 beta build 1053 and the arabic subtitles works like some strange language , Farsi maybe , and It has nothing to do with my windows because the same subtitles works with media player classic ...

I tried to uninstall and reinstall dozens of times but still doest work ..

I know for sure that bs player is best of the best , but It still has some problems with some codecs like ( Flv play , and rm files ) But those I managed to fix , I would be so glad if anyone could help , thanks for you interest .:angel:

And when I install pervious version it is reversed .....

I hope you help me , and now other versions all play it strangely not even the reversed problem any more :confuse::confuse:

adicoto 20th July 2011 07:58 AM

In BSPlayer's subtitle option, which script is selected ?
Options-> preferences -> subtiles -> font

Drift4King 20th July 2011 12:44 PM

thanks for your help
 
Western

Drift4King 20th July 2011 12:46 PM

and I tried every script but didnt work still all strange languages , but different every time , noting that I dont have windows problem , they work on media player classic >.

adicoto 20th July 2011 02:26 PM

MPC and BSPlayer have different rendering engines, they have nothing in common in this matter.
For the main interface, do you have arabic set as language or english ? If arabic, does it display correctly ? If not, then you haven't enabled arabic support in windows (control panel -> region and language for win7 or regional and language options for XP)

Drift4King 22nd July 2011 04:26 AM

NO Its English , and Arabic works just fine in all windows features and programmes :happyroll:

Drift4King 22nd July 2011 04:27 AM

HELP :P:P
 
and I heard about that rending thing alot of times in threads and posts , what is it , how does it wok ???

adicoto 22nd July 2011 06:24 AM

Both BSPlayer and MPC uses directshow to render the image. But for subtitles, they have different engines. In fact, at this time, BSPlayer have 2 different engines (you can eneble the new subtitle rendering engine in preferences -> subtitles -> use the new engine). You may test if there is a difference by enabling/disabling this option (BSPlayer restart is requiered)
So, if you change the language for BSPlayer's main interface to arabic, does the characters display correctly ?

Drift4King 22nd July 2011 09:54 AM

cant find what you are talking about
 
I didnt find the option : use the new engine , I have version 2.58 build 1053

I attached 2 photos to show you the options I have , so please respond ..

THANKS FOR HELPING ...

Drift4King 22nd July 2011 10:02 AM

LINKS
 
https://rapidshare.com/files/713394570/1.png

https://rapidshare.com/files/1762191484/2.png

adicoto 22nd July 2011 05:03 PM

From the top, the 9th is "use new subtitle parser/renderer"

Drift4King 22nd July 2011 10:37 PM

thanks alot
 
yes it worked but now its reserved , what to do ????

adicoto 23rd July 2011 07:22 AM

http://forum.bsplayer.com/bug-report...html#post43387

Seems that the bug is still present.:mad

Drift4King 23rd July 2011 09:20 AM

Ok . the only answer in this page was that to unselect the "use new subtitle passer render " and when I do this it turns to be the strange language again , and to change fonts and I tried every font there and it is still reversed , please help ...

adicoto 23rd July 2011 10:57 AM

Can you attach here a subtitle file ? I would like to test it on my computer. Thanks.

Drift4King 23rd July 2011 03:50 PM

I have used BS PLAYER to download it , and it worked with player classic

https://rapidshare.com/files/3394348...D_DTRG-ara.srt

Drift4King 23rd July 2011 03:55 PM

ANOTHER PROBLEM
 
I have another problem , didnt want to mention before , but I want to ask you about it after the subtitle one is resolved ..

Its about desktop mode which never works ...

adicoto 23rd July 2011 05:18 PM

Windows 7, aero enabled ?

Drift4King 24th July 2011 06:33 AM

What is aero ???

are you talking about the subtitle problem ???

please I want to solve the subtitle before any othe problem ..

do you have an email I can contact you on ??

yahoo , facebook , hotmail ???

adicoto 24th July 2011 11:01 AM

Usually you can find me on YM as adi_cotorogea@yahoo.com . If you want to add me specify please that you are drift4king.

Aero is window's interface introduced with Vista and developped under 7. It uses overlay so therefore, overlay rendering and Aero are incompatible.
Subtitle problem and desktop mode can be related.
I will install arabic support on my laptop to test the subtile.
Probably be back tomorrow.


All times are GMT +1. The time now is 01:06 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20