View Single Post
  #1 (permalink)  
Old 30th January 2009
Doujingai Doujingai is offline
BS.Player Newbie
Join Date: Jan 2009
Posts: 3
Rep Power: 0
Doujingai is an unknown quantity at this point
Default Automatic selection of audio stream

Can't get BS.Player to select any audio stream other than English automatically. (Regardless of the file or audio stream language lable)

AMD Phenom 8400
ATI Radeon HD 3200
DirectX 10

*BS.Player Pro 2.34 Build 980
*CoreAVC Pro 1.8.5
*K-Lite Codec Pack 4.5.3:
w/ FFDshow 2624
w/ Haali Media Splitter (I've tried Gabest
w/ DirectVobSub 2.39

I've set FFDshow to decode everything except H264.

Haali Media Splitter:
Languages>Audio Language Priority> "jpn,ja"
Languages>Subtitle Language Priority> "eng,en"
Languages>Audio and Subtitle Languages> "jpn,eng;ja,en"

Video>Video rendering>[uncheck]Wait for vertical blank
Rendering mode: Internal Renderer Overlay
Audio>[check]Use dedynamic filter
Audio>[uncheck]Use internal Vorbis decoder
Audio>Default audio stream> "1"
Audio>Default audio stream (lang code)> "jpn"
Subtitles>Subtitle properties>[check]Subtitles disabled
Subtitles>Vobsub>[uncheck]Enabled VobSub support
Filter Management>[check]Allow intermediate filters

Despite this combination of settings, BS.Player always chooses English as the default language on multi-stream MKV files (though ass/srt subtitles work perfectly). I tested the same files with Gabest to no success. I also tested the same files using Media Player Classic and was successful (Japanese was selected). Any suggestions? Otherwise I'm forced to use MPC for all multi-stream MKV files; that or select Japanese every episode. The files I'm using also have both English and Japanese clearly labelled.
Thanks in advance 8)
Reply With Quote

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20