Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > General Talk And Support

General Talk And Support General talk and peer-to-peer support about BS.Player and other video and audio multimedia players.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 30th January 2009
Banned
BS.Player Newbie
 
Join Date: Jan 2009
Posts: 3
Rep Power: 0
Doujingai is an unknown quantity at this point
Default Automatic selection of audio stream

PROBLEM~
Can't get BS.Player to select any audio stream other than English automatically. (Regardless of the file or audio stream language lable)


SYS INFO~
AMD Phenom 8400
ATI Radeon HD 3200
DirectX 10


PROGRAMS USED~
*BS.Player Pro 2.34 Build 980
*CoreAVC Pro 1.8.5
*K-Lite Codec Pack 4.5.3:
w/ FFDshow 2624
w/ Haali Media Splitter 1.9.42.1 (I've tried Gabest 1.0.3.0)
w/ DirectVobSub 2.39


SETTINGS CHANGED~
I've set FFDshow to decode everything except H264.

Haali Media Splitter:
Languages>Audio Language Priority> "jpn,ja"
Languages>Subtitle Language Priority> "eng,en"
Languages>Audio and Subtitle Languages> "jpn,eng;ja,en"

BS.Player:
Video>Video rendering>[uncheck]Wait for vertical blank
Rendering mode: Internal Renderer Overlay
Audio>[check]Use dedynamic filter
Audio>[uncheck]Use internal Vorbis decoder
Audio>Default audio stream> "1"
Audio>Default audio stream (lang code)> "jpn"
Subtitles>Subtitle properties>[check]Subtitles disabled
Subtitles>Vobsub>[uncheck]Enabled VobSub support
Filter Management>[check]Allow intermediate filters

Despite this combination of settings, BS.Player always chooses English as the default language on multi-stream MKV files (though ass/srt subtitles work perfectly). I tested the same files with Gabest to no success. I also tested the same files using Media Player Classic and was successful (Japanese was selected). Any suggestions? Otherwise I'm forced to use MPC for all multi-stream MKV files; that or select Japanese every episode. The files I'm using also have both English and Japanese clearly labelled.
Thanks in advance 8)
Reply With Quote
  #2 (permalink)  
Old 31st January 2009
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 21
Tizio will become famous soon enough
Default

Try to use the old style playlist (CTRL+P -> Playlist -> <select> Use old style playlist), and in the right panel, for every item of your playlist, select the audio stream number corresponding to the japanese stream and/or type jap (or japanese) in the other selection field

You can select all the items in the playlist and then assign the default audio stream in one single step.
Tell me if this makes it work, otherwise I think we can tag this as bug confirmed :roll:
__________________
BSP SkinMaker (v1.07) the one and only Skin Editor for BSplayer
BSP Definitions Manager (v1.02)
BS.Player's FAQ (by BSPeter) | Italian language file (v2.57 build 1051)
Reply With Quote
  #3 (permalink)  
Old 31st January 2009
Banned
BS.Player Newbie
 
Join Date: Jan 2009
Posts: 3
Rep Power: 0
Doujingai is an unknown quantity at this point
Default

Alright, I tried your idea.:) My results:
I set the playlist to load all files in the directory and upon opening a file the language that's in the audio stream field is "Eng". However; as soon as I select anything within the playlist, it switches to "jpn" and if I try to change it to anything else it defaults back to "jpn". Also when I try to type something into the audio stream field (within playlist) it acts as though I'm still within BS.Player; like J brings up jump to file and whatnot. Even with "jpn" being the selected language of the playlist I still get English as the default language and sometimes both Japanese and English are selected. (strange)

Here are some pictures of the default language. I made sure to skip to the next file to make sure the "jpn" was in effect:
(I couldn't manage to capture the actual video)
http://img140.imageshack.us/img140/3618/gtofa1.jpg
http://img502.imageshack.us/img502/6...omartiedq9.jpg
http://img156.imageshack.us/img156/267/ippoaa9.jpg
Reply With Quote
  #4 (permalink)  
Old 31st January 2009
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 21
Tizio will become famous soon enough
Default

And what happens if you select 2 as the default audio stream in playlist right panel?
Select all your files in playlist (use CTRL+Click or SHIFT+Click to do the multiple selection), and in the audio stream drop down boxes select 2 (since the japanese audio is the second stream and instead in your playlist preferences the default value is 1) and digit Japan (instead of only jpn)
Hope this works, otherwise as I've written in my previous post this will be added to the confirmed bugs
__________________
BSP SkinMaker (v1.07) the one and only Skin Editor for BSplayer
BSP Definitions Manager (v1.02)
BS.Player's FAQ (by BSPeter) | Italian language file (v2.57 build 1051)
Reply With Quote
  #5 (permalink)  
Old 31st January 2009
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

A link to a file ? Or to a sample of such a file ?
If it's a torrent, post it by PM
Reply With Quote
  #6 (permalink)  
Old 31st January 2009
Banned
BS.Player Newbie
 
Join Date: Jan 2009
Posts: 3
Rep Power: 0
Doujingai is an unknown quantity at this point
Default No luck

Tizio; tried again with 2 / Japan, and no luck.:?
adicoto; I PM'ed the torrent.

http://img300.imageshack.us/img300/8336/retestdn6.jpg
Reply With Quote
  #7 (permalink)  
Old 31st January 2009
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 21
Tizio will become famous soon enough
Default

@adicoto
If after the test you can confirm this behavior please move this topic to the bug section and add a [CONFIRMED] tag before the topic title
Thanks ;)
__________________
BSP SkinMaker (v1.07) the one and only Skin Editor for BSplayer
BSP Definitions Manager (v1.02)
BS.Player's FAQ (by BSPeter) | Italian language file (v2.57 build 1051)
Reply With Quote
  #8 (permalink)  
Old 31st January 2009
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

Thanks, will do it.
Reply With Quote
  #9 (permalink)  
Old 31st January 2009
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

Quote:
Also when I try to type something into the audio stream field (within playlist) it acts as though I'm still within BS.Player; like J brings up jump to file and whatnot.
Confirmed. At least copy-paste can be used.
Reply With Quote
  #10 (permalink)  
Old 31st January 2009
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

File incomplete yet, but started testing. When opened for the first time, english was default audio ;)
OK. If you select english as audio stream when playing the file, the file plays english. If you open the playlist and modify the audio as JA (not jpn or jap or.....) then if you double click on the list, the file opens with japanese audio. I will download at least 2 files then to see what's up if I do have a playlist and confirm the rest.
Reply With Quote
  #11 (permalink)  
Old 31st January 2009
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

Now, in BSPlayer audio preferencies, my settings were 1 / eng as default language. After selecting 2 and JA, the file opened with japanese audio. Now, if I select english in audio streams, I get english audio. I close the file with english audio. I open the file, japanese audio it's active. So, audio preferencies override anything else. I don't know what will happen when you have double audio streams but none it's english or japanese, what BSPlayer will select.

I believe that this is a feature and not a bug, to select the audio that the user declared as important and not the one that it's defined as default into the container.
Reply With Quote
  #12 (permalink)  
Old 31st January 2009
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

Audio preferencies
Attached Images
File Type: png japanese_audio_default_594.png (102.4 KB, 174 views)
Reply With Quote
  #13 (permalink)  
Old 29th August 2010
Junior Member
BS.Player Newbie
 
Join Date: Dec 2009
Posts: 2
Rep Power: 0
Smokey is on a distinguished road
Exclamation

I think i have the same problem.
Whenever i open a video file with 2 audio streams, BSplayer always plays the first audio stream regardless of any settings.

I am using:
Windows 7 Ultimate
BSplayer 2.56 build 1043
FFdshow audio and video decoders
Haali media splitter
DirectVobSub
.OGM .MP4 and .MKV files

I have tried:
<1> Changing the "default audio stream" and (lang code) option in preferences -> audio with no result. I have tried the following lang codes with "default stream" 1 to 5 (all combinations):
"jpn" "jap" "jp" "ja" "japan" "japanese" "und" and empty lang code. (without quotes of course)
I also tried changing the track and lang code in the playlist.

<2> Changing the "audio language priority" option to jpn in Haali media splitter. This did work in WMP 12, but had no effect on BSplayer.

<3> Using the plug-ins that are supposed to change the audio track upon starting playback. (links to plug-ins)
Audio tracks <- Only made "Stream 1" appear in the OSD when playing .OGM files, (normally i would have to press cycle streams twice to get the second audio stream in .OGM files) but did nothing in other files.
Plugin to set default audio stream and subtitle <- Did nothing at all and didn't save any settings changed in the plug-in configuration.

<4> Remuxing. I remuxed some files so that the Japanese audio track would appear as the first track. This worked, but i'm not going to remux all my files one at a time.

<5> Finally i tried the Gabest splitter. While this worked, Gabest doesn't allow me to set the default subtitles track with DirectVobSub.
Compared to Haali, Gabest is crap. It doesn't allow you to set anything.
(If you are wondering why i'm not using the built-in subtitles renderer, read this topic: Built-in subtitles renderer?)

Conclusion: BSplayer always plays the first audio stream when using Haali.
I have no idea why this happens, but it is quite annoying.
I really like BSplayer because it has many hotkeys, its fast, its easy to find subtitles and it can be customized in many ways. As far as i know, there isn't another player out there with these options. (if you know one, please let me know )

PS: this problem dates back to 2005?
How to make Japanese default audio stream?
Default OGM Audio Stream
Default audio stream selection, v2.30
This is a bug and needs fixing
Reply With Quote
Reply

Tags
audio, automatic, selection, stream

Thread Tools
Display Modes

Posting Rules


All times are GMT +1. The time now is 04:30 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19