Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Bug Reports And Codecs (http://forum.bsplayer.com/bug-reports-codecs/)
-   -   BS Player plays video file as audio file...please help! (http://forum.bsplayer.com/bug-reports-codecs/12339-bs-player-plays-video-file-audio-file-please-help.html)

hjwessels 4th September 2011 11:01 PM

BS Player plays video file as audio file...please help!
 
Hi

I've struggled for weeks with this matter and after many hours trawling through the internet still can't solve it, so I'm turning to the experts. I'm a first-time poster, so please bear with me if I don't follow all the rules. I'm sure the information I make available will not be complete, so if you could let me know what additional information you require to help (and how to get it) I'd be more than happy to provide...

Symptoms:

My problem is that BS Player plays certain AVI files as audio files, as if it's an mp3 file. I know they are valid video files, and they work fine when I play them with any other player (Windows Media Player, VLC Media Player, Nero Show Time, etc), but of course I much prefer to use BS Player. The problem affects only AVI files (all other formats play fine) but not all AVI files. The problem also only happen once I have installed the latest DivX codes onto my PC. If I uninstall DivX altogether, the same AVI files play just fine on BS Player. Also, right-clicking on BS Player shows video disabled. When playing the files on BS Player, the file name which appears on the BS Player window shows a .m2ts extension...not one I'm familiar with and I'm not sure that it's only .m2ts files that are affected (besides, Windows shows the extension as .AVI)

The closest I have come across another post on the same issue is on this link:

http://forum.bsplayer.com/general-ta...-no-video.html

However, the post seems to be unresolved and I'm none the wiser myself despite following the recommended actions.

I have set BS Player to play all file types, and I have tried every single rendering mode available but none of them solves the problem.

I have BS Player PRO version 2.57 installed, Build 1051, 8 December 2010 (I receive an "up to date" version message when checking for new versions).

I run Windows 7 Home Premium on my PC.

I really need DivX codecs for other video editing and equally I don't want to give up using BS Player as my default player.

Can anyone help please? Any information much appreciated and I'll try to answer questions as best I can...

Thank you in advance!

BSPeter 5th September 2011 02:45 AM

Did you already try to blacklist DivX codec in BS.Player's filter manager?
(rightclick >) Options > Preferences > Filter management > [Blacklist/Whitelist]
:wink:

adicoto 5th September 2011 05:57 AM

If DivX decoder filter interacts and doesn't play well your AVI files, either assign MPEG4 to DivX decoder or to ffdshow. For example, open XviD properties and check the boxes for all MPEG4 and instead loading DivX decoder, BSPlayer will use XviD decoder, which, at least for me works OK with all avi MPEG4 files.

uge7 26th October 2011 09:37 PM

Audio file No video file
 
I have same problem, Bs player plays my avi file as Audio file and no video is shown

BSPeter 26th October 2011 10:57 PM

Maybe it looks like same problem, but you provide considerably less info.
OS? BS.Player version/build?
This problem is valid for any avi-file? It has never functioned before?
I hope you didn't install any codec-packs?
When you installed BS.Player, did you allow it to internally install its preferred codecs (for use only by BS.Player and not interfering with your system's codecs/filters)?
:wink:

geongu 10th March 2012 03:22 AM

hello !

I have BSPlayer PRO 2.61

and I have video, but no sound with .MOV and rmvb

adicoto 10th March 2012 05:04 AM

Do you use internal codecs downloaded by BSPlayer ?
As far as I know, there is still a problem with Big Endian audio streams (usually found in MOV files)

See here: http://forum.bsplayer.com/answered-s...-filter-2.html

carlosvalinhas 21st January 2017 09:52 PM

I followed your sugestion and got the image but the sound is missing!


All times are GMT +1. The time now is 07:48 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20