Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 4th September 2011
Junior Member
BS.Player Newbie
 
Join Date: Sep 2011
Posts: 1
Rep Power: 0
hjwessels is on a distinguished road
Red face BS Player plays video file as audio file...please help!

Hi

I've struggled for weeks with this matter and after many hours trawling through the internet still can't solve it, so I'm turning to the experts. I'm a first-time poster, so please bear with me if I don't follow all the rules. I'm sure the information I make available will not be complete, so if you could let me know what additional information you require to help (and how to get it) I'd be more than happy to provide...

Symptoms:

My problem is that BS Player plays certain AVI files as audio files, as if it's an mp3 file. I know they are valid video files, and they work fine when I play them with any other player (Windows Media Player, VLC Media Player, Nero Show Time, etc), but of course I much prefer to use BS Player. The problem affects only AVI files (all other formats play fine) but not all AVI files. The problem also only happen once I have installed the latest DivX codes onto my PC. If I uninstall DivX altogether, the same AVI files play just fine on BS Player. Also, right-clicking on BS Player shows video disabled. When playing the files on BS Player, the file name which appears on the BS Player window shows a .m2ts extension...not one I'm familiar with and I'm not sure that it's only .m2ts files that are affected (besides, Windows shows the extension as .AVI)

The closest I have come across another post on the same issue is on this link:

BSPLayer plays avi files as audio -- no video

However, the post seems to be unresolved and I'm none the wiser myself despite following the recommended actions.

I have set BS Player to play all file types, and I have tried every single rendering mode available but none of them solves the problem.

I have BS Player PRO version 2.57 installed, Build 1051, 8 December 2010 (I receive an "up to date" version message when checking for new versions).

I run Windows 7 Home Premium on my PC.

I really need DivX codecs for other video editing and equally I don't want to give up using BS Player as my default player.

Can anyone help please? Any information much appreciated and I'll try to answer questions as best I can...

Thank you in advance!
Reply With Quote
  #2 (permalink)  
Old 5th September 2011
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Did you already try to blacklist DivX codec in BS.Player's filter manager?
(rightclick >) Options > Preferences > Filter management > [Blacklist/Whitelist]
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #3 (permalink)  
Old 5th September 2011
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

If DivX decoder filter interacts and doesn't play well your AVI files, either assign MPEG4 to DivX decoder or to ffdshow. For example, open XviD properties and check the boxes for all MPEG4 and instead loading DivX decoder, BSPlayer will use XviD decoder, which, at least for me works OK with all avi MPEG4 files.
Reply With Quote
  #4 (permalink)  
Old 26th October 2011
Junior Member
BS.Player Newbie
 
Join Date: Oct 2011
Age: 60
Posts: 1
Rep Power: 0
uge7 is on a distinguished road
Default Audio file No video file

I have same problem, Bs player plays my avi file as Audio file and no video is shown
Reply With Quote
  #5 (permalink)  
Old 26th October 2011
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Maybe it looks like same problem, but you provide considerably less info.
OS? BS.Player version/build?
This problem is valid for any avi-file? It has never functioned before?
I hope you didn't install any codec-packs?
When you installed BS.Player, did you allow it to internally install its preferred codecs (for use only by BS.Player and not interfering with your system's codecs/filters)?
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #6 (permalink)  
Old 10th March 2012
Junior Member
BS.Player Newbie
 
Join Date: Apr 2010
Age: 63
Posts: 1
Rep Power: 0
geongu is on a distinguished road
Default

hello !

I have BSPlayer PRO 2.61

and I have video, but no sound with .MOV and rmvb
Reply With Quote
  #7 (permalink)  
Old 10th March 2012
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

Do you use internal codecs downloaded by BSPlayer ?
As far as I know, there is still a problem with Big Endian audio streams (usually found in MOV files)

See here: No sound and old AC3 Filter
Reply With Quote
  #8 (permalink)  
Old 21st January 2017
Junior Member
BS.Player Newbie
 
Join Date: Jan 2017
Posts: 1
Rep Power: 0
carlosvalinhas is on a distinguished road
Default

I followed your sugestion and got the image but the sound is missing!
Reply With Quote
Reply

Tags
audio, codec, divx, file, player, plays, video

Thread Tools
Display Modes

Posting Rules

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rendering Problem Ringola General Talk And Support 10 10th May 2008 04:33 PM
Can't play 640x480 wmv NTuser General Talk And Support 12 23rd August 2005 01:49 AM


All times are GMT +1. The time now is 09:01 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19