Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 30th June 2002
Junior Member
BS.Player Newbie
 
Join Date: Jun 2002
Posts: 2
Rep Power: 0
hans_david is an unknown quantity at this point
Default Vobsub subtitle problem

Hello.

I got problem when using BSPlayer with DVobsub. I open the video. BSPlayer detects that there is a corresponding .sub file available. I press the play button and the following errorlog comes up:

----------------------------------------------------------------
BSPlayer v0.85.488, Unhandled exception at EIP: 011D53D4
Application will be terminated.
Please report this info to the author with description what were you doing.
Invalid floating point operation
EInvalidOp
, 0x004B289F, 0x004B2B01, 0x004520AF, 0x0044971A, 0x77D43A5F, 0x77D43B2E, 0x77D43D6A, 0x77D441FD, 0x004C382F, 0x77E7EB69

Bytes at EIP: DC 5C 24 14 DF E0 F6 C4 44 7A 11 57 FF 15 64 70 1F 01
----------------------------------------------------------------

I have DVobSub v.2.16.

Do you have any tips. I have tried the BSplayer debug version but I cannot find any log files.

Playing movies goes ok without DVobSub. I have to use the force RGB mode. The mode 1 and 2 is only black.

This is an excelent software. Please keep up the good work!!!

Best regards, Hans-David
Reply With Quote
  #2 (permalink)  
Old 1st July 2002
Quietseb's Avatar
Senior Member
BS.Player Power User
 
Join Date: Jun 2002
Location: back in France...
Posts: 581
Rep Power: 0
Quietseb is an unknown quantity at this point
Default

downgrading to vobsub 2.14 helps ... I don't know where it's still available so I put it on my ftp server
Reply With Quote
  #3 (permalink)  
Old 1st July 2002
Junior Member
BS.Player Newbie
 
Join Date: Jun 2002
Posts: 2
Rep Power: 0
hans_david is an unknown quantity at this point
Default

Thanks for the tips. I have downgraded to version 2.14 and now everything works ok.

What is the problems with the new DVobSubs (version 2.16)?

Regards, Hans-David
Reply With Quote
  #4 (permalink)  
Old 9th July 2002
Junior Member
BS.Player Newbie
 
Join Date: Jul 2002
Posts: 1
Rep Power: 0
wotef is an unknown quantity at this point
Default

hi, i confirm an almost identical error message when playing an xvid file with directvobsub 2.15 (w2k sp2, gf4 ti4200 detonator 29.42)

BSPlayer v0.85.488, Unhandled exception at EIP: 0049671A
Application will be terminated.
Please report this info to the author with description what were you doing.
Access violation at address 0049671A in module 'bplay.exe'. Read of address 00000000
EAccessViolation
, 0x004B289F, 0x004B2B01, 0x004520AF, 0x0044971A, 0x77E11B60, 0x77E11CCA, 0x77E183F1, 0x004C382F, 0x77E8D326

Bytes at EIP: 8B 00 FF 50 0C 8B C3 E8 36 C0 F6 FF 8B 45 C8 50 6A 00

the same movie and subs plays fine with WMP 7.1
Reply With Quote
  #5 (permalink)  
Old 14th July 2002
Junior Member
BS.Player Newbie
 
Join Date: Jul 2002
Posts: 2
Rep Power: 0
pistachios is an unknown quantity at this point
Default

A temporary solution is:
In DirectVobSub Properties, check "Force RGB", and set "use overley" to "mode 2" in BSPlayer.
When play avi in BSPlayer, a warning of "Overlay failed" will display, and then it tries to use RGB mode, you can see the movie with subtitles as usual.
Reply With Quote
  #6 (permalink)  
Old 22nd July 2002
Junior Member
BS.Player Newbie
 
Join Date: Jul 2002
Posts: 7
Rep Power: 0
techguru is an unknown quantity at this point
Default

The temporary solution presented above does indeed work, but performance is anything but good!! I can't play movies with this type of performance (all the conversions going on?)

Will the be a fix for this? BSPlayer is a top player, but I need dvobsub support... And 2.16 is what I want, not 2.14. =)
Reply With Quote
  #7 (permalink)  
Old 24th July 2002
Junior Member
BS.Player Newbie
 
Join Date: Jul 2002
Posts: 2
Rep Power: 0
pistachios is an unknown quantity at this point
Default

I don't feel anything wrong with this mode, BTW, my computer is: P4 1.6G, GeForce2 DDR.

I think you may try this:
First, you should do the same thing as I said before.
while the movie is playing, uncheck "Force RGB" in DVobSub, and then switch "Use overley mode 2" to "mode 1", the movie and DVobSub are both reloaded, but it will not crash. If you like, you can swith to "mode 2" again.
After that, DVobSub does not load the subtitles again, you should open the subtitles in DVobSub properties dialog manually.
All have done.
Reply With Quote
  #8 (permalink)  
Old 26th July 2002
Junior Member
BS.Player Newbie
 
Join Date: Jun 2002
Posts: 6
Rep Power: 0
ChAoS Overlord is an unknown quantity at this point
Default

I acknowledge having the very same problem.
Reply With Quote
  #9 (permalink)  
Old 3rd August 2002
Junior Member
BS.Player Newbie
 
Join Date: Aug 2002
Posts: 1
Rep Power: 0
SatCP is an unknown quantity at this point
Default

This issue seems to be fixed in the just released BSPlayer 0.85 build 490.
Reply With Quote
Reply

Tags
subtitle, vobsub

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 11:48 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20