Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 11th November 2003
Senior Member
BS.Player Power User
 
Join Date: Nov 2002
Posts: 125
Rep Power: 0
bond is an unknown quantity at this point
Default overlay mode2/overlay mixer problems

great that bsplayer now supports the overlay mixer filter, as this will allow playing realmedia files with gabest realmedia directshow splitter whitout choppy playback but

it seems to be a little bit buggy as it only shows a black picture when chosen :(

btw. seems that you decided to add video stream switching, great :)

ps: one wish: can you plz change the manual pan scan gui back to the old version, imho it looked nicer

btw: great player :)
Reply With Quote
  #2 (permalink)  
Old 12th November 2003
LotharZ
BS.Guest
 
Posts: n/a
Default

Similar problem here, but was already reported with old versions:

http://forum.bsplayer.org/viewtopic....ht=ati+overlay

ive been testing with different combinations and found that lastest ATI drivers with:

-FFDshow codecs:
Overlay mode1 = no overlay mode enabled (surface type = YV12 DR), and dark colors.
Overlay mode2 = black image (surface type = UNKN), colors can be reset to normal mode with overlay controls of ATI control panel, but return to black if you open/close/change grafic settings of a movie.

-Other codecs:
Overlay mode1 = no overlay mode enabled (surface type = YV12 DR), and dark colors.
Overlay mode2 = works ok with correct colors and overlay enabled (surface type = UNKN)

behaviour with RGB and VMR-9 is same with all codecs, no overlay mode and darker colors.
All confings are tested under Win2K and 2K3, the only temporal solution that ive found is run my videos with WMP9 that is giving me better color quality but sadly without all the extra options of bsplayer and sometimes crashing like hell ><
Ill really apreciate if you can fix this bug that seems only affect ATI users with lastest divers version and ffdshow.

thx
Reply With Quote
  #3 (permalink)  
Old 28th November 2003
Senior Member
BS.Player Power User
 
Join Date: Nov 2002
Posts: 125
Rep Power: 0
bond is an unknown quantity at this point
Default

hi bst

ok, first of all great that you implemented the option to use the "overlay mixer" in bsplayer, cause now no frames are dropped anymore when playing realvideo/realmedia streams :)

also the black picture problem is solved

but there seems to be another problem:
i now get choppy playback when using the overlay mixer (no frames are reported as dropped tough)
this doesnt only happen with real streams but also with others, so it isnt caused by gabests real splitter...


btw two usability proposals:
1) perhaps its a good idea to move the "video info" tab from "options" to "video", i think it fits better there
2) perhaps its a good idea to use the old interface for custom panscan again (it really looked much better than the new "windows style" one imho)

thanks :)
Reply With Quote
Reply

Tags
mixer, mode2 or overlay, overlay

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 11:19 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20