Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 10th January 2015
Junior Member
BS.Player Newbie
 
Join Date: Jan 2015
Posts: 3
Rep Power: 0
jorro is on a distinguished road
Exclamation [bsplayer 2.68] [Windows 8.1] unicode filenames can't be open

Unicode filenames can't be open with bsplayer 2.68 on Windows 8.1.
Current lang for non-Unicode programs is set to Bulgarian (cyrillic).
Example file name: Основи на уеб технологиите.mp4
If renamed with latin chars, everything works fine - the player plays the file.
The problem was not present with the bsplayer 2.66.
Please, advise.
Reply With Quote
  #2 (permalink)  
Old 10th May 2015
Junior Member
BS.Player Newbie
 
Join Date: Jan 2015
Posts: 3
Rep Power: 0
jorro is on a distinguished road
Default Not fixed

Same with the new version: 2.69.1078
The problem wasn't fixed.
Anyone has a solution?
Or at least workaround?
Reply With Quote
  #3 (permalink)  
Old 29th June 2016
Junior Member
BS.Player Newbie
 
Join Date: Jun 2016
Posts: 2
Rep Power: 0
PatrickA is on a distinguished road
Default Windows 8+BS Player+Unicode=Problems

Hello friends!

For those who cannot open unicode filename, try this:

1. Open Regedit.
2. Go to : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\FileSystem
3. Look for: NtfsDisable8dot3NameCreation
4. Change value to 0.
5. Copy again the file you want to open. Try to open this file.
6. If the problem persist, restart your PC. and retry step 5.

It's a windows 8 update bug.
Reply With Quote
  #4 (permalink)  
Old 29th June 2016
Junior Member
BS.Player Newbie
 
Join Date: Jan 2015
Posts: 3
Rep Power: 0
jorro is on a distinguished road
Smile Not working... still

Quote:
Originally Posted by PatrickA View Post
Hello friends!

For those who cannot open unicode filename, try this:

1. Open Regedit.
2. Go to : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\FileSystem
3. Look for: NtfsDisable8dot3NameCreation
4. Change value to 0.
5. Copy again the file you want to open. Try to open this file.
6. If the problem persist, restart your PC. and retry step 5.

It's a windows 8 update bug.
Thank you.
Unfortunately with me your solution doesn't work.
My Win is installed on the SSD and the files are located on the HD.
Reply With Quote
  #5 (permalink)  
Old 22nd November 2016
Junior Member
BS.Player Newbie
 
Join Date: Jun 2016
Posts: 2
Rep Power: 0
PatrickA is on a distinguished road
Default

Quote:
Originally Posted by jorro View Post
Thank you.
Unfortunately with me your solution doesn't work.
My Win is installed on the SSD and the files are located on the HD.
Hi!, it's a partial solution.
I realized that it works if the file path have no unicode names either.
Does not matter where the file is. it is file name or the file path that makes the problem. Even on 2.70 version over win10.

if there is only unicode filename. it should works setting the NtfsDisable8dot3NameCreation value to 0 and copying the file to any place to regenarate short filenames. That is the real problem, i think.
some apps needs the old short filename system.

check your file path and change it to non-unicode names.
Reply With Quote
  #6 (permalink)  
Old 2nd June 2018
Junior Member
BS.Player Newbie
 
Join Date: Jun 2018
Posts: 1
Rep Power: 0
Hesiris is on a distinguished road
Default Another workaround

I had the same issue (just with Japanese characters)

There are two solutions 1 - quick, but may have side-effects; 2 - longer, but no side-effects

1.:
The somewhat counter-intuitive way of doing it is to change system locale to English. If you only use non-Unicode software in English, you might not actually need the locale set to your language.
Note that this will not affect display language, but non-Unicode applications will display gibberish instead of proper characters.

Go to Control Panel -> Clock and Region -> Region -> Administrative (tab) -> Change System Locale (under Language for non-Unicode programs) -> select English. You will be prompted to restart. Do so.
The files should open normally after the restart.

The obvious disadvantage is that if you have non-unicode installers and programs, this might cause an issue. If it does, simply change it back to the previous language.

2:
Download a program that can do this for a single application, like Locale Emulator ( pooi.moe/Locale-Emulator/ ), but it will take a bit of work. Please read through the instructions before starting!

a. Install it. Restart Windows Explorer: Task Manager->Windows Explorer->Restart
b. Navigate to the BS Player Installation directory (C:/Program Files (x86)/Webteh/BSPlayer by default).
c. Give yourself control over it: Right click->Properties->Security->Edit->Administrators->Full Control
d. Inside the folder, right click on the bsplayer.exe and select Locale Emulator->Modify Application Profile. Set Location to English and click Create Shortcut. A shortcut will be created on your Desktop.
e. Right Click the shortcut and copy the contents from "Target". You can delete this shortcut after you finish
f. Go back to the BSPlayer folder and create new text file. Paste what you have copied from the shortcut and save it as a batch file, e.g. "bsplayer.bat" (make sure you have "all files" selected in the save file dialog and are not saving it as bsplayer.bat.txt)
g. Right click your media file of choice and set this batch file as the default program to open the media files.
f. Start a media file. It will not be loaded automatically, but if you drag the media file onto it, it will work

The drawback is that it you can't just click-and-play, you need to click-drag-and-play. Also, setting the icons back is a bit tricky.

If someone knows how to make Locale Emulator pass the arguments it receives on, leave a reply (I tried setting %* as arguments, but it didn't work)
Reply With Quote
Reply

Tags
268, filenames, non-unicode, open, unicode, windows

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 12:28 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19