Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Bug Reports And Codecs (http://forum.bsplayer.com/bug-reports-codecs/)
-   -   Subtitle Bugs in 803 (http://forum.bsplayer.com/bug-reports-codecs/3338-subtitle-bugs-803-a.html)

r_hawke 1st December 2003 01:30 PM

Subtitle Bugs in 803
 
When checking "Subtitles disabled" Player crashes when opening an OGM containing Subtitle.


BSPlayer v1.00.803, Unhandled exception at EIP: 00495C05
If you click 'Close' application will be terminated.
Please report this info to the author with description what were you doing.
Access violation at address 00495C05 in module 'bsplay.exe'. Write of address 00000010
EAccessViolation
, 0x004E746F, 0x004E766D, 0x00453527, 0x0044A872, 0x77E02CA8, 0x77E052E6, 0x77E06487, 0x717521F0, 0x7175276F, 0x71752574, 0x7172C11B, 0x7175276F, 0x71752643, 0x77E02CA8, 0x77E02DC5, 0x77E0577D, 0x004E8584, 0x77E787F5


- Possibility to check "Dont' show Subtitle by default"

- Remove subtitle from Screen if Show subtitle is turned off (it always stays until i toggle full-screen)

- DoubleClick for Full-Screen toggle (used to work in 0.85) I can't assign it manually, BsPlayer recognizes DblClick as Left-Klick + Wheelclick

KHysiek 3rd December 2003 09:41 PM

I add from myself to list that since 1.0 BSPlayer is ignoring "Max subtitles display time" setting

r_hawke 4th December 2003 11:49 AM

Bug 2:

French subtitles do not work either. All ?•, ?© and Ä? are simply left out!

With VobSub it is actually no problem.

Robert

Drizzt 4th December 2003 07:40 PM

I have a matroska file with hungarian sub and if I enable subtitles instead of the national characters like ű,?©,ő (hope you can see it :) ) bsplayer displays the two byte unicode characters (for example instead of erős sg like ern??s). If I turn off subtitles bsPlayer crashes...

r_hawke 5th December 2003 01:54 PM

yeah, matroska files are treated correctly because they can contain unicode whereas OGM doesn't

but i thought that the french letters ?© Ä? ?• are still ANSI(0), which also should work. At least they work with VobSub as said before.

HackerWerger 5th December 2003 11:59 PM

The italics don't load correctly in .sub/.srt subtitle files..
Stupid bug.. :evil:

BSPeter 6th December 2003 12:18 AM

Quote:

Originally Posted by r_hawke
French subtitles do not work either. All ?•, ?© and Ä? are simply left out!

No, they do work and they aren't left out!
Quote:

Originally Posted by r_hawke
but i thought that the french letters ?© Ä? ?• are still ANSI(0), which also should work.

Yes, you're right and they do work!

Same old "problem" probably as with BSPlayer's previous version. Have a look here (2nd item).
:wink:

HackerWerger 6th December 2003 01:00 PM

More bugs!! :evil:
StartTime=X doesn't work in ini files of BSplayer v1.0 803.. :cry:

masa 6th December 2003 06:47 PM

My BsPlayers subtitles dont work with .srt files. With .sub files it works. It worked before but not anymore. I have installed player again but it dont work. I downloaded wobsub but it didnt help. So what can I do?

masa 6th December 2003 09:51 PM

Correction to previous:
.sub files dont work either. Only in one film that I have subtitles work but not in any other film. Wether its .srt or .sub file.

masa 6th December 2003 09:53 PM

Correction to previous:
.sub files dont work either. Only in one film that I have subtitles work but not in any other film. Wether its .srt or .sub file.

BSPeter 7th December 2003 12:48 AM

@masa
Perhaps your subtitles are placed "off screen".
Try setting of subtitles position to "auto" (and e.g. change color)
Any result?
If not, check setting of "Subtitles disabled" (under "Options"/"Preferences"/"Subtitles") and setting of "Draw subtitles to Overlay surface" under "Options"/"Preferences"/"Video" and (also under "Video") perhaps try a different setting of overlay mode (mode 1 or no overlay).
:wink:

muttley 7th December 2003 04:12 PM

latest build DON'T REMEMBER SUBTITLE POSITION
 
why is that?
when i manually set where the subtitle will apper (-50 my favourite), it completely ignores it next time i load the movie

BSPeter 7th December 2003 05:20 PM

Is the box "Remember movie settings" under "Options"/"Preferences"/"General" checked (=selected) in your installation?
:wink:

muttley 8th December 2003 02:03 AM

yep it is checked
 
that option is checked and the subtitle still appears in default position, not the customed one.
and another thing - if the movie was played in fullscreen (and the player remembers the settings) for a 16:9 movie the next time will be 'streched' all over the screen and u have to get out of fullscreen and back in to get it fixed

masa 8th December 2003 10:19 PM

Okay. If I use overlay 1 (preferences/video) and movie is dvdrip (all my movies are .avi files) subs are shown normally and the picture is fitted automaticly to my tv screen and I can browse net at my pc screen while movie is played at tv. If overlay 1 and movie other than dvdrip subs are this black and white dots. Their fuzzy. U cant read them. If I use other overlay than overlay 1 or dont use overlay at all (pref/video) subs are shown normally but picture isnt fitted to my tv screen. Meaning that I cant browse net or something else at the same time.

Movies that arent dvdrips and was working normally before dont work anymore. I just cant understand why. I didnt make any changes to anything but they just dont work anymore!!?? :cry:

masa 8th December 2003 10:20 PM

Allmost forgot. I did try U'r hints but non of them workd...

masa 9th December 2003 02:43 AM

now I lookd a film that wasnt dvdrip but subs was dvdrip and it work normally????

Laurent 20th December 2003 08:25 AM

Subdelay defined in .ini files doesn't work (works if defined manually during movie playing).

Regards.

dkong 14th January 2004 05:55 PM

Since I have experienced the same �loss of subtitle position problem’ as some of you appear to have I tried some things to circumvent this problem. Unsuccessful I might ad but I found a few things to narrow down the problem, first it only seems to appear with negative subtitle position numbers. (These are especially handy when you watch widescreen movies and want to keep the subtitles underneath the actual picture). In a 4:3 movie the subtitles have to appear in the video (position >= 0) and then there’s no problem. I can put them easily I the right position using shift-up/down keys and they stay there right where they’re suppose to be. However when the position is less then zero this setting is lost when the movie is restarted. Setting the �remember movie settings’ option makes no difference. When the position is above zero then these settings are remember. Bsplayer does not seem to permit me to put the subs above the movie. The autosetting for subtitles is remember and in a widescreen movie the position is below zero. But it’s either too far down (which makes it partially outside the screen on tv’s) or a line is half in and half below the movie which is annoying to watch. Using a ini does not help me since the SubPos options is specified like this: �SubPos is subtitle position, if it's <=0 or not defined then subtitles will be positioned automatically’. This is might be a related problem/feature. There’s probably a pragmatic reason for this limitation but I would greatly appreciate it if this would be done differently in future releases. I use RC1 build 803 with the ffdshow filter, without any vobsub program. The previous release I used (0.86.499) did not have this problem but is missing some nice features, so going back is not a good option. The rest of the (new) program work very well for me, thanks for that. Now that’s said there’s always the possibility that I overlooked something so if anybody has a solution or usable workaround it would be greatly appreciated.


All times are GMT +1. The time now is 10:46 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20