Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 31st December 2003
Junior Member
BS.Player Newbie
 
Join Date: Dec 2003
Posts: 4
Rep Power: 0
jang0 is an unknown quantity at this point
Default Bugs concerning OGM Subtitles (v.1.00 build 803)

First of all great work, I love BSPlayer.
However I still encounter some bugs using subtitles in OGM format:

1. It's an OGM file which has 2 subtitles: "German" and "Commentary". In the subtitle list where I can change the subtitles, there is "Sub 1", "German" and "Commentary". "Sub 1" is activated by default, and it is the same as "German", the primary subtitle of the file. Don't know if it's supposed to be a feature or a bug.

2. When choosing "Sub 1", all characters are displayed fine (only if I set character script to Central European in the OGG Subtitle Mixer DS Filter AND in the font options of BSPlayer), but when choosing "German" or "Commentary", the german "Umlauts" like ?¤, ?¶, ?? (ae, oe, ue) and ?? aren't displayed at all. They are just omitted. This happens both with and without "Use subtitle Mixer for subtitles in OGG" checked in the BSPlayer. Generally, this option doesn't seem to make any difference.

The interesting thing is: when I use "western" as a character script in the OGG Subtitle Mixer, the same problem also appears with "Sub 1". This is again independent from the "Use subtitle Mixer for subtitles in OGG" in BsPlayer.

3. Clicking on "Manual correction" in subtitle menue throws the following exception:

BSPlayer v1.00.803, Unhandled exception at EIP: 004CEF14
If you click 'Close' application will be terminated.
Please report this info to the author with description what were you doing.
Invalid floating point operation
EInvalidOp
, 0x004E746F, 0x004E766D, 0x00453527, 0x0044A872, 0x77E2A2D0, 0x77E045E5, 0x77E05B51, 0x004E8584, 0x77E987E7

Bytes at EIP: D8 30 E8 C1 3C F3 FF 89 45 F0 89 55 F4 8D 45 E8 50 8D
Reply With Quote
  #2 (permalink)  
Old 1st January 2004
KV KV is offline
Junior Member
BS.Player Newbie
 
Join Date: Jan 2004
Posts: 2
Rep Power: 0
KV is an unknown quantity at this point
Default

can't play ogm files

here is the error message:

BSPlayer v1.00.803, Unhandled exception at EIP: 0049C7B1
If you click 'Close' application will be terminated.
Please report this info to the author with description what were you doing.
Access violation at address 0049C7B1 in module 'bsplay.exe'. Read of address 6E656C69
EAccessViolation
, 0x004E746F, 0x004E766D, 0x00453527, 0x0044A872, 0x77D67AD7, 0x77D6CCD4, 0x77D44455, 0x77D44D58, 0x004E8584, 0x77E814C7

click continue:
Bytes at EIP: 8B 10 FF 52 14 48 85 C0 0F 8C 8A 00 00 00 40 89 C3 C7
Reply With Quote
  #3 (permalink)  
Old 1st January 2004
KV KV is offline
Junior Member
BS.Player Newbie
 
Join Date: Jan 2004
Posts: 2
Rep Power: 0
KV is an unknown quantity at this point
Default

old version 0.86 works fine.
Reply With Quote
  #4 (permalink)  
Old 1st January 2004
Junior Member
BS.Player Newbie
 
Join Date: Dec 2003
Posts: 4
Rep Power: 0
jang0 is an unknown quantity at this point
Default

I got another bug with my OGM file:

When turning on the Overlay mode for subtitles in BSPlayer and then choosing a subtitle, i got the following exception:

BSPlayer v1.00.803, Unhandled exception at EIP: 00413AD5
If you click 'Close' application will be terminated.
Please report this info to the author with description what were you doing.
List index out of bounds (0)
EStringListError
, 0x004E746F, 0x004E766D, 0x00453527, 0x0044A872, 0x77E2A2D0, 0x77E06B21, 0x77E15010, 0x717521F0, 0x7175276F, 0x71752574, 0x7172C11B, 0x7175276F, 0x71752643, 0x77E2A2D0, 0x77E06B21, 0x77E06B44, 0x004D06F1, 0x77E2A2D0, 0x77E045E5, 0x77E05B51, 0x004E8584, 0x77E987E7

Bytes at EIP: 8B C7 8B 53 0C 8B 14 F2 E8 CA 02 FF FF 5F 5E 5B C3 8B



PS: I forgot to mention that I use Windows 2k SP4 on a Duron 1300 with 512 MB Ram.
Reply With Quote
  #5 (permalink)  
Old 2nd January 2004
Junior Member
BS.Player Newbie
 
Join Date: Jan 2004
Posts: 1
Rep Power: 0
vviskari is an unknown quantity at this point
Default

Hi,

I have the same kind of problem with subtitles. When I play the movie in computer screen, all characters show correctly. But when I move the window to tv out (extended desktop) and try to play the movie, finnish umlaut characters ?¤ and ?¶ are not displayed. They are simply skipped.

How can this happen? What is the difference between playing the movie in computer monitor and tv out?

RC1 b803

BR,

vvi.
Reply With Quote
Reply

Tags
build, ogm, subtitles, v100

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 06:30 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19