Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 9th August 2002
Junior Member
BS.Player Newbie
 
Join Date: Aug 2002
Posts: 3
Rep Power: 0
Yabba02 is an unknown quantity at this point
Default Overlay problem

I have a problem with BSPlayer from version 0.84 on ... In previous versions overlay didn't work at all in my ATI all-in Wonder 128 graphics card, but from 0.84 on it began working in Mode 1. With no overlay I had really jerky playback, with overlay working quality is excellent.

But sometimes overlay stops working. I see an "Overlay Failed" message, but video quality is still good. The big problem is that I use BSPlayer for its easyness with .ini files, I use it with a launcher program and launch differents versions of the same film, but with audio in spanish or in its original language, and with or without subtitles. I also use 2 audio chains in WMA with excellent results, but I use them as 2 separate .wma files. I found it helps to achieve smooth playback, 2 wma chains into an .avi always produced "jumps", non-smooth playback ( excuse my bad english :) ). But if overlay fails, the rest of the .ini won't load and execute, so the whole thing fails :(

I have an AMD Athlon 1,2 Ghz, 256 Mb RAM, Windows 2000 . I have already updated the graphics card and AGP drivers, and after update everything works fine ... but after a few days problems start.

I think I have already tried every possible configuration... please, help me, I don't want to spend the remainings of my youth learning how to use MicroDVD's painful .ini files ... :)

Thank you all on advance ...
Reply With Quote
  #2 (permalink)  
Old 10th August 2002
Junior Member
BS.Player Newbie
 
Join Date: Aug 2002
Location: Athens - Greece
Posts: 7
Rep Power: 0
Amerzone is an unknown quantity at this point
Default

Well, overlay hell, the most unpredictable and peculiar problem I had to face also myself in the past. But in my case, it was BS the only player that could work in overlay, all the rest were using RGB with awful, of course, results... At the end I had to format and start from scratch :(

1. You say it is working for some days and, all of sudden, breaks just by itself, did I understand correctly? When you play the video, is there any other player window open? This breaks overlay, for sure.

2. Have you tried overlay mode 2 from the general settings? This time is better, worse, no change?

3. Play some videos with MDVDP (no need to write ini files... ) in window mode (don't use fullscreen). On the left side of the player there is a little yellow dot blinking... Does it turn white, or it's becoming red?

4. Which codec are the files you're trying (DivX3, 4, 5, ogm), or it happens to all of them?
Reply With Quote
  #3 (permalink)  
Old 10th August 2002
Junior Member
BS.Player Newbie
 
Join Date: Aug 2002
Posts: 3
Rep Power: 0
Yabba02 is an unknown quantity at this point
Default

I think I've just found the problem... My ATI all-in wonder can perform TV output, but when I return to normal mode, Windows sets refresh rate to default ( 60 Hz ) instead of the 100 Hz figure I normally choose. At 60 Hz BSPlayer can't generate overlay surface, but at 100 Hz there's no problem.

Now my only problem is to learn how to tweak Windows to have a default monitor refresh rate of 100 Hz instead of 60, because it's really annoying to set it up manually each time I want to use TV out and return to monitor mode.

Thank you very much for your quick answer...
Reply With Quote
  #4 (permalink)  
Old 14th August 2002
Junior Member
BS.Player Newbie
 
Join Date: Aug 2002
Location: Athens - Greece
Posts: 7
Rep Power: 0
Amerzone is an unknown quantity at this point
Default

You're right, tweaking the color depth that Windows are using (16-bit, 32-bit) and/or the monitor refresh rate may also help with the overlay. I don't know much about ATI, I'm using GeForce 2 MX400 myself (you see, I'm a gamer, too...)
Reply With Quote
Reply

Tags
overlay

Thread Tools
Display Modes

Posting Rules


All times are GMT +1. The time now is 12:13 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19