Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 10th August 2002
Junior Member
BS.Player Newbie
 
Join Date: Jul 2002
Location: Qu?©bec
Posts: 5
Rep Power: 0
bichenoubi is an unknown quantity at this point
Default MANY INTERROGATIONS

My first question is how to tell in the "Directory=" parameter of the ini file to look at the parent level.

Usualy, I write "../" in everything i program and I think it's the convention....
I also tried "..", but nothing works.


My second question is how to place vobsub subtitles in the black part of the screen, not over the image ?

I know I can place the subtitles where I want with some option in Vobsub, but if it is not over the movie, this is not visible


Thanks
Reply With Quote
  #2 (permalink)  
Old 24th September 2002
xlv600's Avatar
Senior Member
BS.Player Power User
 
Join Date: Jun 2002
Location: France
Posts: 218
Rep Power: 0
xlv600 is an unknown quantity at this point
Default

I understand that my answer comes lately, but it's v2.18 default settings now.
Reply With Quote
  #3 (permalink)  
Old 30th September 2002
Junior Member
BS.Player Newbie
 
Join Date: Jul 2002
Location: Qu?©bec
Posts: 5
Rep Power: 0
bichenoubi is an unknown quantity at this point
Default

??? sorry I don't understand what you're trying to say
??? d?©sol?©, je ne comprend pas ce que tu essais de m'expliquer.




My first question is about how to tell the correct path to the movie in the ini file.

My ini file and the player are in the BSplayer dir on my cd, but as the movie itself is in the root, I need to tell the ini file to look at the parent level.

To other question is, how to place the subtitle in the part of my screen where there is no movie. I can do that with srt, sub, txt, and all other file that is managed by bsplayer. The problem is that I can't do that with VobSub subtitles. They can't be in the black part, they must be iver the movie, and I don't want this...





I have to say that this forum is total chaos, there are tons of posts, but nobody reply. Also, everybody write in all the sections without asking themself if their messages go there (I'm not an exception).


We should make more sections in the forum and target them on specified subjets.


We should create modorators. Those people knowing really well BSplayer.




And don't know if BST want to be the only person on the BSplayer project, but I think he sould create a team to help him.

BSplayer is one of the best players, but it seems like nobody takes it seriously.

One thing that I still don't understand, is why there is no help file for this player? I don't understand almost all its features !


TUTORIALS SITES or whateever you want should be created as a UNIQUE source for all the FAQ. This forum is full of all the same questions.



WE MUST DO SOMETHING TO CONTINUE IMPROVE THIS INCREDIBLE SOFTWARE !
Reply With Quote
  #4 (permalink)  
Old 3rd October 2002
Junior Member
BS.Player Newbie
 
Join Date: Jul 2002
Posts: 4
Rep Power: 0
Loul is an unknown quantity at this point
Default Path definition

Try \ instead of / and it should work.

\subtitles\ for instance.
Reply With Quote
  #5 (permalink)  
Old 3rd October 2002
xlv600's Avatar
Senior Member
BS.Player Power User
 
Join Date: Jun 2002
Location: France
Posts: 218
Rep Power: 0
xlv600 is an unknown quantity at this point
Default

bichenoubi: Answering to the last question, I wanted to suggest you to try latest Vobsub v2.18 together with BSPlayer build 490.
In the "General" tab of the Dvobsub filter properties, you can now change the vertical padding, adding or removing black strips, in order to be able to put subtitles below the picture.

About your first problem, I agree with your structure, it's the way it should work.
I've made some tests with BSPlayer debug version 488 and Vobsub v2.14, and checked with Build 490 and Vobsub v2.18...
In the log file, I've seen that AVI relative file path is appended to the ini real path including the trailing '\'.
For instance, if the ini file path is:
F:\BSPlayer\Movie.bsi
and movie file
F:\Movie.avi
In the [MOVIE] section of your ini file , you should have:
Directory=..
FName=Movie.avi

The resulting path (in log file) will be:
F:\BSPlayer\..\Movie.avi

On my HD disk, the ini file path was:
L:\DivX\_Autorun\BSPlayer\Film.bsi
the movie file :
L:\DivX\Mission Cl?©op??tre\Film.avi
In the ini file , I've written:
[MOVIE]
Title=Ast?©rix & Ob?©lix - Mission Cl?©op??tre
Directory=..\..\Mission Cl?©op??tre
FName=Film.avi
AudioName1=Fran?§ais
;AudioName2=Original (only one audio stream here)

[SUBTITLES]
Directory=..\..\Mission Cl?©op??tre ; Same as movie
directorySub1=Film.idx
DefaultSub=0


Nota:
- Here, directory=..\..\..\DivX\Mission Cl?©op??tre works too.
- Tested successfully with movie an subs located in the root directory (Directory=..\..\..).
- VobSubs were working too, but they had to be located in the movie directory. The only issue is that I can't use a shortcut to cycle through them, but the other ways are working: through DVobsub properties or Right-click on movie.
- This has not been tested on CD!. For these tests, BSPlayer and all the needed codec and filters, are running from HD, bsi extension is registerd and associated to the BSPlayer installed in the system partition. It doesn't mean it would necessary work the same on a self sufficient CD.

Hope it helps...
Reply With Quote
Reply

Tags
interrogations

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 03:08 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20