Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 20th March 2004
Junior Member
BS.player Regular User
 
Join Date: Mar 2004
Location: France
Posts: 20
Rep Power: 0
Eyael is an unknown quantity at this point
Default Jerky playback

Hi everyone !

I've decided to register to let you know of what I assume must be a bug. I'm using latest version of BSPlayer 1.00.807. See all details of my configuration and movie at the end of this post.

Problem is : while playing a 2CD DivX movie with BSPlayer, in some parts of the movie (always the same), playback gets jerky (sound and picture) and video tends to freeze and get back to normal later on without my intervening. It only lasts 15 to 30 seconds and curiously sometimes the jerking does not occur at all. I've tried all sorts of changes with the settings of BSPlayer, used DivX decoder instead of FFDShow. The problem remains.

However if I copy the movie file on my CD hard drive, it plays perfectly. Same if I make a disc image and mount it in a virtual CD drive. You might think it has something to do with my CD recorder /DVD drives but I don't think so (DMA for all drives is on of course) as I've tried playing the same movie in the same drives using Gabest Media Player Classic and the jerking never occurs. MPC apparently uses the same decoder and filters as BSPlayer to play that movie.
Hope the developers manage to fix that soon as BSPlayer is such a good player it'd break my heart to have to use another player.
In the meantime, if I forgot to provide important info to help sort that bug, I'd be glad to post it ASAP.

Keep up the good work !

-------------
¤ My config
CPU: AMD Athlon XP 1700+ 1,47GHz
Bus speed: 133 MHz
Motherboard: 8363A-686A
System: VIA VT8363
Bios: Award 6.00 PG
Memory: 256 MB (60ns)
Sound: Audio Via (WAVE)
Video: NVIDIA GeForce 2MX 100/200
OS: Windows XP Pro SP1
DirectX 9

¤ Movie (info provided by GSPot 2.21)
Direct Show Render
Video SRC type: 4cc: DX50
Audio SRC type: MPEGLAYER3 (MP3) (0x0055)
Video path: (S) --> AVI Splitter --> ffdshow MPEG-4 Video Decoder --> (R)
Audio path: S) --> AVI Splitter --> MPEG Layer-3 Decoder --> Morgan Stream Switcher --> (R)

File
Size: 699 MB (or 716,508 KB or 733,704,192 bytes)
Stream type and A/V Interleave
Type: OpenDML AVI
IMRR: 1.00
I/L: 1 vid frame (40 ms), p=480 Split: No

Video
Codec 4CC: DX50/divx
Name: DivX 5.0 (version 5.11)
Runtime: 01:07:34 (101,353 fr)
xy: 672x272 (2.47:1) [=42:17]
Bitrate: 1179 kb/s
FPS: 25.000
Qf: 0.258 bits/pixel

Audio
Codec: 0x0055(MP3) ID'd as MPEG-1 Layer 3
Stream 1 (English)
Bitrate: 128 kb/s (64/ch, stereo) VBR LAME3.90
Fs: 48000 Hz
Stream 2 (French)
Bitrate: 127 kb/s (63/ch, stereo) VBR LAME3.90
Fs: 48000 Hz
__________________
"Our lives end the day we remain silent about things that matter" -- Martin Luther King
Reply With Quote
  #2 (permalink)  
Old 31st March 2004
Junior Member
BS.player Regular User
 
Join Date: Jun 2002
Location: Hungary
Posts: 15
Rep Power: 0
Fenyo is an unknown quantity at this point
Default

I can confirm that too, i experienced jerky video in some cases in BSPlayer 1.0, with MPEG-2, and AVI files too. I tested these files with BSPlayer 0.86 493(just after exiting from ver 1.0), and it wasn't jerky.
__________________
...Fenyo
Reply With Quote
  #3 (permalink)  
Old 17th May 2004
Junior Member
BS.player Regular User
 
Join Date: Mar 2004
Location: France
Posts: 20
Rep Power: 0
Eyael is an unknown quantity at this point
Default Playback still jerky with built 808

I've tested built 808 with update and playback is still jerky at times though, I should point out, slightly less than with the previous built. Sometimes, the parts of the movie that tend to freeze, do not freeze when I try to play them again and that without changing anything in the preferences or elsewhere.
By what I've read on this forum, it sounds like I'm not the only one who finds this bug annoying, so please do something about it. I don't think I'm getting fussy about the whole thing. You've done a great job so far, I'm sure there is a way to sort this nasty bug for good.
Sorry - criticizing is all I can do, however I do hope it is somehow helpful to you.
[/img]
__________________
"Our lives end the day we remain silent about things that matter" -- Martin Luther King
Reply With Quote
  #4 (permalink)  
Old 22nd May 2004
Junior Member
BS.Player Newbie
 
Join Date: May 2004
Location: Koko ni iru.
Posts: 3
Rep Power: 0
DesOk is an unknown quantity at this point
Default Popping sounds and jerky playback

I have been experienceing this for only a short time. :? Videos that played fine a short while ago now have these problems and some now don't have sound in BSPlayer but the worst types of files are the WMA/WMV files I try to play. Some play fine in WMP but not in BSP while others will only play in BSP and not at all in WMP. :evil: I have been dabating on uninstalling and reinstalling all of my audio codecs to see if that will help but I wanted to see if anyone can help me before I spend that much time messing with this problem. It can get really annoying. The popping is not consistent and is worse in some videos than in others. Can someone please help me.

Also, on a side note, can anyone tell me why I am unable to get the newest version of the BSP that just came out. I tried using my e-mail and my Login info and neither work. I cannot seem to receive the e-mail on the downloading information. Thanks.
Reply With Quote
  #5 (permalink)  
Old 20th June 2004
Junior Member
BS.player Regular User
 
Join Date: Mar 2004
Location: France
Posts: 20
Rep Power: 0
Eyael is an unknown quantity at this point
Default

I have just tested build 809 and I'm afraid I have to report that nothing has changed regarding this occasional jerky playing bug. Isn't there anything you can do about it? So far this never occurred with Media Player Classic (or Windows Media Player) which is such a shame for BSPlayer beats them all.
__________________
"Our lives end the day we remain silent about things that matter" -- Martin Luther King
Reply With Quote
  #6 (permalink)  
Old 24th June 2004
Junior Member
BS.player Regular User
 
Join Date: Mar 2004
Location: France
Posts: 20
Rep Power: 0
Eyael is an unknown quantity at this point
Default Re: Popping sounds and jerky playback

Quote:
Also, on a side note, can anyone tell me why I am unable to get the newest version of the BSP that just came out. I tried using my e-mail and my Login info and neither work. I cannot seem to receive the e-mail on the downloading information. Thanks.
I think you need to allow cookies for BSPlayer's site to be able to download. Check your browser and firewall configurations. I've just remembered it happened to me ages ago and that's how I got it sorted out.
__________________
"Our lives end the day we remain silent about things that matter" -- Martin Luther King
Reply With Quote
Reply

Tags
jerky, playback

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 04:53 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20