Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 8th August 2004
Junior Member
BS.Player Newbie
 
Join Date: Apr 2003
Posts: 3
Rep Power: 0
roninmedia is an unknown quantity at this point
Default OGM not Playing

I downloaded the most recent BSplayer and the OGM file opens (it displays the file info) but it doesn't show any picture or sound and the file does not begin playing. It is because of my codecs because even windows media player plays the OGM file correctly.
Reply With Quote
  #2 (permalink)  
Old 10th August 2004
aok aok is offline
Junior Member
BS.Player Newbie
 
Join Date: Aug 2004
Posts: 9
Rep Power: 0
aok is an unknown quantity at this point
Default

This seems to be a common issue with BSPlayer while it works with other players. I prefer to use bsplayer though.

I hope the bsplayer developers try to figure out why other players seem to be more flexible in terms of playing certain formats. I wouldn't mind helping experiment to get bsplayer better.

Even when using codec packs. The K-lite Codec Pack used to even include BSPlayer until the licensing change.
Reply With Quote
  #3 (permalink)  
Old 11th August 2004
aok aok is offline
Junior Member
BS.Player Newbie
 
Join Date: Aug 2004
Posts: 9
Rep Power: 0
aok is an unknown quantity at this point
Default

I just found out that after I load up an OGM movie and get the black initial screen, that if I go into the Audio menu and select an OGM Stream, then click the play button, that the movie starts playing.

However, no sound.

Also I tried toggling the "Use internal vorbis decoder" but no change in sound.

Does this offer any clues?

I have VMR-9 enabled. I think enabling this allowed me to drag to various positions of the movie to see the frame rendered.
Reply With Quote
  #4 (permalink)  
Old 11th August 2004
Junior Member
BS.Player Newbie
 
Join Date: Aug 2004
Posts: 2
Rep Power: 0
Loopy is an unknown quantity at this point
Default Me2

Likewise here, and I know there is nothing wrong with my setup, since I can use other players (like Media Player Classic) with absolutely no problems whatsoever, so this is not just aok's system.
Reply With Quote
  #5 (permalink)  
Old 12th August 2004
Junior Member
BS.Player Newbie
 
Join Date: Aug 2004
Posts: 2
Rep Power: 0
Loopy is an unknown quantity at this point
Default The Answer! (I think)

I think I might have the answer for you, aok. Here's what you need to do:

1. Play the movie
2. Bring up the menu.
3. From the stream selection, you will have something like this:

Stream 1
Stream 2
-- OGM Streams -- <= Separator, Unselectable
English
Japanese

To get the correct audio, you need to pair up the Stream option with the correct language, so Stream 1 + English for English Audio and Stream 2 + Japanese for Japanese Audio. If you attempt to seek through the movie, you have to flick the OGM Stream to another stream and then back again to get the audio again.

Try this out and see if it works with you, I may just be lucky.

Loopy
Reply With Quote
  #6 (permalink)  
Old 13th August 2004
aok aok is offline
Junior Member
BS.Player Newbie
 
Join Date: Aug 2004
Posts: 9
Rep Power: 0
aok is an unknown quantity at this point
Default

I just tried it with a couple of OGMs. Actually I did that before in all the combinations, but I just tried it again after your post in case I missed something.

Didn't work. It sort of stutters and then stops. Kind of random.

Now I'm pretty sure there is a bug somewhere because the behaviour is too erratic.
Reply With Quote
  #7 (permalink)  
Old 22nd September 2004
aok aok is offline
Junior Member
BS.Player Newbie
 
Join Date: Aug 2004
Posts: 9
Rep Power: 0
aok is an unknown quantity at this point
Default

This problem is still there with BSplayer version 1.02 Build 812.

Can someone that has successfully played any OGM file post here to say they have? And also mention if there were multiple audio streams in their OGM file.
Reply With Quote
  #8 (permalink)  
Old 22nd September 2004
Senior Member
BS.Player Power User
 
Join Date: Sep 2004
Location: Warsaw, Poland
Posts: 124
Rep Power: 0
Garet_Jax is an unknown quantity at this point
Default

install this:
http://www.vorbis.com/files/1.0/tobias/OggDS0995.exe
that may fix your problems.
Yes I played lots of ogms/avis/mkvs with many kinds of video/audio/subtitles streams combinations, and it worked.
Reply With Quote
  #9 (permalink)  
Old 22nd September 2004
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 51
Posts: 5,127
Rep Power: 26
adicoto is on a distinguished road
Default

Strange things. Just created myself an ogm file for testing. VIdeo is DivX and 3 audio streams, the default one, another one MP3 and the third is ogg. BSPlayer failed to play the file. But BSPlayer 0.86 didn't played the file either.
Same file, saved as mkv played OK.
Same file, without ogg stream, saved as avi, played fine.
And if "use internal vorbis decoder" was enabled, the external decoder wasn't used any more.
Clearly is an BSPlayer bug.
Reply With Quote
  #10 (permalink)  
Old 22nd September 2004
Senior Member
BS.Player Power User
 
Join Date: Sep 2004
Location: Warsaw, Poland
Posts: 124
Rep Power: 0
Garet_Jax is an unknown quantity at this point
Default

After adicoto post I also made a test files, using videos: div3, div5, xvid and audios: 2x mp3, 2x ogg (only one video stream at the time, cause VDM isn't able to do multiple video streams). I can't reproduce any of your bug.

to adicoto:
Can you post a sample file?

to aok:
Maybe you also will post a sample file? (that is - IF installing the file I posted link to will not help)

to Loopy:
Quote:
If you attempt to seek through the movie, you have to flick the OGM Stream to another stream and then back again to get the audio again.
Why is that?


About different audio streams in ogm file:
There are basically two situations.

first, someting like that:
Code:
Stream 1
-- Ogm Streams --
English
Japanese
...
n-th language
there is one stream in upper section, one or more in bottom section. This is simple - you just choose whatever you want from bottom section and it changes immediatelly.

second situation:
Code:
Stream 1
Stream 2
...
Stream k
-- Ogm Streams --
English
Japanese
...
n-th language
there is more then one stream in upper section. That should happen only if language versions are encoded with different codecs (for example japanese is ogg file, english is mp3 file). If you want to use some language, first you have to select a Stream from upper section - the one that this language is in. Then BSplayer immediatelly switch to first language version found in enabled stream. If language you want to hear is not the first in it's stream, then after selecting stream you have to select the language (from the bottom list).
So the conclusion is: if you change language and nothing happens, try to click on different stream, and then choose the language again.

For example, I have:
Stream 1 (ogg) - japanese (first in file) and english (second in file) audio.
Stream 2 (mp3) - polish (third in file) and czech (fourth in file) audio.

I want to hear japanese audio:
If pl or czech is enabled I click Stream 1
If english is enabled I click Japanese

I want to hear english audio:
If pl or czech is enabled I click Stream 1 and then English
If japanese is enabled I click English

I want to hear polish audio:
japanese or english - click Stream 2
else click Polish

I want to hear czech audio:
japanese or english - Stream 2 then Czech
else - Czech

I hope that clears the situation somewhat... ;)
Reply With Quote
  #11 (permalink)  
Old 23rd September 2004
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 5
Rep Power: 0
cz.petab is an unknown quantity at this point
Default OGM file with multiple audio streams doesn't play - SOLUTION

I had the same problem as others above: OGM file with more than 1 audio stream didn't play until I manually selected one of the audio streams (I tried both internal and 0.995 external OGG splitter). I always thought of it as BSPlayer bug. But to my surprise BSPlayer played such files on the other PC (with nearly identical sw setup) without problems. After a little investigation I found the difference. That's what helped me: after unchecking "Always enable all streams" in Ogg Splitter properties BSPlayer started playing OGMs without a need for manual selection of audio stream.
Be sure you have latest BSPlayer (some older versions have problems playing OGM AFAIK).
BTW: there's a keyboard shortcut (default Shift+S) to cycle audio streams.
Reply With Quote
  #12 (permalink)  
Old 23rd September 2004
Senior Member
BS.Player Power User
 
Join Date: Sep 2004
Location: Warsaw, Poland
Posts: 124
Rep Power: 0
Garet_Jax is an unknown quantity at this point
Default Good solution

Quote:
Originally Posted by cz.petab
after unchecking "Always enable all streams" in Ogg Splitter properties BSPlayer started playing OGMs without a need for manual selection of audio stream.
Oh, so that's why I didn't have any of those video problems. That's right, checking "Always enable ..." makes it not work properly. :/
Reply With Quote
  #13 (permalink)  
Old 24th September 2004
aok aok is offline
Junior Member
BS.Player Newbie
 
Join Date: Aug 2004
Posts: 9
Rep Power: 0
aok is an unknown quantity at this point
Default

AHHHH! Unchecking "Always enable all streams" did the trick.

The only way I could access the Ogg Splitter properties was after I loaded the OGM.
Reply With Quote
Reply

Tags
ogm, playing

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 07:16 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19