Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 10th September 2004
esp esp is offline
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 9
Rep Power: 0
esp is an unknown quantity at this point
Default so annoying =(

ok here's the story: today i downloaded the newest version of BS player. After that when i tried to watch an .avi file, it was slow as hell.. everything worked just fine until i downloaded that newest version of bsplayer.. i have tried everything i can: 1) tried older version of bsplayer 2) re-installed some of my codecs 3) downloaded newest versions of divx and ffdshow 4) tried to play with the overlay modes in bsplayer and still isnt working. I tried all my other programs too but they do the same thing.. im using that gordian knot pack (or what ever is it) could this be because of that?

pls help me.. i desperately need to watch my favourite anime series!!
thanx in advance.
Reply With Quote
  #2 (permalink)  
Old 10th September 2004
DragonFighter's Avatar
Senior Member
BS.Player Power User
 
Join Date: Apr 2004
Location: Hellas
Age: 36
Posts: 195
Rep Power: 0
DragonFighter is an unknown quantity at this point
Default

Are you sure that you are using the latest build of BSplayer?? (That is 1.01 Build 811). :?
There was a confict with a NAV update in previous versions..
Take a look here: http://forum.bsplayer.org/viewtopic.php?t=5351
__________________
HWmaker
Please read BSPeter's Help2Help topic
Reply With Quote
  #3 (permalink)  
Old 10th September 2004
esp esp is offline
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 9
Rep Power: 0
esp is an unknown quantity at this point
Default

but im not using nav...
Reply With Quote
  #4 (permalink)  
Old 10th September 2004
Quietseb's Avatar
Senior Member
BS.Player Power User
 
Join Date: Jun 2002
Location: back in France...
Posts: 581
Rep Power: 0
Quietseb is an unknown quantity at this point
Default

when you say 'slow as hell', do you mean the program itself or the playing ?

when playing a video, what filters are loaded (right-click on the movie, options->filters) ?
Reply With Quote
  #5 (permalink)  
Old 11th September 2004
esp esp is offline
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 9
Rep Power: 0
esp is an unknown quantity at this point
Default

i took a screen shot http://www.members.lycos.co.uk/butcheri/bsplayerbug.jpg

Video rendering options are:

Wait for vertical blank
Disbale YV12 format
Use overlaymode 2 (overlay mixer)

but like i said ive tried to change those options with out succes..
Reply With Quote
  #6 (permalink)  
Old 11th September 2004
Quietseb's Avatar
Senior Member
BS.Player Power User
 
Join Date: Jun 2002
Location: back in France...
Posts: 581
Rep Power: 0
Quietseb is an unknown quantity at this point
Default

I'm not familiar with the gordian knot codec pack (I don't usually appreciate codec packs) but their version of ffdshow is pretty old (may 2003)
you can try and grab a new one from sourceforge (latest ffdshow alpha is dated 28 august as of today)

although you said problems appeared after changing bsplayer version... updating ffdshow shouldn't do any harm
Reply With Quote
  #7 (permalink)  
Old 12th September 2004
esp esp is offline
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 9
Rep Power: 0
esp is an unknown quantity at this point
Default

downloaded the newest version of ffdshow - still not working..
Reply With Quote
  #8 (permalink)  
Old 12th September 2004
Quietseb's Avatar
Senior Member
BS.Player Power User
 
Join Date: Jun 2002
Location: back in France...
Posts: 581
Rep Power: 0
Quietseb is an unknown quantity at this point
Default

sorry, I've got no clues for now :(
Reply With Quote
  #9 (permalink)  
Old 12th September 2004
Senior Member
BS.Player Power User
 
Join Date: Sep 2004
Location: Warsaw, Poland
Posts: 124
Rep Power: 0
Garet_Jax is an unknown quantity at this point
Default

Quote:
Originally Posted by esp
hmmm.... that look just like my players when I had my monitor display colors turned to 24 bits. Go to display properties (or however it's called in english Windows), and chage color depth either to 16 or to 32 bits. Hope that help ^_^
Reply With Quote
  #10 (permalink)  
Old 12th September 2004
esp esp is offline
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 9
Rep Power: 0
esp is an unknown quantity at this point
Default

Quote:
Originally Posted by Garet_Jax
Quote:
Originally Posted by esp
hmmm.... that look just like my players when I had my monitor display colors turned to 24 bits. Go to display properties (or however it's called in english Windows), and chage color depth either to 16 or to 32 bits. Hope that help ^_^
tried that but still aint workin :evil:
Reply With Quote
  #11 (permalink)  
Old 12th September 2004
Senior Member
BS.Player Power User
 
Join Date: Sep 2004
Location: Warsaw, Poland
Posts: 124
Rep Power: 0
Garet_Jax is an unknown quantity at this point
Default

grab GSpot --> http://gspot.headbands.com/
the 2.51 beta version, not 2.21 !

use GSpot to open file that can't be played properly.

see what it says. (paste it)

in "proposed codec solution and tests --> MS A/V" press 1, and then 2. See if it's rendered properly.

then in "proposed codec solution and tests --> GSpot --> Vid" press 1, then 2, and for every render option that gave you the result "Video Render OK" right click and "play this graph". See if it renders ok.

If in any case the render is succesful, see what codec/filter was used, and paste it here.

Also in GSpot you can go to "System --> List Codecs and Other Filters" and check if there is anything marked red (red = problem).
Reply With Quote
  #12 (permalink)  
Old 13th September 2004
esp esp is offline
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 9
Rep Power: 0
esp is an unknown quantity at this point
Default

1. in "proposed codec solution and tests --> MS A/V" I pressed 1 and got this report "Render: Partial failure

2. in "proposed codec solution and tests --> MS A/V" I pressed 2 and it started playing my video

3. in "proposed codec solution and tests --> GSpot --> Vid" I pressed 1 it gave me this http://www.members.lycos.co.uk/butcheri/1.jpg

4. in "proposed codec solution and tests --> GSpot --> Vid" I pressed 2 it gave me this http://www.members.lycos.co.uk/butcheri/2.jpg

5. in "proposed codec solution and tests --> GSpot --> Vid" I pressed 3 and started playing my video


very weird :?
Reply With Quote
  #13 (permalink)  
Old 13th September 2004
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 6
Rep Power: 0
agent is an unknown quantity at this point
Default

what have u selected for video rendering?

pref-video-video rendering

have u tried overlay mode 1?
Reply With Quote
  #14 (permalink)  
Old 13th September 2004
Senior Member
BS.Player Power User
 
Join Date: Sep 2004
Location: Warsaw, Poland
Posts: 124
Rep Power: 0
Garet_Jax is an unknown quantity at this point
Default

tell me more:

1) post a screenshot of what you see after:
Quote:
1. in "proposed codec solution and tests --> MS A/V" I pressed 1 and got this report "Render: Partial failure
2) when you say that the video played, then you mean that it worked correctly, yes?
Reply With Quote
  #15 (permalink)  
Old 13th September 2004
esp esp is offline
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 9
Rep Power: 0
esp is an unknown quantity at this point
Default

tell me more:

1) post a screenshot of what you see after: 1. in "proposed codec solution and tests --> MS A/V" I pressed 1 and got this report "Render: Partial failure

http://www.members.lycos.co.uk/butcheri/3.jpg


2) when you say that the video played, then you mean that it worked correctly, yes?

http://www.members.lycos.co.uk/butcheri/4.jpg


it worked properly in that little test screen but it didnt work in bsplayer..
Reply With Quote
  #16 (permalink)  
Old 13th September 2004
Senior Member
BS.Player Power User
 
Join Date: Sep 2004
Location: Warsaw, Poland
Posts: 124
Rep Power: 0
Garet_Jax is an unknown quantity at this point
Default

lol... that actually didn't give any more information... damn GSpot :/

anyway, try that:
go to ffdshow configuration page (the link should be somewhere in start menu)
and in "codecs" menu change "supported codecs" option for "XviD" from disabled to libavcoded or the other way (and btw. post which one was turned on).
Reply With Quote
  #17 (permalink)  
Old 14th September 2004
esp esp is offline
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 9
Rep Power: 0
esp is an unknown quantity at this point
Default

before changes:

Format:|||||Decoder:|||||||Supported FOURCCs/remarks
XviD|||||||||libavcodec|||||XVID, XVIX

Format:|||||Decoder:|||||||Supported FOURCCs/remarks
XviD|||||||||XviD1|||||||||||XVID, XVIX

is that what you mean? cuz it still aint working :evil:

btq. the | mean space (stupid bbcode doesent allow to use 2 spaces in a row..)
Reply With Quote
  #18 (permalink)  
Old 14th September 2004
Senior Member
BS.Player Power User
 
Join Date: Sep 2004
Location: Warsaw, Poland
Posts: 124
Rep Power: 0
Garet_Jax is an unknown quantity at this point
Default

err... O_o

anyway, maybe try that:

1) uninstall ffdshow
2) install latest XviD: http://www.koepi.org/XviD-1.0.2-29082004.exe
3) play...

if it won't succeed, then try different BSplayer settings again,
and if it still won't play, post a screenshot like this one before: http://www.members.lycos.co.uk/butcheri/bsplayerbug.jpg
Reply With Quote
  #19 (permalink)  
Old 16th September 2004
esp esp is offline
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 9
Rep Power: 0
esp is an unknown quantity at this point
Default

http://www.members.lycos.co.uk/butcheri/5.jpg

if i dont use overlay modes, bsplayer plays my video but it lags = is slow as hell
Reply With Quote
  #20 (permalink)  
Old 16th September 2004
Senior Member
BS.Player Power User
 
Join Date: Sep 2004
Location: Warsaw, Poland
Posts: 124
Rep Power: 0
Garet_Jax is an unknown quantity at this point
Default

So, unistalling ffdshow didn't help?
... I have no idea.
You can try reinstalling all your codecs... -_-"


All those screenshots made me want to see if Madlax is any good.
Reply With Quote
Reply

Tags
annoying

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 04:52 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20