Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 3rd November 2004
trodas's Avatar
Senior Member
BS.Player Power User
 
Join Date: Nov 2002
Location: Czech republic
Age: 45
Posts: 239
Rep Power: 0
trodas is an unknown quantity at this point
Default AC3sound + pause/play bug

In movies, that use AC3 sound (decoded trough AC3 filter 1.01a RC5), repeatedly using pause/play cause very bad bug - the sound get changed to very ungly noise, screaming at me from all channels :shock: :(

Since this bug did not seems to happen with other players using the very same AC3 filter to decode sound, and it did never happend to me when using seeking, then I do believe that this is just a BSplayer glitch - bug

And it's there for a long time, maybe is time to finally fix this one? :D
__________________
"It is dangerous to be right in matters on which the established authorities are wrong." - Voltaire
...just keep folding, just keep folding... :) my config - my caps
Reply With Quote
  #2 (permalink)  
Old 4th November 2004
trodas's Avatar
Senior Member
BS.Player Power User
 
Join Date: Nov 2002
Location: Czech republic
Age: 45
Posts: 239
Rep Power: 0
trodas is an unknown quantity at this point
Default

Oh, it's not a BSplayer fault, I repead the same pause/play bug that cause "distorted" audio with Windows Media Player that come with Win2k, so, this looks like a AC3 filter bug :oops:

Let's ask Alex about it :lol:
__________________
"It is dangerous to be right in matters on which the established authorities are wrong." - Voltaire
...just keep folding, just keep folding... :) my config - my caps
Reply With Quote
  #3 (permalink)  
Old 19th December 2004
trodas's Avatar
Senior Member
BS.Player Power User
 
Join Date: Nov 2002
Location: Czech republic
Age: 45
Posts: 239
Rep Power: 0
trodas is an unknown quantity at this point
Default

Setting the output from AC3 filter to 16bit instead of 24bit (one could use 32bit too) fix the problem as immediate solution, however I would like to know, if anyone else having such problem too...? :roll: :oops:

Or if it's only related to some sort of bug in creative drivers on Audigy2zs card - using the latest, EAX4 suxxkers... :evil:
__________________
"It is dangerous to be right in matters on which the established authorities are wrong." - Voltaire
...just keep folding, just keep folding... :) my config - my caps
Reply With Quote
  #4 (permalink)  
Old 31st December 2004
trodas's Avatar
Senior Member
BS.Player Power User
 
Join Date: Nov 2002
Location: Czech republic
Age: 45
Posts: 239
Rep Power: 0
trodas is an unknown quantity at this point
Default

...well, it did not work at 100% as a solution - even with the 16bit output only I find that many times channels get swaped (front to subwoofer is especially funny thing, because from the normal talking you can't hear a thing, except muffled low-frewuency noises :lol: ) :?

It happen for me with the AC3 filter from it's early days trought various hardware (CPUs, mobos, chipsets...) and sound cards and it's drivers, so - anyone experiencing thig thing on AC3 movies and fast pause/unpause too? :?: :?: :?:

Please speak loud, thanks! :P
__________________
"It is dangerous to be right in matters on which the established authorities are wrong." - Voltaire
...just keep folding, just keep folding... :) my config - my caps
Reply With Quote
  #5 (permalink)  
Old 5th January 2005
trodas's Avatar
Senior Member
BS.Player Power User
 
Join Date: Nov 2002
Location: Czech republic
Age: 45
Posts: 239
Rep Power: 0
trodas is an unknown quantity at this point
Default

^bump^

...anyone? I could not belive that this happend to me only. There is no AC3 filter users out there? :roll: :shock: :(

(and issue like it is unresolved from early AC3 filter days anyway...)
__________________
"It is dangerous to be right in matters on which the established authorities are wrong." - Voltaire
...just keep folding, just keep folding... :) my config - my caps
Reply With Quote
  #6 (permalink)  
Old 6th January 2005
Senior Member
BS.Player Power User
 
Join Date: Jul 2004
Posts: 117
Rep Power: 0
majk_tajsam is an unknown quantity at this point
Default

I also had some problems with AC3 filter 1.01a RC5 (http://forum.bsplayer.org/viewtopic.php?t=5330), which I solved by "playing" with options...
Reply With Quote
  #7 (permalink)  
Old 6th January 2005
trodas's Avatar
Senior Member
BS.Player Power User
 
Join Date: Nov 2002
Location: Czech republic
Age: 45
Posts: 239
Rep Power: 0
trodas is an unknown quantity at this point
Default

Well, yea, but these aren't the pause problems lead to either distorted noise (24bit output) or at least changing channels (16bit & 24bit as well) :?

Those are simple misconfigurations.

BTW, for optimal quality, the master volume should be set at 6 (to avoid clipping in amplifier/got the same volume, as 89dcb norm should be), and the four first options in the Options should be enabled + the bass redirection at 120Hz set
Voice control and expand stereo are useless on 5.1 systems. BTW, maybe not on all sestems, but Audigy2zs does the stereo expand by itself, so... :)
__________________
"It is dangerous to be right in matters on which the established authorities are wrong." - Voltaire
...just keep folding, just keep folding... :) my config - my caps
Reply With Quote
Reply

Tags
ac3sound, pause or play

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 06:15 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20