Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 4th December 2002
Junior Member
BS.Player Newbie
 
Join Date: Dec 2002
Posts: 1
Rep Power: 0
dgosman is an unknown quantity at this point
Default Xvid codec, solution

Just a little note.

A new and populair codec is the xvid codec (www.xvid.org)

I was searching for a solution, because the xvid encoded movie blinked and freezed in my bsplayer .

Maybe this is something for the faq's.

The solution is the following.

You should switch off overlay mode in your player .

Greetings,

Daniel
Reply With Quote
  #2 (permalink)  
Old 4th December 2002
trodas's Avatar
Senior Member
BS.Player Power User
 
Join Date: Nov 2002
Location: Czech republic
Age: 44
Posts: 239
Rep Power: 0
trodas is an unknown quantity at this point
Default

For me, Xvid movies playing perfectly there.
Latest BSplayer.
For decoding i used first orginaly Xvid decoder, later and now FFD filters.
Win2k SP3.
Detonators 23.11 on GF2Ti.
__________________
"It is dangerous to be right in matters on which the established authorities are wrong." - Voltaire
...just keep folding, just keep folding... :) my config - my caps
Reply With Quote
  #3 (permalink)  
Old 9th December 2002
Senior Member
BS.Player Power User
 
Join Date: Jun 2002
Posts: 156
Rep Power: 0
bluedan is an unknown quantity at this point
Default

XVid isn' that new anymore, though it is still under heavy development. In its current state there are two different branches of development, one of it aiming for stable release versions while the others target is to finalize implementation of B-frames, global motion Compensation and QPel as a experimental (test) build.
I wonder, if this has a meaning to anyone of you anyway...
Normally, XVid should be no problem at all for the player,truly it hasn't been for over a year, AFAIK!!
So if this is an unknown source of video material (piracy??), or you or a friend were very experimental with latest experimental version, then you may run into problems with playback indeed.
Other possible reasons: check if it only occurs in bsplayer. If not, then bsplayer is not to blame.
If using ffdshow try to set decoding under Codecs tab to XVid, because decoder coming with XVid Codec installation should handle it most properly.
If every effort is useless, do codec install again:http://www.roeder.goe.net/~koepi/xvid.shtml
How powerfull is your engine? If for instance you owe an Intel PII@500MHz you could hardly watch an XVid movie with B-frames and/or QPel, especially at high resolution.Anyway if movie resolution is higher than 640x480, there are even playback problems without b-frames and such...
From your posting I cannot conclude anything, and BTW, turning off overlay is not a good idea if you want subtitles...
Be more precise.
__________________
Keep forum organized and use the search button !! :o
Reply With Quote
  #4 (permalink)  
Old 9th December 2002
Junior Member
BS.Player Newbie
 
Join Date: Jun 2002
Posts: 7
Rep Power: 0
vio_man is an unknown quantity at this point
Default

This problem with the XviD codec only occurs with nVIDIA Detonator XP 40.72 or later. Using 29.42 version all movies played fine using overlay.
Disabling overlay, no subtitles :(
I think that RadLight Player has the same problem.
Reply With Quote
Reply

Tags
codec, solution, xvid

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 03:33 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20