Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Bug Reports And Codecs (http://forum.bsplayer.com/bug-reports-codecs/)
-   -   SUBTITLES display bug (http://forum.bsplayer.com/bug-reports-codecs/6939-subtitles-display-bug.html)

concept 8th November 2005 04:02 PM

SUBTITLES display bug
 
I'm using a mkv file with encoded subtitles

bs player doesn't display subtitle correctly whenever there is a font change while another media player does:

http://img397.imageshack.us/img397/2...asusmpc8hs.jpg
ON MEDIA PLAYER CLASSIC



http://img397.imageshack.us/img397/1...asusbsp2xj.jpg
ON BS PLAYER

concept 23rd December 2005 05:31 PM

I thought a subtitle bug would get the author attention
It seems I was wrong :-|

Lenchik 23rd December 2005 07:26 PM

At least you see some subs in MKV (see http://forum.bsplayer.org/viewtopic.php?t=7476 - more bugs in mkv subs and bsp)

Can you share your options file (bsplayer*.xml) - maybe someone will see any subtitles.

Lenchik 23rd December 2005 09:39 PM

Time to sleep, but i have done little testing. Unfortunately not on concept's problem. But this topic is in bug reports and dedicated to subtitles in mkv...
Win98
matroskasplitter by gabest 20050321
BSP deleted and then each version is extracted in clean folder from zip
Ghost_in_the_Shell_SAC_02.DVD(XviD.AC3_5.1)[KAA][CD24ADD8].mkv
RahXephon - 21.mkv

800 - vsfilter loaded 2.36 2.37 no subs (even not detected by VSFilter)
803 - vsfilter loaded 2.37 subs working (by VSFilter), bsplayer crashed on RahXephon subs
805 - vsfilters loaded, 2.36+ subs working (by VSFilter) Gits, RahX subs and 2.37 bsplayer crashed,RahX subs and 2.36 if not crashing bsplayer seems to determine subs but show with little font and hor black line.
807 - vsfilters loaded, 2.36+ subs working (by VSFilter) Gits, RahX subs and 2.37 bsplayer crashed subs not detected, RahX 2.36 subs detected only by bsp but not shown
further testing on VSfilter 2.36
808 - vsfilter loaded, Gits subs working (by VSFilter), RahX subs detected only by bsp but shown with big black background and small font, increasing font increases big black BG.
811 - vsfilter loaded, Gits subs working (by VSFilter, bsplayer doesn't detect as in all previous), RahX subs detected only by bsp but shown with big black background, some part of BG closes text, if i turn "draw subs on ovelay" on then subs of normal size at the top of movie window and transparent (how to move down? and make them not to show only couple of words in line?), seeking RahXephon makes BSP crash
812 -
814 -
817 - vsfilter loaded, Gits subs working (by VSFilter, bsplayer doesn't detect), RahX subs detected only by bsp but shown with big black background, some part of BG closes text, if i turn "draw subs on ovelay" on then subs of normal size at the top of movie window and transparent (how to move down? and make them not to show only couple of words in line?)
820 - vsfilter loaded, Gits subs working (by VSFilter, bsplayer doesn't detect), RahX subs detected only by bsp but shown with big black background, some part of BG closes text, if i turn "draw subs on ovelay" on then subs of normal size at the top of movie window and transparent, seeking RahXephon makes subs (with "draw subs on ovelay" on) not to show sometimes especially when you are seeking back
823 - vsfilter loaded, Gits subs working (by VSFilter, bsplayer doesn't detect),RahX subs detected only by bsp but shown with big black background, some part of BG closes text, if i turn "draw subs on ovelay" on then subs of normal size at the top of movie window and transparent
825 - vsfilter loaded, Gits subs working (by VSFilter, bsplayer doesn't detect),RahX subs detected only by bsp but shown with big black background, some part of BG closes text, if i turn "draw subs on ovelay" on then subs of normal size at the top of movie window and transparent
826 - Gits subs not working (vsfilter not loaded (at least to tray) but shown in filter chain), RahX same problems like 823 but vsfilter not loaded too.

It also seems that checking "advanced graph building" and/or "allow intermediate filters" make sense - they crashed bsp 825 with mkv and after that RahX in ActiveMovie window worked good with VSFilter
Some time ago these option helped me with bsp and vsfilter - now seems to crash...


All times are GMT +1. The time now is 01:17 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20