Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 12th December 2005
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 23
Tizio will become famous soon enough
Default BUGS in BSplayer v1.37.826 (Normal/Pro)

I'm very glad to see that a new version of BSplayer has come out!! :D
A lot of bug fixes in this release, but some bugs are still alive

BUGS:
TV TUNER
- After the capture process has been started/terminated, the channel saved in memory is the first in list even if the current selected one is different from the first
- When capturing videos, if the PAUSE button is pressed the displayed captured size freezes, but number of frames captured and seconds elapsed continues counting, then re-pressing the PAUSE button the size counter continues counting, but the resultant captured file is BAD! The playback is ridicolously fast and the audio is out of sync
This appens with NO Compression filters, and ONLY if the PAUSE button is pressed.
Quote:
Originally Posted by BST
Known bug, it will be fixed
- (BUG?) Italian (antenna) region doesn't work in the Italian territoty (wrong frequencies? GERMANY settings works fine in Italian territory [NOTE: DScaler's Italian settings works ok])
- (BUG?) In the tuner configuration window, it isn't possible to select NTSC/SECAM Standard Videos even for those countries that have NTSC/SECAM as standard video definitions
- Audio: (Since tv capture exists) If for example audio source is Line-in and in "Capture settings" Line-in is selected (and in the Windows volume control Line-in is not Muted), there is a sort of echo, this is because BSplayer sound is delayed in respect of Line-in one, and don't use Line-in sound only, but overlap Line-in sound with BSplayer sound
- The teletext window position is not remembered.
- If the Output size height is greater than 288pixels, then while capturing the video displayed is BLACK and the audio is unhearable (the file is correctly captured, but it's not possible to view/hear the video/audio while capturing).

SKIN
- "Install skin" explorer menu item is not the default one, instead the default one is "Open with...". Plus it is not translated when changing BSplayer language
- If the "Disable skinned windows" option in Skin section is checked, then also the Menus lost the skinned feature (even if the "Disable skinned menus" option is UNchecked)

OTHER
- If you try to do a frame-by-frame seek (PAUSE+ARROWS) when you go forward (RIGHT ARROW) for example by 5 seconds, then go backward (LEFT ARROW) and then forward again (RIGHT ARROW) to restart the frame-by-frame seeking, then a wrong positioned frame is placed where the frame-by-frame forward ended before restarting it (all these actions have to be made without restarting the playback).
- Redundant Explorer shell menu items for media files: Open/Play/Play in BSplayer
- When the MovieWindow's top border coordinates are minor than -25 pixels (for example if top border is out of the top screen border by 50 pixels), and the movie window is manually resized, then after resizing, the movie window new dimensions are equal to "the movie window resized width"x"the movie window resized height+25pixels", and the video image is stretched even if the Keep aspect ratio option is selected.
- If the movie window is resized (downsized) by dragging the top-left corner, BSplayer doesn't check the minimum window's dimensions, and the window is resizable down to 2x2 pixels.
- Is it normal that the buffer state goes from -1% to 99% instead of from 0% to 100%? :s
- If the chapters' names have ":" char in them, then BSplayer crashes!
- BSplayer doesn't recognise "." character sent by Girder!
This only appens in Windows2000/XP systems. In Windows 9.x/ME "." character works.
AFAIK it's a BSplayer issue since Girder is able to send "." char to others applications.
Quote:
Originally Posted by BST
We'll look into this.
MISSING TRANSLATIONS
- About Window -> version, Registered to, Icons created by, (Language) by (translator), Month abbrevations
- Cancel in the "Please wait..." window
- Playlist (right pane when selecting TV tuner channels) -> tuner:
- Explorer shell menu items -> Play, Open
- (when .ogm files are opened) Menu -> Audio -> Audio streams -> -- Ogm streams --
- Free for non-commercial use (but I think that I know why you don't want to add this string to the translatable ones )

NOT WORKING TRANSLATIONS
- All the subtitle editor menu items
- "Install skin" string. In the windows explorer menu is still present the item "Install"




Well, all other bugs mentioned in the BIG bugs post have been fixed, so all I have to say is: THANK YOU BSplayer TEAM :!: :!:

Keep up the great work :)
__________________
BSP SkinMaker (v1.07) the one and only Skin Editor for BSplayer
BSP Definitions Manager (v1.02)
BS.Player's FAQ (by BSPeter) | Italian language file (v2.57 build 1051)
Reply With Quote
  #2 (permalink)  
Old 12th December 2005
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,190
Rep Power: 28
adicoto is on a distinguished road
Default

Tizio wrote:
NOT WORKING TRANSLATIONS
- All the subtitle editor menu items

I am sure, at first opening the translated lines were there, ok. At second opening, no more. Strange things.
Reply With Quote
  #3 (permalink)  
Old 17th December 2005
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,190
Rep Power: 28
adicoto is on a distinguished road
Default

At least on my system, the bug with window resizing when pressing pauze is still present. But only for avi files. Just tested on MPEG2 files, there is no such behaviour. Using elecard.
Reply With Quote
  #4 (permalink)  
Old 17th December 2005
Junior Member
BS.Player Newbie
 
Join Date: Dec 2005
Posts: 8
Rep Power: 0
rikis is an unknown quantity at this point
Default

1) Screen blinks black, then i pause/resume with latest version in v1.37.826 (with default renderer and with overlay mixer). Downgraded to v1.36.825 and all works fine.
2) Then i try play mkv with bsplayer option subtitles disabled, in v1.36.825 and v1.37.826, all same, (I have latest matroska pack)
I get:

BSplayer v1.36.825, Unhandled exception at EIP: 004FE995
If you click 'Close' application will be terminated.
Please report this info to the author with description what were you doing.
If you have internet connection, it's recommended to send error report, this will help us solve problems faster.
Access violation at address 004FE995 in module 'bsplayer.exe'. Write of address 0000000C
EAccessViolation
Call stack: 00000000,004FE995,0040367F,004FE931,004FE909,0057F 750,00571DEC,00569736,00437819,0044FC36,00439EDC,0 044CE54,0045581B,0058C2B1
Reply With Quote
  #5 (permalink)  
Old 17th December 2005
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,190
Rep Power: 28
adicoto is on a distinguished road
Default

Some old files I've encoded with DivX 3.11 are now playing upside-down, using DivX 3.11 as decoder. I am not sure wich one of them, those encoded with fast-motion or low-motion. I'll try to identify.

VirtualDub states low-motion decompresor used. But files I've encoded 5 minutes ago don't have this problem. Strange.
Reply With Quote
Reply

Tags
normal or pro

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 06:06 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20