Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 7th January 2003
Junior Member
BS.Player Newbie
 
Join Date: Jan 2003
Location: Irvine, California
Posts: 4
Rep Power: 0
Nicholi is an unknown quantity at this point
Default Big Bug with the new build

I have no idea how this happened, but I have had one other person I know also confirm the same problem. BSplayers internal subtitle program no longer works. It will immediatly crash and not play at all if the file contains softsubs. If however you check the option "Don't show susbtitles" the file will play fine and you will need some external program to read the subs for you. This is an option I very much enjoy having in BSplayer and I hope it is either just something I am doing wrong or will be fixed soon. In the previous build i had no problems using BSplayers internal sub thinger, but now it doesn't.........oh well

Edit: forgot to mention....these files are all using divx5 (5.0.0 not 5.0.2) ogg streams and srt subs....if that has anything to do with it.

Edit2: Also tried turning on the "Use Subtitle Mixer for subtitles in OGG files" option but the same error came up. Also in the previous build, I never needed to have this option on for my ogm video files.
Reply With Quote
  #2 (permalink)  
Old 7th January 2003
Junior Member
BS.Player Newbie
 
Join Date: Jan 2003
Posts: 1
Rep Power: 0
Blue? is an unknown quantity at this point
Default

I also noticed this problem. And to add to the report:

This only happens with OGM files that have subtitles muxed into them, external subtitles work ok still. OGM with external subs(not muxed into the file) seems to still be ok, as well as AVI with external.

The player only crashes if you have subtitles set to play by default. If you attempt to start a movie without subtitles and then turn them on after it has started the player won't crash, however, the subtitles aren't displayed at all.

This is true with ALL OGM files, not just files that use the DivX 5 codec.

Well, hope this helps a bit. Previous versions worked fine, so hopefully you guys will get it working again :)
Reply With Quote
  #3 (permalink)  
Old 8th January 2003
Senior Member
BS.Player Power User
 
Join Date: Jun 2002
Posts: 156
Rep Power: 0
bluedan is an unknown quantity at this point
Default

I have an exemple against and one in favour of it.
Both cases OGM:Xvid video:Ogg Vorbis2x:SRT subs.
One it shows the subtitles using internal machine. The other starts and maybe plays for some seconds but then shuts down player immediately without any notice.
Will try if turned off subs will solve this.
Strange that it seems to be inconstant issue, or I should better say, I didn't find any difference between those two movies, except that the used Xvid build has changed and developped meanwhile.
Note: files play fine in Zoomplayer !
__________________
Keep forum organized and use the search button !! :o
Reply With Quote
  #4 (permalink)  
Old 9th January 2003
Senior Member
BS.Player Power User
 
Join Date: Jun 2002
Posts: 156
Rep Power: 0
bluedan is an unknown quantity at this point
Default

OK. I was able to open OGM in player with subtitles turned off. Instead uninstalling SubTitDis.dll didn't solve it.
This workaround is in cost of proper OGM support: Usually my movies are bilingual. But when once switching from 1st audio stream to 2nd the player crashed when trying to switch again. :x
Another sideeffect if you don't start movie through .bsi file is that chapter viewer does not show the last two chapter pictures. Also you are not able to jump from chapter to chapter neither through chapter viewer nor with CTRL-B or Y. This is pretty hard because in my bsi files where chapter information is mirrored (other is situated in OGM file!) subtitles are turned on because I normally have two sub streams.
Hmm, I was so excited to read about enhanced SRT feature, but: BST you obviously screwed something up with latest SRT tag supprt implementation. What a pity.
__________________
Keep forum organized and use the search button !! :o
Reply With Quote
  #5 (permalink)  
Old 10th January 2003
bst's Avatar
bst bst is offline
BS.Developer
BS.Player Power User
 
Join Date: Jun 2002
Posts: 181
Rep Power: 10
bst will become famous soon enoughbst will become famous soon enough
Default

I'll check this.
Reply With Quote
  #6 (permalink)  
Old 10th January 2003
Senior Member
BS.Player Power User
 
Join Date: Jun 2002
Posts: 156
Rep Power: 0
bluedan is an unknown quantity at this point
Default

Ah, thank you very much BST.
Glad to hear from you, Happy New Year, BTW!
__________________
Keep forum organized and use the search button !! :o
Reply With Quote
  #7 (permalink)  
Old 13th January 2003
Senior Member
BS.Player Power User
 
Join Date: Jun 2002
Posts: 156
Rep Power: 0
bluedan is an unknown quantity at this point
Default

Additions:
The only difference between the above mentioned OGMs is that the one that makes player quit playing actually contains tags in subtitles, while the other ogm don't.
At least an evidence that the crash is due to your last modifications concerning tag support.
Keep trying!!
__________________
Keep forum organized and use the search button !! :o
Reply With Quote
  #8 (permalink)  
Old 13th January 2003
Junior Member
BS.Player Newbie
 
Join Date: Jan 2003
Posts: 4
Rep Power: 0
Malkovich is an unknown quantity at this point
Default

ZoomPlayer doesn't work at me either :(
__________________
Life is great! :)
Reply With Quote
  #9 (permalink)  
Old 14th January 2003
Senior Member
BS.Player Power User
 
Join Date: Jun 2002
Posts: 156
Rep Power: 0
bluedan is an unknown quantity at this point
Default

Actually, the behaviour changed and bsplayer lately refuses to play ogm + subs at all :shock: , while zoomplayer is working but with horizontaly compressed image...
__________________
Keep forum organized and use the search button !! :o
Reply With Quote
  #10 (permalink)  
Old 14th January 2003
Junior Member
BS.Player Newbie
 
Join Date: Jan 2003
Posts: 4
Rep Power: 0
Malkovich is an unknown quantity at this point
Default

I made up my mind to use the BSplayer Version 085 until this sub problem is solved.
__________________
Life is great! :)
Reply With Quote
  #11 (permalink)  
Old 20th January 2003
Senior Member
BS.Player Power User
 
Join Date: Jun 2002
Posts: 156
Rep Power: 0
bluedan is an unknown quantity at this point
Default

@BST Although Nicholi stated to have used DivX codec in his OGM
-@Nicholi:did you eventually set up ffdshow to decode DivX with XVid decoder??-
there is an interesting thread over @Doom9 http://forum.doom9.org/showthread.php?s=&threadid=42205 about subtitle display problems in conjunction with b-frame decoding errors in XVid encoded OGMs. Maybe the reason for crashing bsplayer does not derive from your last optimations...
Please have a look, thank you!
__________________
Keep forum organized and use the search button !! :o
Reply With Quote
  #12 (permalink)  
Old 10th February 2003
Junior Member
BS.Player Newbie
 
Join Date: Jan 2003
Location: Irvine, California
Posts: 4
Rep Power: 0
Nicholi is an unknown quantity at this point
Default

Yes I have had ffdshow and tried uninstalled all other Sub programs, SubTitDS and VobSub and tried playing the ogm with the same problems. I do firmly believe the problem lies at fault with the new additions of Subtitle features in the new builds. I have tried the latest build with lots of different files, and it only seems to occur with OGM's that have muxed subs into them, softsubs although the only ones I have to test are DivX5.

All these files from the same group that encodes I might add, all of their files will not play with the latest official build, However I have noticed with Build 494, under Nightly builds it does play them fine, so if you install the latest and extract Build 494 over it seems to play OGMs with subs just fine now.
Reply With Quote
  #13 (permalink)  
Old 16th February 2003
Senior Member
BS.Player Power User
 
Join Date: Jun 2002
Posts: 156
Rep Power: 0
bluedan is an unknown quantity at this point
Default

Just to complete this:
Anyone having problems with distorted picture when making use of Ogg Subtitle parser should enter correct aspect ratio for movie in the corrsponding field in filter properties:16:9 or 235:100...

Still few problems in tag parsing for srt files remain alive in 494 version.
Reported somewhere in bug forum section, could just not retrieve the thread...
__________________
Keep forum organized and use the search button !! :o
Reply With Quote
Reply

Tags
big, build

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 01:35 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20