Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 15th August 2006
Junior Member
BS.Player Newbie
 
Join Date: Aug 2006
Location: Czech Republic, Prague
Posts: 2
Rep Power: 0
corpse is an unknown quantity at this point
Default BSplayer wont play XVID, even if XVID/FFDshow is installed

It's probably just me, but I can't get BSPlayer to play the Quake 3 Annihilation movie. (I was able to play it a year ago, with an older version of BSPlayer and CodecPack All-in-1 without problems.)

I'm using BSPlayer Pro version 2.10 Build 939 (Windows XP Pro SP2). I tried DivX 6.2.5.34 with "Support decoding of Generic MPEG-4 video" option enabled, but I didn't get the video to play properly (no real picture, just green lines and artifacts). So I installed Koepi's XviD package XviD-1.1.0-30122005, but even though the codec shows up in Preferences->Filter management->Filter manager as "XviD MPEG-4 Video Decoder", BSPlayer won't play the file and gives this error message:

Unknown file format (XVID)

I tried playing a bit with all the settings, re-registered xvid.ax and quartz.dll manually, but it didn't help. I tried scanning the movie with GSpot and it says I have all the right codecs installed and it can even play it using XviD, but I don't want to use GSpot as my movieplayer :). I even tried to use FDDShow, but had the same problem. I tried searching this forum for help, but didn't find anything concerning my specific problem. So now I'm really out of ideas, any help would be much appreciated.
Reply With Quote
  #2 (permalink)  
Old 15th August 2006
J7N's Avatar
J7N J7N is offline
Senior Member
BS.Player Power User
 
Join Date: Feb 2006
Location: Cyberspace
Posts: 762
Rep Power: 0
J7N is an unknown quantity at this point
Default Re: BSplayer wont play XVID, even if XVID/FFDshow is install

Ffdshow can play just about any MPEG-4 video track if decoding is enabled in the configuration window. What filters does Gspot display as being used for this video?
Reply With Quote
  #3 (permalink)  
Old 15th August 2006
Junior Member
BS.Player Newbie
 
Join Date: Aug 2006
Location: Czech Republic, Prague
Posts: 2
Rep Power: 0
corpse is an unknown quantity at this point
Default

GSpot uses the XviD MPEG-4 Video decoder and renders the movie perfectly. What bothers me is this weird error - unknown file type (XVID). Other XviD movies display just fine in BSPlayer, but this one doesn't.
Reply With Quote
  #4 (permalink)  
Old 15th August 2006
J7N's Avatar
J7N J7N is offline
Senior Member
BS.Player Power User
 
Join Date: Feb 2006
Location: Cyberspace
Posts: 762
Rep Power: 0
J7N is an unknown quantity at this point
Default

Quote:
Originally Posted by corpse
GSpot uses the XviD MPEG-4 Video decoder
Only?
Reply With Quote
Reply

Tags
installed, play, xvid, xvid or ffdshow

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules

LinkBacks (?)
LinkBack to this Thread: http://forum.bsplayer.com/bug-reports-codecs/7762-bsplayer-wont-play-xvid-even-if-xvid-ffdshow-installed.html
Posted By For Type Date
Official BS.Player forums - Threads Tagged with xvid This thread Refback 5th April 2009 06:14 PM


All times are GMT +1. The time now is 03:09 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19