Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 10th January 2003
Junior Member
BS.Player Newbie
 
Join Date: Jan 2003
Posts: 2
Rep Power: 0
TheBrain is an unknown quantity at this point
Default strange problem with XviD B-Frames

i got a very strange problem:

when i play a XviD movie, encoded with b-frames and the filename is between 9 and 18 chars long the message "Broken B-Frames, Mising Ref Frame" is blinking while playing and it comes to standstills.

if i change the filename to <9 chars or >18 chars (doesn't matter which chars i use), the movie is played correctley.

i encoded this video once with "Packed Bitstream" activated and once without. same result.

TheBrain
Reply With Quote
  #2 (permalink)  
Old 11th January 2003
Junior Member
BS.player Regular User
 
Join Date: Nov 2002
Location: France
Posts: 24
Rep Power: 0
Manao is an unknown quantity at this point
Default

I can't reproduce it.

Do you have this problem only with BSPlayer, or with every player ?
Which OS ? Do you use ffdshow for playback ? Or Xvid DSF ?
Reply With Quote
  #3 (permalink)  
Old 11th January 2003
Junior Member
BS.Player Newbie
 
Join Date: Jan 2003
Posts: 2
Rep Power: 0
TheBrain is an unknown quantity at this point
Default very strange...

that problem is really strange...
i have the following directory structure:

Code:
M:\TEMP DVD
|   Bowfinger - CD1.avi
|   Bowfinger - Deutsch.ac3
|   Bowfinger - English.ac3
|
\---Bowfinger_CD1
    |   autorun.inf
    |   bowfinger.bsi
    |
    +---BSPlayer
    |   |   bplay.exe
    |   |   bsrendv.dll
    |   |
    |   +---lang
    |   |      ...
    |   |
    |   \---Skins
    |          ...
    |
    +---Data
    |       autorun.exe
    |       autorun.ini
    |       bowfinger.bmp
    |
    +---Install
    |       BSPlayer v0.85 Build 492.exe
    |       XviD (23.12.02).exe
    |
    \---Subtitles
            Bowfinger - Deutsch.srt
            Bowfinger - English.srt
if the movie ("Bowfinger - CD1.avi") is in the directory as above there are no problems to play it. but if it's in the subdir /Bowfinger_CD1 it doesn't work as i described it in my first post.

does bsplayer scan the directory for any files (e.g. .bsi-files) ?
but if i rename the .bsi file and change the extension, the problem is still there.

i use Win2000 Prof., BSPlayer v0.86 (the one in the directory above is still v0.85) and XviD version of 23. Dec '02

TheBrain
Reply With Quote
Reply

Tags
bframes, strange, xvid

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 10:36 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19