Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Bug Reports And Codecs (http://forum.bsplayer.com/bug-reports-codecs/)
-   -   won't play .avi files with XviD MPEG-4 and DivX3 codecs (http://forum.bsplayer.com/bug-reports-codecs/8748-wont-play-avi-files-xvid-mpeg-4-divx3-codecs.html)

teapot 28th February 2008 02:29 AM

won't play .avi files with XviD MPEG-4 and DivX3 codecs
 
I just purchased BS.Player 2.26 PRO lite. Before that I used the free version for years, so it was quite an old version, don't ask which, as I don't know. The old version played all .avi files with no problem.
I probably wouldn't have bothered to upgrade but I had a problem with some trojans a few weeks ago and some antivirus happened to delete bsplayer from my system, thinking it's malicious software. (??!)

I wanted BSPlayer back, and having realised the free version comes with piles of adware, I decided to buy the pro version.

So I downloaded and installed BS.Player 2.26 PRO lite, and lo and behold, it's not like the old one, it won't play my old .avi files. I don't like that, I feel like a bit of an idiot, having just paid for it to watch it stop working.
Surely that's not right.

As far as I can make out, it won't play .avi files with XviD MPEG-4 and DivX3 codecs. According to VideoInspector both of those are installed on my computer, and those same files have no problem playing in other players like winamp or VLC.

What happens with BSplayer is that when I try to open an .avi file with those codecs, it gives me an error and offers to close, restart or continue the application. It also gives me a huge bug report (I'll post info from it if it's necessary)

It plays all other files I've tried - .mpg files with MPEG-1 codecs, and vob files, those have worked.


As for my computer, I'm running WindowsXP SP2.


I really hope you can help me, would be a shame to not get this to work now that I've paid for it.

Ledah 28th February 2008 03:48 AM

Well if you don't have xvid decoder install on your pc bsplayer won't play AVI files.
Atleast you must have DivX installed to play AVI files.

Here try this link to get DivX player, once you installed it your bsplayer should able to play AVI files.http://www.divx.com/?lang=en

ps: just download the free version.

teapot 28th February 2008 03:53 AM

But I ALREADY HAVE DivX installed. That whole package.

teapot 28th February 2008 04:03 AM

Ok, for the sake of trying it, I just upgraded my divX from 6.7 to 6.8. No change in BS player. Here's another thing I noticed, which can't be right:

http://img.photobucket.com/albums/v6...screenshot.jpg

Why is the whole video section blanked out? Why is BSplayer refusing to read my codecs?

adicoto 28th February 2008 06:58 AM

To play Div3 Content, you just need to install DivX 3.11 alpha. It's free and you can download it from the internet. It remains one of the best codecs. You don't need a later release, such as DivX 5 or 6. Just reinstall XviD and let it decode DivX content. Those builds are needed just in case you want to play some special content like .divx files.
Once you have DivX 3.11 installed and open a file encoded with it, the settings won't be greyed out any more and you cand adjust decoding either from the decoder interface, either from BSPlayer interface, as in the picture above.

J7N 28th February 2008 10:02 AM

It is possible that during the cleanup of your PC some video decoders also got deleted. You don't need this DivX package. Remove it and install ffdshow. It will allow you to play all MPEG-4 formats and comes with no nonsense like DivX6.

Quote:

It remains one of the best codecs.
As they say on Wikipedia: Citation needed.

teapot 29th February 2008 10:43 PM

Quote:

Originally Posted by J7N
It is possible that during the cleanup of your PC some video decoders also got deleted. You don't need this DivX package. Remove it and install ffdshow. It will allow you to play all MPEG-4 formats and comes with no nonsense like DivX6.

Quote:

It remains one of the best codecs.
As they say on Wikipedia: Citation needed.

yay!! that worked!

Thank you so much!!

Ico-man 4th March 2008 08:42 AM

"and some antivirus happened to delete bsplayer from my system, thinking it's malicious software. (??!) " !? What antivirus are your using?

P.S.: BS.Player does not uninstall any decoders during instalation of new version, so this problem you had might be connected to the problems with trojans on your PC and their cleanup, like suggested by J7N.

teapot 4th March 2008 12:14 PM

Quote:

Originally Posted by Ico-man
"and some antivirus happened to delete bsplayer from my system, thinking it's malicious software. (??!) " !? What antivirus are your using?

P.S.: BS.Player does not uninstall any decoders during instalation of new version, so this problem you had might be connected to the problems with trojans on your PC and their cleanup, like suggested by J7N.

well, I used quite a few, I used antivir XP (don't think that one did anything) and a-squared free and combofix and some other stuff. I think they deleted it cos the free version comes with adware so it thought the whole bsplayer package was malware.
Not sure if that's what caused the problem with the codecs though, that could have been the virus/trojan, who knows.

ps. why aren't quotes working?

J7N 4th March 2008 12:40 PM

Quote:

Originally Posted by teapot
ps. why aren't quotes working?

Some problem in PHPBB. You must enable "Disable HTML in this post" option. You can make this the default choice by editing your profile.

teapot 4th March 2008 04:40 PM

Quote:

Originally Posted by J7N
Quote:

Originally Posted by teapot
ps. why aren't quotes working?

Some problem in PHPBB. You must enable "Disable HTML in this post" option. You can make this the default choice by editing your profile.

ahhh, ok, thanks!


All times are GMT +1. The time now is 07:09 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20