Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Bug Reports And Codecs (http://forum.bsplayer.com/bug-reports-codecs/)
-   -   [FIXED] Bug conc. subtitle pop-up window (http://forum.bsplayer.com/bug-reports-codecs/9709-fixed-bug-conc-subtitle-pop-up-window.html)

NikLok 3rd June 2009 09:55 AM

[FIXED] Bug conc. subtitle pop-up window
 
In version 2.40 - 2.41.101 i watch one bug.
When i select new film, the playing not started because appeared window with question - "Local subtitle not found, search him in internet!". Sorry!!! In my setting the checkbox "subtitle disable" is SETTED!!! What the sheet!!! Correct this please.

BSPeter 3rd June 2009 07:22 PM

And which boxes are checked/selected under:
(rightclick >) Options > Preferences > Subtitles > [Online subtitles] ?
:wink:

NikLok 3rd June 2009 08:55 PM

Quote:

Originally Posted by BSPeter (Beitrag 37568)
And which boxes are checked/selected under:
(rightclick >) Options > Preferences > Subtitles > [Online subtitles] ?
:wink:

All checkbox is setting to off - cleared.

BSPeter 3rd June 2009 09:09 PM

Bug confirmed (for version 2.41.1003).
Thx for reporting!
:wink:

NikLok 6th July 2009 11:35 AM

Океy! Pop-up window don't apeared in buil 1005, but on avi window i see text "search subttitles", "subtitles not found". I think that this text dont be apear, because in my settings i set chekbox "subtitles disabled"

And why in help BS have version 2.42, but in skin - main window drawing version 2.41 ?!?!?

How to run instalation without downloading codecs from internet ?!

NikLok 29th August 2009 09:21 AM

Bug once more
 
In version 2.43 b 1008 bug with pop up subtitles window are present again!!!

Rocho 8th February 2010 02:27 PM

[CONFIRMED/NOT FIXED] I can't turn off checking for online subtitle
 
I go to subtitle > online subtitle > unchecked all and unchecked 2 available urls. When i close/open BS those 2 online site are checked again.
How to fix this?
Every time when i start video type i get the message do i want to download subtitle.

BSPeter 8th February 2010 03:18 PM

Quote:

Originally Posted by Rocho (Beitrag 40632)
... Every time when i start video type i get the message do i want to download subtitle.

Confirmed re. not being able to turn off checking on-line subs; tried builds 1022 and 1023ß.
:cry:
Quote:

Originally Posted by Rocho (Beitrag 40632)
I go to subtitle > online subtitle > unchecked all and unchecked 2 available urls. When i close/open BS those 2 online site are checked again...

Cannot confirm!
(1) Where did you -upon installation- select your settingsfile to be stored and
(2) do you have the correct rights/privileges to access that folder?
:wink:
P.S.: When posting please ALWAYS mention at least BS.Player's build number!!

Rocho 8th February 2010 11:18 PM

It is build 1022.

I installed by default. I didn't change nothing except in preferences after installation. Configuration, nothing special.

BSPeter 7th March 2010 02:12 PM

Bug still present in 1024beta
:sad:

Ico-man 8th March 2010 08:51 AM

In 1024 and earlier, if Enable online subs was disabled from Preferences, BS.Player asked one more time if you wanted to use online subtitles, if you decided on NO and checked 'Do not display this message anymore' you will not see this message again.

Will be corrected in 1025.

BSPeter 8th March 2010 09:21 PM

Unchanged in 2.50.1025β and 2.50.1026β !
:confuse:

BSPeter 22nd March 2010 04:56 PM

Unchanged in final 2.52.1028/1029.
:confuse:

Ico-man 24th March 2010 12:08 PM

In 2.52.1030 (and later) once you deselect it in popup window, BS.Player will never search for online subs (or alternatively if you uncheck option "Enable online subs" in Preferences ).

BSPeter 24th March 2010 12:42 PM

Quote:

Originally Posted by Ico-man (Beitrag 41005)
In 1024 and earlier, if Enable online subs was disabled from Preferences, BS.Player asked one more time if you wanted to use online subtitles, if you decided on NO and checked 'Do not display this message anymore' you will not see this message again.

Will be corrected in 1025.

Quote:

Originally Posted by Ico-man (Beitrag 41180)
In 2.52.1030 (and later) once you deselect it in popup window, BS.Player will never search for online subs (or alternatively if you uncheck option "Enable online subs" in Preferences ).

So, what has changed in 1030?:confuse:

Ico-man 25th March 2010 10:20 AM

Now it will work like stated.

BSPeter 25th March 2010 02:02 PM

Option "Enable online subs" unchecked in Preferences (as well as both urls). BS.Player (1030) nevertheless persists in asking (pop-up window) if online subs should be searched. So it doesn't work as stated "(or alternatively if you uncheck option "Enable online subs" in Preferences)".

Be that as it is .... if the user has already willingly/deliberately chosen to NOT "Enable online subtitles" (and perhaps also has both url's deselected), such user surely shouldn't expect a screen like "No local subtitles found. Do you want to search for subtitles online? (Yes) (No)". The user's option to check a box in that window "Don't show this message again" doesn't undo the fact that such window shouldn't pop up in the first place (since the user has already clearly indicated his/her preference by not enabling online subs. So BS.Player annoys such user at least once)!.
I understand BS.Player team is proud of the feature that BS.Player can download and use online subtitles. I personally would have made it the default, but then the more logical option should have read to "Disable online subtitles" (as opposed to Enable ..).
However, if BS.Player team wishes to stick to the existing "procedure" (that way possibly annoying users at least once), then simply say so and don't give the impression that it will be changed, like when you wrote "Will be corrected in 1025" resp. "or alternatively if you uncheck option "Enable online subs" in Preferences".
This in order to enable us to also inform users accordingly on this forum (to the effect that it needn't be more than a one-time-only nuisance).
:wink:

Ico-man 26th March 2010 03:42 PM

It should work like i said. Maybe its your old installation interffering, but basically, all you need to do is uncheck it in Preferences OR check Do not display anymore in popup window, and you should not see any online subs notifications in the future.

Could you try clean new install or delete bsplayer.xml file ( or temporarily move it somewhere) and run BS.P. But you have to click ONCE (in popup or Prefs) that you don't want to use this feature anymore.

:wink:

BSPeter 27th March 2010 02:27 PM

(1) closed BS.Player
(2) renamed bsplayer.xml
(3) re-installed BS.Player 1030 (settings in installation folder; have to do so to be able to run more versions)
(4) started BS.Player
(5) deselected all checkboxes of [Online subtitles]
(6) exited and restarted BS.Player
(7) verified settings under [Online subtitles]: all unchecked
(8) loaded a video from my HD (with no accompanying subtitle file)
(9) presto: pop-up window :frown:

further on a clean system (vista-laptop on which BS.Player has never been installed before):
(a) downloaded and installed free version (settings in installation folder)
(b) made sure to have all rights/privileges/writing rights to change settings
(c) as -4-5-6-7- above
(d) loaded a video from a USB-disk (with no accompanying subtitle file)
(e) presto: pop-up window :frown:

So just unchecking under preferences does NOT do the trick (but I understand from you it should)!!

BSPeter 27th March 2010 03:02 PM

Also in this connection a possible 'logical' sequence of pop-ups:
http://members.home.nl/van.raak/NoSubsOrMaybe.png
(Added this to my bugs/cosmetical issues-post.)
:confuse:


All times are GMT +1. The time now is 11:46 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19