Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 3rd February 2003
Feñiz's Avatar
Member
BS.player Regular User
 
Join Date: Jun 2002
Location: Spain
Posts: 98
Rep Power: 0
Feñiz is on a distinguished road
Default Still a litle bug when using SRT format tags (sorry BST)

Something strange happens with a line in a SRT subtitle file ends by "[/i]."

The dot is showed as some strange characters. For example, this subtitle:

I say Hello...

is showed like that:

I say Hello###

# are strange characters (not always a "#")
Reply With Quote
  #2 (permalink)  
Old 3rd February 2003
Senior Member
BS.Player Power User
 
Join Date: Jun 2002
Posts: 156
Rep Power: 0
bluedan is an unknown quantity at this point
Default

BST noted in last nightly build 0.86-494 that there are still problems with tags in SRT subs. He might have meant something like this, which is really strange, I admit.
Did you come across any further mishaps in the meantime? I didn't have the opportunity to test it myself so far.
I think I will try to generate a test SRT file.
__________________
Keep forum organized and use the search button !! :o
Reply With Quote
  #3 (permalink)  
Old 3rd February 2003
Feñiz's Avatar
Member
BS.player Regular User
 
Join Date: Jun 2002
Location: Spain
Posts: 98
Rep Power: 0
Feñiz is on a distinguished road
Default

I see at Changes.txt, BST talk about SRT format and the tags. He wrote:

Still some problems with [b],[i],<u> tags in SRT subtitles

... but I thought he means:

Still some problems with [b],[i],<u> tags in SRT subtitles CORRECTED

The only problem I found with tags and SRT subtitles is that.

PD: A new SubRip version is out, and some new tags had been added for supporting subtitle colours.....
Reply With Quote
  #4 (permalink)  
Old 3rd February 2003
Senior Member
BS.Player Power User
 
Join Date: Jun 2002
Posts: 156
Rep Power: 0
bluedan is an unknown quantity at this point
Default

My experiences say that in each line the last letter is missing.
If it includes tags, the closing tag is shown, also the last character erased.

exemple:
Hello, my name is Sandy.</i
__________________
Keep forum organized and use the search button !! :o
Reply With Quote
  #5 (permalink)  
Old 3rd February 2003
Feñiz's Avatar
Member
BS.player Regular User
 
Join Date: Jun 2002
Location: Spain
Posts: 98
Rep Power: 0
Feñiz is on a distinguished road
Default

I think you're talking about SRT subtitles in OGG files.

I'm using SRT and AVI files, and the characters are showed correctly, except when a line finish in a [/i] and then a dot ([/i].)
Reply With Quote
  #6 (permalink)  
Old 3rd February 2003
Senior Member
BS.Player Power User
 
Join Date: Jun 2002
Posts: 156
Rep Power: 0
bluedan is an unknown quantity at this point
Default

Yes, you're right, Feniz.
In my case it's SRT embedded in OGM.
I think the last fixes from BST focussed on that, so I assumed you were writing about this, too.
(Besides I didn't see you mention AVIs before... )
__________________
Keep forum organized and use the search button !! :o
Reply With Quote
Reply

Tags
format, litle, srt, tags

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 02:44 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20