Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > General Talk And Support

General Talk And Support General talk and peer-to-peer support about BS.Player and other video and audio multimedia players.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 31st October 2011
Junior Member
BS.Player Newbie
 
Join Date: Oct 2011
Posts: 4
Rep Power: 0
wolfgang is on a distinguished road
Unhappy [SOLVED] Problem with sound in mp4 file

Hello, I have been trying to watch an mp4 file with 6 sound channels but bsplayer 2.58 recognizes only 2, and plays the file with only 2 sound channels, while in avi files with surround it has no problem. I played the file in other media players (wmp and VLC) and the sound was ok. I have downloaded all the availabe codecs that bs suggested me to download when I first installed it. I have also tried to install 3ivx and Mp4 splitter in order to fix the problem, but with no result.

Any suggestion would be appreciated...
Reply With Quote
  #2 (permalink)  
Old 31st October 2011
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 49
Posts: 5,118
Rep Power: 25
adicoto is on a distinguished road
Default

1. When playing such a file, which filters are used ? ( rightclick -> options -> filters -> advanced)
2. If ffdshow audio it's used, can you get into it's options -> mixer -> is there enabled 5.1 ?
3. If it's another audio decoder, can you post here which is ?
Reply With Quote
  #3 (permalink)  
Old 31st October 2011
Junior Member
BS.Player Newbie
 
Join Date: Oct 2011
Posts: 4
Rep Power: 0
wolfgang is on a distinguished road
Default

As far I can see ffdshow is not being used. Microsoft DTV-DVD Audio Decoder and DTV-DVD Video Decoder are being used instead.
Reply With Quote
  #4 (permalink)  
Old 1st November 2011
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 49
Posts: 5,118
Rep Power: 25
adicoto is on a distinguished road
Default

Run codecmanager.exe from BSPlayer's install folder and allow installing all codecs (they are used only by BSPlayer and don't mix with installed ones).
Normal filters for decoding an MP4 file should be Haali media splitter / ffdshow video decoder / ffdshow audio decoder if internal codecs are installed (as before mentioned) or Gabest MP4 splitter / CoreAVC / CoreAAC if independent codecs are installed. BSPlayer uses window's filters (that you mentioned above) if no other filters can be found. The filters you mentioned can handle H264 decoding and AAC decoding...but...poorly

AND...be sure you have UAC turned off so filters can be installed.
Reply With Quote
  #5 (permalink)  
Old 1st November 2011
Junior Member
BS.Player Newbie
 
Join Date: Oct 2011
Posts: 4
Rep Power: 0
wolfgang is on a distinguished road
Default

OK. So, while UAC was off, I reinstalled bs and I allowed the installation of the codecs. Bs now uses ffdshow Video decoder and MPA Decoder Filter. In the options of MPA Decoder Filter I switched the audio to 5.1, but I still have 2 channel audio...

Any Ideas
Reply With Quote
  #6 (permalink)  
Old 2nd November 2011
Junior Member
BS.Player Newbie
 
Join Date: Oct 2011
Posts: 4
Rep Power: 0
wolfgang is on a distinguished road
Default

ΟΚ. Problem fixed
I suppose it was a codec priority problem. After uninstalling all the external codecs that I had installed on my own and not via codecmanager, bs started using AC3 and now I have 6 channel audio.. Yay !

Thank you for your replies
Reply With Quote
Reply

Tags
file, mp4, sound

Thread Tools
Display Modes

Posting Rules

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with file path / can't open file / no message beholder4096 Bug Reports And Codecs 2 8th February 2011 04:28 AM
Rendering Problem Ringola General Talk And Support 10 10th May 2008 05:33 PM
Problem with Xvid File: sound with no video rscaputo General Talk And Support 3 3rd November 2005 08:38 PM
Problem playing an .avi file -- freezing & crashing Sesca5 General Talk And Support 4 10th August 2005 11:45 PM
No sound from AVI file right after playing a rmvb file ww220 General Talk And Support 3 16th April 2005 05:12 AM


All times are GMT +1. The time now is 07:53 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19