Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > General Talk And Support

General Talk And Support General talk and peer-to-peer support about BS.Player and other video and audio multimedia players.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 7th February 2006
Member
BS.player Regular User
 
Join Date: May 2004
Posts: 45
Rep Power: 0
Anthony2816 is an unknown quantity at this point
Default Audio out of sync on some video files

On some of the video files I've downloaded, both avi and mgp, the audio is out of sync with the video. It's as if the audio was recorded at a different speed, so the further I go into the video, the more the difference between the video and audio.

According to Gspot, I have the correct codecs installed.

Is there any way to fix this, or does it just mean the video files are bad?
Reply With Quote
  #2 (permalink)  
Old 7th February 2006
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,163
Rep Power: 27
adicoto is on a distinguished road
Default

It could be a bad video file, a bad audio decoder or a slow CPU.
Reply With Quote
  #3 (permalink)  
Old 11th June 2006
Member
BS.player Regular User
 
Join Date: May 2004
Posts: 45
Rep Power: 0
Anthony2816 is an unknown quantity at this point
Default

No new ideas on this?

Guess I've just been getting some video files in which the audio wasn't recorded in sync with the video?
Reply With Quote
  #4 (permalink)  
Old 11th June 2006
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,163
Rep Power: 27
adicoto is on a distinguished road
Default

1. It could be a bad video file, as you said before
2. It could be a bad audio decoder or your audio card is trying to use hardware acceleration for MP3.
3. Your CPU speed may be too slow and can't decode fast enough the streams.

So, can you provide more details so we can try to help you ? What CPU, wich audio\video decoder is used on those files, wich audio card do you use, does disabling hardware acceleration help ?
Reply With Quote
  #5 (permalink)  
Old 12th June 2006
Member
BS.player Regular User
 
Join Date: May 2004
Posts: 45
Rep Power: 0
Anthony2816 is an unknown quantity at this point
Default

Um, lessee. My computer has a P4, 2.8 ghz, 1 gb PC3200 ram, and a Creative SB Audigy 2 Platinum EX.

Running the latest offending video file through Gspot shows:

Container: MPEG-1 System Stream << 1 vid, 1 aud, 1 other, Sys Bitrate 1394 kb/s

Audio: MPEG-1 Layer 2; Codec(s) Installed

Video: Codec: MPEG_Payload Name: MPEG-1 Stat: Codec(s) are Installed.


Not sure how to turn off hardware acceleration.
Reply With Quote
  #6 (permalink)  
Old 12th June 2006
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 23
Tizio will become famous soon enough
Default

To turn off the audio hardware acceleration, if you installed a sound card utility probably you'll be able to do that directly in it, otherwise you can open Windows Control Panel, click on the "Sound and Audio Periferals" icon. Now select Audio tab and in "Sound playback" press the Advanced button. On the new window go to the second tab and lower the Hardware acceleration slider.

(I don't have the Windows XP English version, so the voices may be a bit different, but I think they are understandable)
__________________
BSP SkinMaker (v1.07) the one and only Skin Editor for BSplayer
BSP Definitions Manager (v1.02)
BS.Player's FAQ (by BSPeter) | Italian language file (v2.57 build 1051)
Reply With Quote
  #7 (permalink)  
Old 12th June 2006
Member
BS.player Regular User
 
Join Date: May 2004
Posts: 45
Rep Power: 0
Anthony2816 is an unknown quantity at this point
Default

Thanks...I knew I'd seen that somewhere.

Okay, I can now say that disabling audio hardware acceleration had no effect on the out-of-sync sound.

I also tried playing the video file back on a different computer, and it's still out of sync there.

Also makes no difference whether I use BSPlayer or Windows Media Player.
Reply With Quote
  #8 (permalink)  
Old 12th June 2006
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,163
Rep Power: 27
adicoto is on a distinguished road
Default

In this case I am afraid that your file is bad. But, still, let's try one last option:
If you open the file in BSPlayer, wich filters are used for playing the file ?
(rightclick->options->filters)
Reply With Quote
  #9 (permalink)  
Old 12th June 2006
Member
BS.player Regular User
 
Join Date: May 2004
Posts: 45
Rep Power: 0
Anthony2816 is an unknown quantity at this point
Default

I've never used the filter option, so it's whatever the default ones are.

How do I tell which ones are being used? The non-grayed-out choices are:

Default DirectSound Device
MPEG Video Decoder
MPEG Audio Decoder
Advanced

I kind of suspected that the file is bad, although I do seem to get quite a few of them. Most are downloaded TV episodes...
Reply With Quote
  #10 (permalink)  
Old 12th June 2006
artam's Avatar
Member
BS.player Regular User
 
Join Date: Apr 2004
Posts: 98
Rep Power: 16
artam is on a distinguished road
Default

Anthony2816>

Unfortunately, your video files are bad encoded. This is the typical feature of videos from coders that don't understand principles of A/V sampling. Using cheap TV card and separate sound card (or on-mainboard chip) make this out-of-sync feature unavoidable, especially when sampling audio directly on 44.1 kHz instead of 48 kHz. Soud cards run internally on 48 kHz and the sample rate 44.1 is mostly just interpolated. Moreover, video sampling ADC and audio sampling ADC are unsynchronized because of running with separate oscillators.

There is nothing else to do with such a mpeg files than resample the sound track to correspond with video track length. In avi file there is the possibility to correct the header with fps value to match the video length with audio without resampling anything (using VirtualDub for example), however the fps value will not correspond any video standart (you can get something like 25.007 fps or 23.983...), it will be sure playable on PC, but if you decide to make the mpeg from it, you will have to make the fps back to 25.000 (or 23.976 for NTSC) and resample the sound track.
Reply With Quote
  #11 (permalink)  
Old 12th June 2006
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,163
Rep Power: 27
adicoto is on a distinguished road
Default

Old MPEG audio decoder that is built-in windows do often get out of sink on 48.000 VBR files. YOu could try to install an alternate MPEG decoder such as Elecard (moonlight) or BitCtrl.
Reply With Quote
  #12 (permalink)  
Old 12th June 2006
Member
BS.player Regular User
 
Join Date: May 2004
Posts: 45
Rep Power: 0
Anthony2816 is an unknown quantity at this point
Default

Thanks for the info!
Reply With Quote
  #13 (permalink)  
Old 12th June 2006
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,163
Rep Power: 27
adicoto is on a distinguished road
Default

Please come back and post the results.
Reply With Quote
  #14 (permalink)  
Old 12th June 2006
artam's Avatar
Member
BS.player Regular User
 
Join Date: Apr 2004
Posts: 98
Rep Power: 16
artam is on a distinguished road
Default

2adicoto>
AFAIK these TV series are mostly coded as VCD video MPEG-1 stream and the 48.000 audio would be not correct for VCD standard, reasonable software will force 44.100 when selecting VCD profile.

I think that the decoder is not the case of audio unsync, IMO it is due to primary bad grabbing with all arising consequences. On a hardware wihout professional synchronized A/D converters I would recommend allways to grab at 48.000 and then to resample to 44100, the time difference after cca 1 hr (the usual length of an episode) will probably stay as low as no further time stretching will be necessary.
Reply With Quote
  #15 (permalink)  
Old 12th June 2006
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,163
Rep Power: 27
adicoto is on a distinguished road
Default

Most of the TV episodes are XviD :D.
If you are right, than we can't help. We can post here a tutorial to transform MPEG files to .avi using VirtualDub. I think I've posted it somwere around here.
If I am right, we may be of some help with decoder changing.
I hope I am right (just because of that)

Just thinking, saw plenty of files on the net as KVCD, wich is a non-standard VCD type.
Reply With Quote
  #16 (permalink)  
Old 14th June 2006
artam's Avatar
Member
BS.player Regular User
 
Join Date: Apr 2004
Posts: 98
Rep Power: 16
artam is on a distinguished road
Default

Quote:
Most of the TV episodes are XviD
Well, it depends on people and what p2p you are searching for. Just tell you, what people are - I know guys they grab TV series primarily in MPEG1 just because it is far less CPU power consuming that coding directly to XviD, but after that they convert that crap into XviD as final... :? Can anybody understand that ? I can't :shock: . Good advices didn't work for them :( .

But I think I'm right :D so decoder changing will be useless.
Reply With Quote
  #17 (permalink)  
Old 15th June 2006
J7N's Avatar
J7N J7N is offline
Senior Member
BS.Player Power User
 
Join Date: Feb 2006
Location: Cyberspace
Posts: 762
Rep Power: 0
J7N is an unknown quantity at this point
Default

Quote:
I know guys they grab TV series primarily in MPEG1 just because it is far less CPU power consuming that coding directly to XviD, but after that they convert that crap into XviD as final
So that's why analog TV rips suck so hard? Good to know. :)
Reply With Quote
Reply

Tags
audio, sync, video

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 05:57 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20