Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > General Talk And Support

General Talk And Support General talk and peer-to-peer support about BS.Player and other video and audio multimedia players.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 10th April 2007
Default_Def's Avatar
Junior Member
BS.player Regular User
 
Join Date: Apr 2007
Posts: 16
Rep Power: 0
Default_Def is an unknown quantity at this point
Default Error after installing BSplayer *please help*

An interesting program :D

I was watching some *.mkv files on my computer with 'VLC media player', and the video kept on stopping but the sound kept on going on, then the video would jump and catch the audio that never had a problem.

So, thinking it was my computer (I was doing something that took a bit of CPU power at the same time), I went on my moms computer, found out she didn't have 'VLC Player' installed to watch the files, instead it had BSplayer. :?

I was able to watch the file perfectly ( I still can't figure out how to turn off the sub titles, I even went to options and disabled them, but they still shows up ( in VLC player, I can turn them off or switch between sub01 and Sub 02., so does anyone know if this is just a bug in BSplayer or something?)

So, I went back to my computer and installed BSplayer (v1.37 - Don't want ad-ware on my computer - also want to test it out first) and after installing and restarting the computer.
I set *.mkv files to started up by default with BSplayer, but after I double clicked the file, this error pops up.

Error Message:
http://img175.imageshack.us/img175/1988/bserrorjo7.jpg

I noticed this error only happens if VLC Player is also installed on the same computer, I tried installing BSplayer (using the exact same instillation (*.exe) file on another computer without VLC Player installed, and it was able to play it perfectly, no problems.

Any idea what is going on? :?

Also: If it does this in the free version , will these two players conflict even worse if I decide to get the PRO version of BSplayer?

Ty in advance! :)

---
:!:
BSplayer: v1.37 (build 826, 11. Dec 2005)
Computer Info:
OS: XP Home SP2
DirectX: v9.0c
RAM: 512MB
CPU: 1.003GHz
Used gspot (v2.70a Build 20070222): File works (audio/video works perfectly).
Reply With Quote
  #2 (permalink)  
Old 10th April 2007
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

The subtitles you were seeing probably were rendered by VobSub (or Vsfilter). If you installed it by your own will, then is OK and you could disable the subtitles from the green icon in systray. If you didn't installed, then it came from a codec pack. If you don't need it, uninstall it.
On the other hand, if you have MKV with internal and external subtitle you may experience some problems, especially if one of the subtitles are in vobsub format. If this is the case, in options->preferences->filter management, enable both options. Can you also tell us if you use Haali media splitter for MKV ? (play an mkv->options->filters->advanced and click on the one named "source"). If you install Gabest mkv splitter do you have the same problem ?
Reply With Quote
  #3 (permalink)  
Old 10th April 2007
J7N's Avatar
J7N J7N is offline
Senior Member
BS.Player Power User
 
Join Date: Feb 2006
Location: Cyberspace
Posts: 762
Rep Power: 0
J7N is an unknown quantity at this point
Default

VideoLAN Client has nothing to do with BSPlayer. It could not have caused this error.

You should run other tasks in Idle priority while watching video. You should also get a fast decoder and make sure it is not doing any 'post-processing'. Your computer must be capable of decoding the highest bitrate section of your video in realtime.

__
PS: I keep wondering why they have chosen this complex and resource demanding format (H.264/CABAC) for distributing hi-resolution videos, while at the same time most standard definition material comes as ASP or transcoded MPEG-2.
Reply With Quote
  #4 (permalink)  
Old 10th April 2007
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

I assume he have VLC from a codec pack. That's where I believe the errors came up.
No comments about your PS
Reply With Quote
  #5 (permalink)  
Old 10th April 2007
Default_Def's Avatar
Junior Member
BS.player Regular User
 
Join Date: Apr 2007
Posts: 16
Rep Power: 0
Default_Def is an unknown quantity at this point
Default

"...You should also get a fast decoder and make sure it is not doing any 'post-processing'. Your computer must be capable of decoding the highest bitrate section of your video in realtime. .."
And how do I check/do this?

"...I assume he have VLC from a codec pack. That's where I believe the errors came up..."
I got LVC Player form the site, non packaged with anything**

Ok, normally when I double click a *.mkv file, it loads file then plays fine (before on other computer without VLC player on as well) , but I get this instead:

- Double click file
- After a few seconds, get error in first post.
- I hit 'continue'
- I then hit the play button in the player
- The player starts to play the AUDIO ONLY, the video for some reason is nowhere to be found, as far as I can tell, it's not disabled or anything, but I see nothing at all.

Update:
I can right click -> Video -> Full Screen (just hitting 'F' works too) but the Video doesn't show up, unless I do this every time.

Also: The audio 'disappears' sometimes when I do above (ok, only once so far, but still, it’s the idea)


"...Can you also tell us if you use Haali media splitter for MKV ? (play an mkv->options->filters->advanced and click on the one named "source").."

I checked, it says "Haali Media Splitter v1.7.7.5"

"...If you install Gabest mkv splitter do you have the same problem ?..."
What is that, and how will that help?

I right clicked the green arrow in the taskbar, and was able to select, no sub titles, so now I know how to sdo that, hope it works.

**As far as I can tell, I only have one Codex packs installed:
‘Combined Community Codex Pack (CCCP)2007-20-22’

I installed it a bit ago, when I was trying to watch some *.ogm files (or were they *.avi files, I forgot) anyway, I was told to install this (I decided on this one, from a list of Codex Packets that was recommended to me)

I noticed this error only happens when I have both VLC Player and BSplayer installed on the same OS, why does this happen?
Reply With Quote
  #6 (permalink)  
Old 10th April 2007
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

Haali media splitter is known to have issues with BSPlayer (unfortunately). Many problems were solved by uninstalling Haali splitter and installing Gabest splitter. (This is the one I use if that is of any help).
MKV files come nowadays encoded with x264 as video. So, CoreAVC anc CoreAAC will be also needed. But as far as I remember, they are included in CCCP. If not, try to uninstall the codec pack and install those.
Reply With Quote
  #7 (permalink)  
Old 10th April 2007
J7N's Avatar
J7N J7N is offline
Senior Member
BS.Player Power User
 
Join Date: Feb 2006
Location: Cyberspace
Posts: 762
Rep Power: 0
J7N is an unknown quantity at this point
Default

> And how do I check/do this?
Watch the CPU usage. If it peaks at 100% you will lose video until the next keyframe. If when idle, your machine can not play H.264 videos without dropped frames, you need to "acquire" the paid version of CoreAVC decoder. For most videos ffdshow included in CCCP will do fine.

I agree with Adicoto. You need to replace Haali splitter with Gabest's Matroska splitter. It is simpler and does not conflict with BSPlayer. Since Gabest is inactive for about a year now it does not support the newest changes in Matroska format, but you will probably not encounter unplayable files.

To install Gabest's splitter, you unpack one *.ax file to a directory of your choice and memorize the full path, such as: "c:\apps\directshow\MatroskaSplitter.ax". Then open Start -> Run and type "regsvr32.exe c:\apps\directshow\MatroskaSplitter.ax" to register the filter. Choose Release Unicode, if you're running Win2k/XP, or Release, if you're using or plan to use Win98.

Adicoto :: Only low quality files, like anime fansubs, have AAC audio. HD captures use either the broadcast 384 kBit/s AC-3 or matching synced AC-3 from a DVD release. And btw, the OP didn't complain about missing audio.
Reply With Quote
  #8 (permalink)  
Old 10th April 2007
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

CoreAAC doesn't decode only AAC audio Normaly he can hear the sound, so it must have allready AC3Filter installed. No need for more.
At this moment, CoreAVC is the litest filter to decode x264 streams. For a 720p you need a CPU about 1,7 Ghz but for 1080i around 2,5 Ghz. 1080p will require above 3 GHz to play. If you are under those specifications, try to disable post processing from the decoder. The file with audio problems, isn't an XviD encoded file by any chance ?
Reply With Quote
  #9 (permalink)  
Old 10th April 2007
Default_Def's Avatar
Junior Member
BS.player Regular User
 
Join Date: Apr 2007
Posts: 16
Rep Power: 0
Default_Def is an unknown quantity at this point
Default

...Haali media splitter is known to have issues with BSPlayer (unfortunately)..."
So is this why I get that error every time I start BSplayer, or is it something else that if giving that error?


"...The file with audio problems, isn't an XviD encoded file by any chance ?..."
How do I find this out if it is or not?

Tried gspot on file, didn't' get much info:
http://img218.imageshack.us/img218/2782/infoel3.jpg

Under MS A/V, I hit button '2' and it played in gspot perfectly.
I just tried VLC Media Player again, plays fine, still get 'video lag' once in a while.


I have no idea how I got 'Haali media splitter' in my computer , did it come with BSplayer, or do you think it came with DivX or CCCP?
Reply With Quote
  #10 (permalink)  
Old 10th April 2007
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

Came with CCCP.
Reply With Quote
  #11 (permalink)  
Old 10th April 2007
J7N's Avatar
J7N J7N is offline
Senior Member
BS.Player Power User
 
Join Date: Feb 2006
Location: Cyberspace
Posts: 762
Rep Power: 0
J7N is an unknown quantity at this point
Default

Quote:
Under MS A/V, I hit button '2' and it played in gspot perfectly.
BSPlayer has problems with Haali splitter. Most other software don't. You won't need the extra duplicate features of Haali: audio/sub streams can be selected in BSPlayer, bitrate monitor for video can be seen using ffdshow.

> CoreAAC doesn't decode only AAC audio
It doesn't?

> For a 720p you need a CPU about 1,7 Ghz but for 1080i around 2,5 Ghz. 1080p will require above 3 GHz to play.
1) H.264 can be made complex to decode in any resolution, not just these modern HD standards. It is wrong to automatically associate Matroska with H.264 and it with HD.
2) If CABAC is used (it mostly is, disregarding the processing power of target computers), the CPU usage is almost proportional to input bitrate, NOT resolution.
3) 1080i. Due to obvious reasons (legacy technology from the 1930s) interlaced video is not common in pir___d sources. And if it is to be played, it will have way greater CPU requirement, because of need for a deinterlacer.
Reply With Quote
  #12 (permalink)  
Old 10th April 2007
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

Offtopic:

720p requires a minimum of 1,7 GHz CPU to play. As for the bitrate, most of today DVD drives can support this speed.
1080i are the most common among pi___es and are the source for further "so called" 720p files. Why "so called" ? Because, by definition 720p plays at 47,952-60 fps and most of the files are at 23,976 fps. And 1080i MPEG2 files play OK on my computer (2,53 GHz Celeron) using Elecard's software deinterlacing MPEG2 decoder. DOn't know about 1080i H264 files. Never had one.
It is wrong to associate matroska with HD files, but it's 99 % sure.
Reply With Quote
  #13 (permalink)  
Old 11th April 2007
Default_Def's Avatar
Junior Member
BS.player Regular User
 
Join Date: Apr 2007
Posts: 16
Rep Power: 0
Default_Def is an unknown quantity at this point
Default

Thanks for that info.

What should I do now?

Why am I still getting the error when ever I start BSplayer everytime?

Should I uninstall 'CCCP'?

What about 'Haali media splitter' should I uninstall that and install 'Gabest's splitter' instead (what will doing this actualy do anyway to my computer?)

Will it effect any other programs/files that I use/watch on my computer, or is it the same program, just slightly different?
Reply With Quote
  #14 (permalink)  
Old 11th April 2007
J7N's Avatar
J7N J7N is offline
Senior Member
BS.Player Power User
 
Join Date: Feb 2006
Location: Cyberspace
Posts: 762
Rep Power: 0
J7N is an unknown quantity at this point
Default

You should uninstall Haali media splitter. If you are unable to uninstall it seperately, then you should reinstall CCCP without this splitter. Replacing Haali with Gabest will change the way your computer works with Matroska media files (*.mkv, *.mka). If you have any MP4 files, then you will also need to install Gabest's MP4 Splitter.
Reply With Quote
  #15 (permalink)  
Old 11th April 2007
Default_Def's Avatar
Junior Member
BS.player Regular User
 
Join Date: Apr 2007
Posts: 16
Rep Power: 0
Default_Def is an unknown quantity at this point
Default

I went to 'add/remove programs' in the Control panel , only thinh I had that I can remove that started with an 'H' is HJT.
:?

So I went to CCCP site and downloaded 'Combined-Community-Codec-Pack-2007-02-22' and installed it.


Info on what I installed (all but noted ones):

- CoreWavPack 1.0.3
- FFDShow 2007-02-14 CCCP
- FLV Splitter 1.0.0.1
- Haali Media Splitter 2007-02-15 (said NO to this)
- MPV (MPEG2) Decoder 1.0.0.3 CCCP
- VSFilter 2007-01-09
- Windows Media 9 VCM

Players (sayed 'No' to both of these)
- Media Player Classic 6.4.9.0
- Zoom Player 5.00 Standard


Then this came up after It installed, I left as it was:
http://img208.imageshack.us/img208/3315/settingsnf5.jpg

This came up next, I left alone as well:
http://img86.imageshack.us/img86/4825/settings2iq9.jpg


*Was that ok to do?*



I then installed 'Gabest's Matroska splitter v1.0.2.9' like you said, but I get this error:

"...RegSvr32:

LoadLibrary("regsvr32.exe C:\_Filters\MatroskaSplitter.ax") failed - The Specified module could not be found...."
:evil:


I unzipped the *.7z file and it contained two directorys:

'Release Unicode' and 'Release', they both a have the file 'MatroskaSplitter.ax' in them, but I used the one from the "Release' folder.


Did I do something wrong?
:?: :oops:
Reply With Quote
  #16 (permalink)  
Old 11th April 2007
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

Release unicode for Windows XP, 2003, NT or Vista
Release for win98, ME
Reply With Quote
  #17 (permalink)  
Old 11th April 2007
Default_Def's Avatar
Junior Member
BS.player Regular User
 
Join Date: Apr 2007
Posts: 16
Rep Power: 0
Default_Def is an unknown quantity at this point
Default

^Thanks for that tip, I was able to register the filter properly, was wondering why there was two files in there. :D



I open the file and the video starts up right away, no error, but...


I have no sound now, and the video is a bit slow, not smooth like it was before, what is going on now?


*fixed one problem, got two more, ugg*
:evil:
Reply With Quote
  #18 (permalink)  
Old 11th April 2007
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

Never used mkv with ffdshow, so I can't really tell you wich settings to use to have e better rendering. Maybe J7N can help in here.
I personally use CoreAVC decoder and AC3Filter for playing...this kind of files. Can you tell us what is the resolution of the video file ?
Reply With Quote
  #19 (permalink)  
Old 11th April 2007
Default_Def's Avatar
Junior Member
BS.player Regular User
 
Join Date: Apr 2007
Posts: 16
Rep Power: 0
Default_Def is an unknown quantity at this point
Default

When I start it, it says in the player "Movie Size: 704x528"

And I noticed the button that shows the speaker icon (for volume) has an X on it, will look into that as well.


Update:
The volume level was reset to 0%, got that fixed, but..

Now, the video/audio is out of sink(sp?) a bit, not very noticeable if not much is happening, but still.
*as far as I know, I don't have anything running in the background to cause this type of problem*
Reply With Quote
  #20 (permalink)  
Old 12th April 2007
J7N's Avatar
J7N J7N is offline
Senior Member
BS.Player Power User
 
Join Date: Feb 2006
Location: Cyberspace
Posts: 762
Rep Power: 0
J7N is an unknown quantity at this point
Default

I was away for 1.5 days, so could not reply.

First screenshot shows the different video and audio formats you can decode using ffdshow. You uncheck the ones you want to decode using other modules. For example, I have found that DTS and AC3 are decoded and downmixed properly only with AC3filter. Also uncheck the "tray icon" box, so that it does not clutter the systray and possibly force BSPlayer out of full screen mode.

Second screenshot is pretty self-explanatory. You may leave all options untouched.

Release is valid for both WinXP and Win98 (as I wrote before). But you may choose Release Unicode if you don't plan using Win98.

video is a bit slow :: What is the CPU usage while you play the video? You can see CPU usage using, for example, WinXP 'Task Manager' (taskmgr.exe). If CPU usage of BSPlayer.exe is at 90% or higher, then you must find out which option eats the CPU. It could be video post processing. Uncheck that in ffdshow properties.

video out of sync :: I have never experienced out of sync with this configuration – Gabest's Matroska splitter + ffdshow + ac3filter/uncompressed/mp3. It didn't show up with native H.264, nor with H.264 in VfW mode (with delay frames). Video will be desynced from time to time if your CPU cannot keep up, but the delay will not be constant.

What is the video format of files in question? (MKV is not a video format.) If you're using ffdshow, you can see it under this path while a file is currently playing.

Options -> Filters -> ffdshow MPEG-4 Video Decoder -> Info & debug

___
To all :: I wonder if Haali could have treated the videos in some special way, automatically resyncing audio with video...
Reply With Quote
Reply

Tags
installing

Thread Tools
Display Modes

Posting Rules


All times are GMT +1. The time now is 12:10 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19