Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > General Talk And Support

General Talk And Support General talk and peer-to-peer support about BS.Player and other video and audio multimedia players.

Reply
 
LinkBack Thread Tools Display Modes
  #21 (permalink)  
Old 13th April 2007
Default_Def's Avatar
Junior Member
BS.player Regular User
 
Join Date: Apr 2007
Posts: 16
Rep Power: 0
Default_Def is an unknown quantity at this point
Default

“…video is a bit slow :: What is the CPU usage while you play the video?…”

CPU # for Bsplayer.exe jumps between 76-96% (but mostly between 85-96% while playing.)

“…It could be video post processing. Uncheck that in ffdshow properties. …”
I went to it and hit the ‘reset to default’ button, the slider went from the farthest right to the farthest left point, now the %# is between 85-95/96.
:shock:


“…What is the video format of files in question? (MKV is not a video format.) If you're using ffdshow, you can see it under this path while a file is currently playing.

Options -> Filters -> ffdshow MPEG-4 Video Decoder -> Info & debug …”

*sorry, MKV files and the BSplayer are still new to me* :oops:

All get is this:
http://img476.imageshack.us/img476/4342/infocv3.jpg


And when I click on 'ffdshow MPEG-4 Video Decoder' , I get this screen:
http://img402.imageshack.us/img402/8245/info2gp7.jpg


If I hit the ‘advanced’ button, I get this:
http://img408.imageshack.us/img408/1350/info3pt3.jpg


UPDATE, do you mean this? I think this is what you wanted to know:
http://img218.imageshack.us/img218/8488/info4vp2.jpg

Any ideas :?

*If I could. I'd put this BSplayer program on my other computer (CPU 1.8MHz VS 1.002MHz that I‘m using now) But for some reason I can't get ANY Audio/video to play at all on it. Hard to explain here*

Note: I could create a new topic for trying to get it working on that computer, but I want to try and fix it on this computer first.
Reply With Quote
  #22 (permalink)  
Old 13th April 2007
J7N's Avatar
J7N J7N is offline
Senior Member
BS.Player Power User
 
Join Date: Feb 2006
Location: Cyberspace
Posts: 762
Rep Power: 0
J7N is an unknown quantity at this point
Default

So the video format is DX50. Thats MPEG-4 ASP, more commonly known as DivX. CPU usage for ASP does not depend on bitrate as much. Still I believe ~85% CPU is too much and any background activity, such as a running P2P client will hurt your viewing experience.

Maybe you can switch from VobSub subtitle renderer to the simpler BSPlayer built-in subtitle renderer to save some CPU?

It does not matter what the settings on the post processing page are, if you have not placed a tick next to "Postprocessing" in the left pane.

I have a guess why this video might not play smoothly. It's just a guess. Since the fps value is 29.970, it might be that you're watching a NTSC standard video that has originally been created from 24 fps FILM source by artificially creating the extra frames. If this is the case then there's nothing you can do.
Reply With Quote
  #23 (permalink)  
Old 13th April 2007
Default_Def's Avatar
Junior Member
BS.player Regular User
 
Join Date: Apr 2007
Posts: 16
Rep Power: 0
Default_Def is an unknown quantity at this point
Default

"...Maybe you can switch from VobSub subtitle renderer to the simpler BSPlayer built-in subtitle renderer to save some CPU? ..."
How do I do that?
*I only had the sub titles on during the opening/ending credits, but if I have to turn them off all the way (always have to via green arrow in system bar) then that is fine with me.* :D


"...It does not matter what the settings on the post processing page are, if you have not placed a tick next to "Postprocessing" in the left pane. ..."
So, should I leave those settings alone :?


Well, this was a video I got off the net, and i have no idea what program that they used to make it (or what the original format was) but have one video/audio file on my computer that is about 232MB big, and only 2 programs can play it, it's hard to figure out sometimes.


Note: The only things I have running in the background are these:
- ZoneAlarm
- AVG Free Eedition
- SpywareGuard
*I even ran the video after I turned them all off, same result*
And they don't take up any CPU usage at all, so I can't understand why I don't get smooth and then not for the video, but oh well. :?
Reply With Quote
  #24 (permalink)  
Old 14th April 2007
J7N's Avatar
J7N J7N is offline
Senior Member
BS.Player Power User
 
Join Date: Feb 2006
Location: Cyberspace
Posts: 762
Rep Power: 0
J7N is an unknown quantity at this point
Default

I don't have any more ideas. Maybe other users be of more help. :roll:
Reply With Quote
  #25 (permalink)  
Old 14th April 2007
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

It could take long, it could be painfull, but worth trying. :D

1. To disable vobsub go to it's configuration panel from start->programs-> directvobsub. On the 2nd page (see upper tabs) you have 3 options for subtitles: load when needed, allways load and don't load. Try to select the 3rd one.

2. Be sure you downloaded FFDshow's package for your CPU and not for other.

3. You could try to swich in video->rendering to VMR 9. FFdshow works better with it.

4. You can try do uninstall FFdshow and install independent codecs, XviD, DivX, AC3Filter and CoreAVC.
Reply With Quote
  #26 (permalink)  
Old 16th April 2007
Default_Def's Avatar
Junior Member
BS.player Regular User
 
Join Date: Apr 2007
Posts: 16
Rep Power: 0
Default_Def is an unknown quantity at this point
Default

^I'll try all that, thanks for the help on this :D

*And thank you everyone that has helped me so far, or has even bothered to read this topic, if you have any more advise please feel free to add it*
Reply With Quote
  #27 (permalink)  
Old 16th April 2007
J7N's Avatar
J7N J7N is offline
Senior Member
BS.Player Power User
 
Join Date: Feb 2006
Location: Cyberspace
Posts: 762
Rep Power: 0
J7N is an unknown quantity at this point
Default

Quote:
You can try do uninstall FFdshow and install independent codecs, XviD, DivX, AC3Filter and CoreAVC.
There are no other free decoders for certain formats, such as DIV3, WMV, WMA.
Reply With Quote
  #28 (permalink)  
Old 16th April 2007
Member
BS.player Regular User
 
Join Date: Aug 2005
Posts: 64
Rep Power: 0
speedtrap is an unknown quantity at this point
Default

The DivX decoder should be able to play DIV3. Otherwise use the DivX 3.11 codec.

And Microsoft has free codecs for WMV/WMA. Just install Windows Format Runtimes. No need to install WMP.
Reply With Quote
  #29 (permalink)  
Old 16th April 2007
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

Div3 it's played OK by any further release of DivX except some 4.xx that screwed this thing. Long gone. Anyhow, DivX 3.11 it's still "free". For WMV you don't need anything, just a clean Windows XP or 2k SP4 install. I assume that nobody in here uses an older version of Windows.
Reply With Quote
Reply

Tags
installing

Thread Tools
Display Modes

Posting Rules


All times are GMT +1. The time now is 12:12 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19