Official BS.Player forums

Official BS.Player forums (http://forum.bsplayer.com/)
-   Bug Reports And Codecs (http://forum.bsplayer.com/bug-reports-codecs/)
-   -   BSPlayer v1.0 RC1 Bug Thread (http://forum.bsplayer.com/bug-reports-codecs/3033-bsplayer-v1-0-rc1-bug-thread.html)

Sintel 12th November 2003 05:10 PM

BSPlayer v1.0 RC1 Bug Thread
 
bugs in red are fixed in 803 build

I thought it would be best to group all the bugs encountered in one thread. THIS IS NOT A FEATURE REQUEST THREAD; so any missing features you want implemented, put in appropriate forum.

A word of warning, I'm using windows98se (all patched up/latest-version'd/tweaked tho) and some of these bugs may have something to do with it. I would like it if someone with windowsxp or windows2000 who has tested it and doesn't encounter a particular bug to speak up and let me know about it.

Performance issues have nothing to do with my hardware as I have an AthlonXP 2800+, 512mb ram PC3200, Radeon 9600Pro, and play my video files from hard disk, without any background programs running.

After some use, I encountered the following:
GENERAL
* Performance has degraded in this sense: moving the video window during playback goes very slow (the window jump around on the screen, it doesn't follow the mouse pointer smoothly as it did in 0.86.xxx) Actually, ALL windows you move around during video playback show this behaviour. When the file playback is stopped, moving around speed returns to normal. I haven't tried other overlay modes yet either (only used default). ONLY OCCURS ON WIN9X
* The bsz/bsi/bsl extensions aren't properly registered with bsplayer, it shows the default windows icon and if double-clicked:
1) WHEN THE PLAYER IS ALREADY OPEN: it says "Can't open file".
2) WHEN THE PLAYER ISN'T OPEN: behaviour is as it should be, with a exceptions.

--> The playlist new features (fullscreen, aspect radio, etc.) don't get applied on the first file in the playlist. Only way I could get it to apply is by double clicking it in the playlist, but not by trying next track, previous track. On succeeding playlist entries it works.
--> The new playlist features don't get saved/used in text mode, only in internal mode (could be by design).
--> If the bsi/bsl files are empty, it shows an unhandled exception dialog, but it isn't fatal, the player stays open. If the bsz file is empty, the player buttons become unusable. Also, the empty bsz file gets copied to the skins folder even though it's unusable, maybe a check should be in place (see skins section for more on this).
--> I haven't tested bsi support thorougly yet, they are on my cd's.
* Subtitles in OGM files aren't supported yet? Subtitle playback seems generally improved A LOT tho. BUT BROKEN
* Forward jump in OGM files is now correct (10 seconds) but backward jump still doesn't work.

SKINS
* The default skin has a type error: Incrase instead of Increase Font.
* Older skin (only have one: HiQ) that worked fine with 0.86.501 get a message "skin not supported". This could be by design but behaviour is very problematic: the player looks like this and the error "skin not supported" keeps showing up till you delete all the contents from the skin in the skin folder (it automatically copies these contents to the folder even if it's not supported). Also, a lot of unhandled exceptions. I also don't understand why it keeps checking if all skins in skins folder are supported even if you use another skin.

PREFERENCES WINDOW:
* Changing the file icon in General -> Filetypes doesn't work. The exe also includes only one icon, the default, and not the other ones available in the preferences.
* In the options window, the help bar that shows up when you go over an option is extremely annoying: it shows up too fast and doesn't disappear immediatly when you move away from the option, this way it obscures other options etc.
* Equalizer isn't implemented yet, but you prolly know that already. The audio output device doesn't get saved yet either.
* Subtitles: the preview window doesn't get updated every time you change something in the preferences, only occasionally (outline font, antialiasing etc.)

Even after all these things, I still think you (bst) are going very much in the right direction. I like what you did with the playlists (even though the feature is still somewhat broke) I like the new menu/preferences layouts and the new features & Advanced filters dialog. To put it bluntly, the player is a lot more consistent then earlier. The xml file for preferences was a real good idea too. Lastly, The filters menu item is a bit too much hidden, maybe put it under subtitles in the main menu, instead of the submenu "options"? And remove the icon in front of subtitles while you're at it, in the name of uniformity :-) (nitpicking I know). I'll prolly revert back to 0.86.501 for the time being but I'll sure keep an eye on and test any upcoming releases.

Sintel 12th November 2003 06:33 PM

When selecting rgb overlay, the mouse keeps jumping around in the box with the mode select, only way to get the mouse out of the box is by pressing escape. Performance in rgb mode is abysmal compared to the other modes.

KHysiek 12th November 2003 07:19 PM

Can't set space key. I miss Space key as pause :(. Now I often hit Stop key. I know I could set pause to some other but Space is the best for it.
The is no simple plain clear-to-understand skin. Current skins are often hard to read and typically not compatible with other BSPlayer languages (longer texts are drawed beyond space they should take).

Marcel 13th November 2003 12:18 AM

Hm, maybe it's not a bug, but a feature:

I've set "Cycle Audio Streams" to <Alt Gr>-<-> (=> Alt+Ctrl+#189).
Every time I hit these two keys, BSPlayer not just cycles the audio stream, but also pauses. (Tested with an AVI, XVid / MP3 VBR / MP3 VBR)
IMHO, that's annoying.

PcVII 13th November 2003 04:49 AM

directvobsub+ogm = crash
 
when ever directvobsub loads in bsplayer with an ogm bsplayer crashes.

i switch the overlay to a different one and directvobsub stops opening but then i can't seem to get bsplayer 1.0's subs to run i'm guessing they aren't in rc1.

let me know what i can do to help get directvobsub to run with bsplayer with out crashing. This works in wmp.

testy_tester 13th November 2003 10:19 AM

div3 files shows gray screen
 
In RC1, playing DIV3 files results in gray screen. Video plays fine in older .86 build 501 player. Tested this with 5 other videos.

Any video encoded using the older Divx 3.11 will not display right.

BMan 13th November 2003 10:24 AM

got a big black bar on the bottom...the video is squeezed into the remaining space, creating a wrong AR...besides that, within the black bars there appear corruptions...
only in windowed mode...

ZanderZ 13th November 2003 11:06 AM

Many spelling errors in English language file. I could correct them if anyone is interested

kostasmaster 13th November 2003 12:57 PM

Just tried v1.00 and removed it at once. 1) it is slower than 0.86.501 (just use your right click and see how jerky the video becomes) and 2) I just ran the exe file (no installing whatsoever) and it registered all filetypes with it, shouldn't it ASK before it did it ??
So as far as I am concerned, I will use the previous version until 1.00 becomes final.

Telstar 13th November 2003 01:25 PM

Hi,
Here are a few items regarding minor issues in the v1.00 RC1.
Hope it's ok that I simply posted the links to my Forum topics to reduce redundancy.
These are still open waiting for replies and point out a couple of spelling errors, the now prevalent BS media type logo and inability of v1.00 to play .wmv files whereas the former v0.86 can play .wmv files (at least this is true in my player....codec issue?):

http://forum.bsplayer.org/viewtopic.php?t=3116

http://forum.bsplayer.org/viewtopic.php?t=3121

http://forum.bsplayer.org/viewtopic.php?t=3151

With all of it's bugs, even though a release candidate, I, for one, appreciate the thought and creativeness that goes into this product. I'm a newbie to the various players available and think the BSplayer has great potential. Just imagine if all of these bugs could be addressed and eliminated for the next version of this player.
Consolidation of these issues into a single thread was a good idea.

Telstar

adicoto 13th November 2003 03:01 PM

Sorry to disappoint some of you, but I have no problem with WMV files on ver 1.0

totally81 13th November 2003 04:12 PM

any incompability with radeon9600pro ati cards?
 
hi, do you have any reduced divx/xvid quality with your ati card? the media files play fine with the divx player, but not bsplayer.

Sintel 14th November 2003 06:51 AM

When changing skin, the menu doesn't get the appropriate menu coloring associated with the skin, only with a restart.

dakalro 14th November 2003 08:01 AM

Using Windows 2000 SP3

Other than this error when clicking Audio preferences:
BSPlayer v1.00.800, Unhandled exception at EIP: 004A6C74
If you click 'Close' application will be terminated.
Please report this info to the author with description what were you doing.
Access violation at address 004A6C74 in module 'bsplay.exe'. Read of address 00000000
EAccessViolation
, 0x004DFFFB, 0x004E01F9, 0x004534E7, 0x0044A832, 0x77E3A2D0, 0x77E16B21, 0x77E25010, 0x717521F0,

I have not encountered no lag in movie play or window movement, no other crashes (played DivX, Xvid, WMV, MPEGs - it even plays mpegs that used to give Unknown Format() error in 0.86.501).
Oh, and there is no Space for Pause (and you can't define Space :)).

And there is some stuff missing.

Drizzt 14th November 2003 03:24 PM

Chapters and embedded subs
 
I've some matroska and ogm files with chapters and embedded subs and I found these bugs:

- I've the latest vsfilter installed, and when I open a file with embedded subs (either matroska or ogm) vsfilter (forced version) is loading but detects no subs (wonder then why loading :) ). Maybe bsplayer doesn't pass the info on the subs to vsfilter. It worked with earlier versions of bsplayer.

- When I change chapter via the right click menu, the osd doesn't displays the chapter name (as earlier) and pauses(!), it works fine when I change it via ctrl+b, ctrl+z (and doesn't pause).

Anyway bsplayer is my favourite I'll recommend it to all my friends (when these bugs will be corrected).

ps: sorry for my english :)

Grador 14th November 2003 03:50 PM

Several bugs in new version: Subtitles can't be moved under the movie in full screnn, in previous version it worked (I think), now you have subtitles through movie and under and below film is lot of empty space.
In window I am missing subtitle status (ON/OFF) in previous version it worked too.
After installing new version I lost all my key definitions, why it doesn't support import from previous version.

Honestly I like this new version much, it is more stable then previous builds, just the problem with subtitles in movie in full screen:(

BillyETS 14th November 2003 04:27 PM

i wanted to watch an AVi file with AC3 sound
and got the following error message:

BSPlayer v1.00.800, Unhandled exception at EIP: 00459935
If you click 'Close' application will be terminated.
Please report this info to the author with description what were you doing.
Ung??ltige Klassenzeichenfolge
EOleSysError
, 0x004DFFFB, 0x004E01F9, 0x004534E7, 0x0044A832, 0x77D13A68, 0x77D13B37, 0x77D13D91, 0x77D1438C, 0x004E0BC4, 0x77E614C7


........ using WinXP, DX9.0b, AC3 decoder: Moonlight Odio Dekoda V1.23

Movies with MP3 Audio work without any errors.

vamp1r0 14th November 2003 04:34 PM

Hi? there's another problem whith associasions - first? BsPlayer not give associated files icon, that i choose in options? then, i cannot change in by myself because he hide associations whith these file when i uncheck associate on start checkbox. Those associations just desappear from List of associated Files, and when i try to add them manualy, windows tell me that it already associated with 'program', but i cannot see them, until i dont turn back chekbox in BsPlayer.

PS i use win98se. I it matter.

Andrusha 14th November 2003 05:56 PM

I have some problems while trying to play WMV-file made with Windows Movie Maker...

trodas 14th November 2003 07:50 PM

Well, for RC1 this is not as bad thing, as it sounds. I dont encounter on W2k any performance issues, but i incounter the fact, that since v1 it dont using any other that default sound output device, 5+1 output dont work anymore.
This alone makes the player useless.
However this is the only one bug i hit - some glitches from 0.86 seems fixed, like that playback is killed when one do fullscreen switch AND have defined resolution change...

Okay, there is a small glitch that force subtitles to be drawn into movie, and i want them at the botton of screen into fullscreen mode, as before. This i can't change anymore...

So, frankly spoken, if i can use 5+1 audio (if v1 start remembering/using the output device i NEED to select to AX filter begin working) and the subtitles are fixed, then except the fact, that someone have to rework windvdplus2.bsz skin for me to be usable into v1 - im happy with it.
Until this i have to fight with so many bugs of the latest 0.86 .... :cry:


All times are GMT +1. The time now is 04:47 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20