Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 12th November 2003
Member
BS.player Regular User
 
Join Date: Oct 2003
Location: between a rock and a hard place
Posts: 36
Rep Power: 0
Sintel is an unknown quantity at this point
Default BSPlayer v1.0 RC1 Bug Thread

bugs in red are fixed in 803 build

I thought it would be best to group all the bugs encountered in one thread. THIS IS NOT A FEATURE REQUEST THREAD; so any missing features you want implemented, put in appropriate forum.

A word of warning, I'm using windows98se (all patched up/latest-version'd/tweaked tho) and some of these bugs may have something to do with it. I would like it if someone with windowsxp or windows2000 who has tested it and doesn't encounter a particular bug to speak up and let me know about it.

Performance issues have nothing to do with my hardware as I have an AthlonXP 2800+, 512mb ram PC3200, Radeon 9600Pro, and play my video files from hard disk, without any background programs running.

After some use, I encountered the following:
GENERAL
* Performance has degraded in this sense: moving the video window during playback goes very slow (the window jump around on the screen, it doesn't follow the mouse pointer smoothly as it did in 0.86.xxx) Actually, ALL windows you move around during video playback show this behaviour. When the file playback is stopped, moving around speed returns to normal. I haven't tried other overlay modes yet either (only used default). ONLY OCCURS ON WIN9X
* The bsz/bsi/bsl extensions aren't properly registered with bsplayer, it shows the default windows icon and if double-clicked:
1) WHEN THE PLAYER IS ALREADY OPEN: it says "Can't open file".
2) WHEN THE PLAYER ISN'T OPEN: behaviour is as it should be, with a exceptions.

--> The playlist new features (fullscreen, aspect radio, etc.) don't get applied on the first file in the playlist. Only way I could get it to apply is by double clicking it in the playlist, but not by trying next track, previous track. On succeeding playlist entries it works.
--> The new playlist features don't get saved/used in text mode, only in internal mode (could be by design).
--> If the bsi/bsl files are empty, it shows an unhandled exception dialog, but it isn't fatal, the player stays open. If the bsz file is empty, the player buttons become unusable. Also, the empty bsz file gets copied to the skins folder even though it's unusable, maybe a check should be in place (see skins section for more on this).
--> I haven't tested bsi support thorougly yet, they are on my cd's.
* Subtitles in OGM files aren't supported yet? Subtitle playback seems generally improved A LOT tho. BUT BROKEN
* Forward jump in OGM files is now correct (10 seconds) but backward jump still doesn't work.

SKINS
* The default skin has a type error: Incrase instead of Increase Font.
* Older skin (only have one: HiQ) that worked fine with 0.86.501 get a message "skin not supported". This could be by design but behaviour is very problematic: the player looks like this and the error "skin not supported" keeps showing up till you delete all the contents from the skin in the skin folder (it automatically copies these contents to the folder even if it's not supported). Also, a lot of unhandled exceptions. I also don't understand why it keeps checking if all skins in skins folder are supported even if you use another skin.

PREFERENCES WINDOW:
* Changing the file icon in General -> Filetypes doesn't work. The exe also includes only one icon, the default, and not the other ones available in the preferences.
* In the options window, the help bar that shows up when you go over an option is extremely annoying: it shows up too fast and doesn't disappear immediatly when you move away from the option, this way it obscures other options etc.
* Equalizer isn't implemented yet, but you prolly know that already. The audio output device doesn't get saved yet either.
* Subtitles: the preview window doesn't get updated every time you change something in the preferences, only occasionally (outline font, antialiasing etc.)

Even after all these things, I still think you (bst) are going very much in the right direction. I like what you did with the playlists (even though the feature is still somewhat broke) I like the new menu/preferences layouts and the new features & Advanced filters dialog. To put it bluntly, the player is a lot more consistent then earlier. The xml file for preferences was a real good idea too. Lastly, The filters menu item is a bit too much hidden, maybe put it under subtitles in the main menu, instead of the submenu "options"? And remove the icon in front of subtitles while you're at it, in the name of uniformity :-) (nitpicking I know). I'll prolly revert back to 0.86.501 for the time being but I'll sure keep an eye on and test any upcoming releases.
Reply With Quote
  #2 (permalink)  
Old 12th November 2003
Member
BS.player Regular User
 
Join Date: Oct 2003
Location: between a rock and a hard place
Posts: 36
Rep Power: 0
Sintel is an unknown quantity at this point
Default

When selecting rgb overlay, the mouse keeps jumping around in the box with the mode select, only way to get the mouse out of the box is by pressing escape. Performance in rgb mode is abysmal compared to the other modes.
Reply With Quote
  #3 (permalink)  
Old 12th November 2003
Junior Member
BS.player Regular User
 
Join Date: Jan 2003
Posts: 17
Rep Power: 0
KHysiek is an unknown quantity at this point
Default

Can't set space key. I miss Space key as pause :(. Now I often hit Stop key. I know I could set pause to some other but Space is the best for it.
The is no simple plain clear-to-understand skin. Current skins are often hard to read and typically not compatible with other BSPlayer languages (longer texts are drawed beyond space they should take).
Reply With Quote
  #4 (permalink)  
Old 12th November 2003
Junior Member
BS.player Regular User
 
Join Date: Jan 2003
Posts: 13
Rep Power: 0
Marcel is an unknown quantity at this point
Default

Hm, maybe it's not a bug, but a feature:

I've set "Cycle Audio Streams" to <Alt Gr>-<-> (=> Alt+Ctrl+#189).
Every time I hit these two keys, BSPlayer not just cycles the audio stream, but also pauses. (Tested with an AVI, XVid / MP3 VBR / MP3 VBR)
IMHO, that's annoying.
Reply With Quote
  #5 (permalink)  
Old 13th November 2003
Junior Member
BS.Player Newbie
 
Join Date: Nov 2003
Posts: 2
Rep Power: 0
PcVII is an unknown quantity at this point
Default directvobsub+ogm = crash

when ever directvobsub loads in bsplayer with an ogm bsplayer crashes.

i switch the overlay to a different one and directvobsub stops opening but then i can't seem to get bsplayer 1.0's subs to run i'm guessing they aren't in rc1.

let me know what i can do to help get directvobsub to run with bsplayer with out crashing. This works in wmp.
Reply With Quote
  #6 (permalink)  
Old 13th November 2003
Junior Member
BS.Player Newbie
 
Join Date: Nov 2003
Posts: 4
Rep Power: 0
testy_tester is an unknown quantity at this point
Default div3 files shows gray screen

In RC1, playing DIV3 files results in gray screen. Video plays fine in older .86 build 501 player. Tested this with 5 other videos.

Any video encoded using the older Divx 3.11 will not display right.
Reply With Quote
  #7 (permalink)  
Old 13th November 2003
Junior Member
BS.Player Newbie
 
Join Date: Nov 2003
Posts: 3
Rep Power: 0
BMan is an unknown quantity at this point
Default

got a big black bar on the bottom...the video is squeezed into the remaining space, creating a wrong AR...besides that, within the black bars there appear corruptions...
only in windowed mode...
Reply With Quote
  #8 (permalink)  
Old 13th November 2003
Member
BS.player Regular User
 
Join Date: Jun 2003
Location: Groningen, The Netherlands
Posts: 68
Rep Power: 0
ZanderZ is an unknown quantity at this point
Default

Many spelling errors in English language file. I could correct them if anyone is interested
__________________
Creator of BadFellas, a free online mafia game: http://www.badfellas.org
Reply With Quote
  #9 (permalink)  
Old 13th November 2003
Junior Member
BS.Player Newbie
 
Join Date: Sep 2003
Location: Athens, Greece
Posts: 3
Rep Power: 0
kostasmaster is an unknown quantity at this point
Default

Just tried v1.00 and removed it at once. 1) it is slower than 0.86.501 (just use your right click and see how jerky the video becomes) and 2) I just ran the exe file (no installing whatsoever) and it registered all filetypes with it, shouldn't it ASK before it did it ??
So as far as I am concerned, I will use the previous version until 1.00 becomes final.
Reply With Quote
  #10 (permalink)  
Old 13th November 2003
Telstar's Avatar
Junior Member
BS.player Regular User
 
Join Date: Nov 2003
Location: Oregon USA
Posts: 15
Rep Power: 0
Telstar is an unknown quantity at this point
Default

Hi,
Here are a few items regarding minor issues in the v1.00 RC1.
Hope it's ok that I simply posted the links to my Forum topics to reduce redundancy.
These are still open waiting for replies and point out a couple of spelling errors, the now prevalent BS media type logo and inability of v1.00 to play .wmv files whereas the former v0.86 can play .wmv files (at least this is true in my player....codec issue?):

http://forum.bsplayer.org/viewtopic.php?t=3116

http://forum.bsplayer.org/viewtopic.php?t=3121

http://forum.bsplayer.org/viewtopic.php?t=3151

With all of it's bugs, even though a release candidate, I, for one, appreciate the thought and creativeness that goes into this product. I'm a newbie to the various players available and think the BSplayer has great potential. Just imagine if all of these bugs could be addressed and eliminated for the next version of this player.
Consolidation of these issues into a single thread was a good idea.

Telstar
Reply With Quote
  #11 (permalink)  
Old 13th November 2003
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,159
Rep Power: 27
adicoto is on a distinguished road
Default

Sorry to disappoint some of you, but I have no problem with WMV files on ver 1.0
Reply With Quote
  #12 (permalink)  
Old 13th November 2003
Junior Member
BS.player Regular User
 
Join Date: Nov 2003
Posts: 13
Rep Power: 0
totally81 is an unknown quantity at this point
Default any incompability with radeon9600pro ati cards?

hi, do you have any reduced divx/xvid quality with your ati card? the media files play fine with the divx player, but not bsplayer.
__________________
the newbie...
Reply With Quote
  #13 (permalink)  
Old 14th November 2003
Member
BS.player Regular User
 
Join Date: Oct 2003
Location: between a rock and a hard place
Posts: 36
Rep Power: 0
Sintel is an unknown quantity at this point
Default

When changing skin, the menu doesn't get the appropriate menu coloring associated with the skin, only with a restart.
Reply With Quote
  #14 (permalink)  
Old 14th November 2003
Junior Member
BS.Player Newbie
 
Join Date: Nov 2003
Posts: 1
Rep Power: 0
dakalro is an unknown quantity at this point
Default

Using Windows 2000 SP3

Other than this error when clicking Audio preferences:
BSPlayer v1.00.800, Unhandled exception at EIP: 004A6C74
If you click 'Close' application will be terminated.
Please report this info to the author with description what were you doing.
Access violation at address 004A6C74 in module 'bsplay.exe'. Read of address 00000000
EAccessViolation
, 0x004DFFFB, 0x004E01F9, 0x004534E7, 0x0044A832, 0x77E3A2D0, 0x77E16B21, 0x77E25010, 0x717521F0,

I have not encountered no lag in movie play or window movement, no other crashes (played DivX, Xvid, WMV, MPEGs - it even plays mpegs that used to give Unknown Format() error in 0.86.501).
Oh, and there is no Space for Pause (and you can't define Space :)).

And there is some stuff missing.
Reply With Quote
  #15 (permalink)  
Old 14th November 2003
Junior Member
BS.Player Newbie
 
Join Date: Nov 2003
Location: Budapest, Hungary
Posts: 5
Rep Power: 0
Drizzt is an unknown quantity at this point
Default Chapters and embedded subs

I've some matroska and ogm files with chapters and embedded subs and I found these bugs:

- I've the latest vsfilter installed, and when I open a file with embedded subs (either matroska or ogm) vsfilter (forced version) is loading but detects no subs (wonder then why loading :) ). Maybe bsplayer doesn't pass the info on the subs to vsfilter. It worked with earlier versions of bsplayer.

- When I change chapter via the right click menu, the osd doesn't displays the chapter name (as earlier) and pauses(!), it works fine when I change it via ctrl+b, ctrl+z (and doesn't pause).

Anyway bsplayer is my favourite I'll recommend it to all my friends (when these bugs will be corrected).

ps: sorry for my english :)
Reply With Quote
  #16 (permalink)  
Old 14th November 2003
Junior Member
BS.Player Newbie
 
Join Date: Jul 2002
Posts: 5
Rep Power: 0
Grador is an unknown quantity at this point
Default

Several bugs in new version: Subtitles can't be moved under the movie in full screnn, in previous version it worked (I think), now you have subtitles through movie and under and below film is lot of empty space.
In window I am missing subtitle status (ON/OFF) in previous version it worked too.
After installing new version I lost all my key definitions, why it doesn't support import from previous version.

Honestly I like this new version much, it is more stable then previous builds, just the problem with subtitles in movie in full screen:(
__________________
. Grador the Dwarf
Reply With Quote
  #17 (permalink)  
Old 14th November 2003
Junior Member
BS.Player Newbie
 
Join Date: Nov 2003
Posts: 1
Rep Power: 0
BillyETS is an unknown quantity at this point
Default

i wanted to watch an AVi file with AC3 sound
and got the following error message:

BSPlayer v1.00.800, Unhandled exception at EIP: 00459935
If you click 'Close' application will be terminated.
Please report this info to the author with description what were you doing.
Ung??ltige Klassenzeichenfolge
EOleSysError
, 0x004DFFFB, 0x004E01F9, 0x004534E7, 0x0044A832, 0x77D13A68, 0x77D13B37, 0x77D13D91, 0x77D1438C, 0x004E0BC4, 0x77E614C7


........ using WinXP, DX9.0b, AC3 decoder: Moonlight Odio Dekoda V1.23

Movies with MP3 Audio work without any errors.
Reply With Quote
  #18 (permalink)  
Old 14th November 2003
Junior Member
BS.Player Newbie
 
Join Date: Nov 2003
Posts: 2
Rep Power: 0
vamp1r0 is an unknown quantity at this point
Default

Hi? there's another problem whith associasions - first? BsPlayer not give associated files icon, that i choose in options? then, i cannot change in by myself because he hide associations whith these file when i uncheck associate on start checkbox. Those associations just desappear from List of associated Files, and when i try to add them manualy, windows tell me that it already associated with 'program', but i cannot see them, until i dont turn back chekbox in BsPlayer.

PS i use win98se. I it matter.
Reply With Quote
  #19 (permalink)  
Old 14th November 2003
Junior Member
BS.Player Newbie
 
Join Date: Nov 2003
Location: Russia, Ivanovo city
Posts: 3
Rep Power: 0
Andrusha is an unknown quantity at this point
Default

I have some problems while trying to play WMV-file made with Windows Movie Maker...
__________________
Made in USSR... ;)
Reply With Quote
  #20 (permalink)  
Old 14th November 2003
trodas's Avatar
Senior Member
BS.Player Power User
 
Join Date: Nov 2002
Location: Czech republic
Age: 44
Posts: 239
Rep Power: 0
trodas is an unknown quantity at this point
Default

Well, for RC1 this is not as bad thing, as it sounds. I dont encounter on W2k any performance issues, but i incounter the fact, that since v1 it dont using any other that default sound output device, 5+1 output dont work anymore.
This alone makes the player useless.
However this is the only one bug i hit - some glitches from 0.86 seems fixed, like that playback is killed when one do fullscreen switch AND have defined resolution change...

Okay, there is a small glitch that force subtitles to be drawn into movie, and i want them at the botton of screen into fullscreen mode, as before. This i can't change anymore...

So, frankly spoken, if i can use 5+1 audio (if v1 start remembering/using the output device i NEED to select to AX filter begin working) and the subtitles are fixed, then except the fact, that someone have to rework windvdplus2.bsz skin for me to be usable into v1 - im happy with it.
Until this i have to fight with so many bugs of the latest 0.86 ....
__________________
"It is dangerous to be right in matters on which the established authorities are wrong." - Voltaire
...just keep folding, just keep folding... :) my config - my caps
Reply With Quote
Reply

Tags
rc1, thread, v10

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 03:58 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20