Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 29th May 2004
Junior Member
BS.player Regular User
 
Join Date: Feb 2004
Posts: 27
Rep Power: 0
hazmat42 is an unknown quantity at this point
Default Xvid Autorun CD doesn't work in Win98?

Would somebody please confirm whether or not you can run a bsplayer autorun cd with an xvid movie on Windows 98? I recently made this post:
http://forum.bsplayer.org/viewtopic.php?t=4853 , but I feel that maybe I was asking the wrong question. I'm using BSPlayer .85 build 501, and I can't get it to play an xvid movie from cd at all! tried using xvid.ax, divx.ax with "use divx for generic mp4" turned on, and ffdshow.ax, and I still get "unknown file format [xvid]"

So does anyone know if it will work in Windows 98 at all? Ever try it with a different version of BSPlayer?

thanks.
Reply With Quote
  #2 (permalink)  
Old 31st May 2004
DragonFighter's Avatar
Senior Member
BS.Player Power User
 
Join Date: Apr 2004
Location: Hellas
Age: 35
Posts: 195
Rep Power: 0
DragonFighter is an unknown quantity at this point
Default

Copy Bplay.exe and bsrend.dll, and create a new dir called "Filters". Download the xvid decoder and the Ac3 filter and copy them inside the "Filters".
Finally, make a BSPfilter.dat file which will contain the following text:

[BSPlayer filter def file]
AddFilter xvid.ax,{64697678-0000-0010-8000-00AA00389B71},XviD MPEG-4 Video Decoder
AddFilter ac3filter.ax,{A753A1EC-973E-4718-AF8E-A3F554D45C44},AC3Filter

Root of the CD: "Filters", Bplay.exe, bsrend.dll, Autorun.inf, Movie, bsi/ini, BSPfilter.dat

BSplayer will now be able to play the movie.

P.S: HWmaker, which is going to be out in few days, is making playable discs easy and fast.
__________________
HWmaker
Please read BSPeter's Help2Help topic
Reply With Quote
  #3 (permalink)  
Old 1st June 2004
Junior Member
BS.player Regular User
 
Join Date: Feb 2004
Posts: 27
Rep Power: 0
hazmat42 is an unknown quantity at this point
Default

I updated to xvid-1.0-09052004, and to my surprise, the new Koepi build actually worked after I copied the xvidcore.dll and xvidvfw.dll files to my CD root directory. However, it only works when I write to .inf file to open the player and the avi (bplay.exe "movie.avi"), and not the player and bsi file (bplay.exe "movie.bsi"). When I use an .inf file with the latter command, I get the same "unknown file format [Xvid]" error. So technically, I can get an autorun CD to work, but I am still frustrated by the fact that I can't use my .bsi information, since most of my movies are 2 or more CD's with subtitles and chapters. This is the .bsi of the sample movie I was using for testing:

[movie]
Title=movie
Directory=.
FName=movie.avi
[Options]
ExitAtEnd=1
FullScreen=1

The sample doesn't have subs or chapters, but if I can't get the computer to load even this simple info properly, that doen't bode to well for any
other movie I want to burn to autorun CD

Any ideas on how to get the .bsi file to load properly?
Reply With Quote
Reply

Tags
autorun, win98, xvid

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 05:46 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20