Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 21st September 2004
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 3
Rep Power: 0
soguy is an unknown quantity at this point
Default Full-Screen changes nVidia TV Screen Adjustment

I'm using the TV as a secondary monitor (Clone mode) to play movies. In nVidia there is a setting which can change the screen position and size (zoom) on the TV at "Screen Adjustments".
When I switch to full-screen, BSPlayer change this size\zoom setting to full causing the picture to be bigger than the TV frame. When you switch back to window-mode you can see that the size of the picture is bigger cause the task bar is almost hidden. To fix it you should manually go to the nVidia settings.
Reply With Quote
  #2 (permalink)  
Old 6th October 2004
Junior Member
BS.Player Newbie
 
Join Date: Oct 2004
Location: Canada
Posts: 2
Rep Power: 0
alexmyron is an unknown quantity at this point
Default Me Too

This is exactly what happens with mine too!

Anybody have any suggestions??

Setting nvidia to single mode is presently the only way that it will work for me, problem is clone mode is needed to have my monitor work.
Reply With Quote
  #3 (permalink)  
Old 6th October 2004
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 3
Rep Power: 0
soguy is an unknown quantity at this point
Default I think I have a workaround ...

I doesn't happen when in 'Preferences > Video' I select:
- General: Remember Pan-Scan settings ONLY
- Video Rendereing: Wait for vertical blank
Reply With Quote
  #4 (permalink)  
Old 6th October 2004
Junior Member
BS.Player Newbie
 
Join Date: Oct 2004
Location: Canada
Posts: 2
Rep Power: 0
alexmyron is an unknown quantity at this point
Default

Thanks, will try that!
Reply With Quote
  #5 (permalink)  
Old 8th October 2004
Junior Member
BS.player Regular User
 
Join Date: Sep 2004
Location: Sweden
Posts: 21
Rep Power: 0
Dennis_Olof is an unknown quantity at this point
Default Me too

I had this problem too, but I dont know if this fixes it but seems to have worked, I use latest Nvidia players from Nvidia (not manufactures drivers like asus etc). And I had this problem when switching to TV that nvidia Zoomed in so that the picture was too big, this mad me angry.

Had to live with it for a while, the be chance I discoverd that if you go to TV mode, and then go to where you can "ZOOM" in and out the picture, select "standard values" then use the "SAVE" settings and enter a name.

Done, this has worked for me now for 4 days. I donno why but seems now that when I use the Nvidia Icon, select Nview then "TV" it goes to TV mode it looks fine, not this constand ZOOMing in all the time.

This might be a bug in Nvidia drivers, but this seems to work fine.

Probably other methods ? but this works.

Allso this problem has only been around for a few builds of the drivers this didnt happend before.

This might help you.

P.S. You need to switch to TV mode to access this menu that zooms the picture.

:D
Reply With Quote
  #6 (permalink)  
Old 18th October 2004
Junior Member
BS.Player Newbie
 
Join Date: Oct 2004
Posts: 2
Rep Power: 0
SchizoSirhc is an unknown quantity at this point
Default Re: I think I have a workaround ...

I have the same problem. When i set BSPlayer to Force RGB Mode it stopped zooming (so when i am not using overlay). I prefer using overlay however (because it's an older system i use for TV-OUT --> CPU load gets to around 90% when not using overlay).
I also tried another player (ZoomPlayer) and that one didn't zoom in on the TV when setting to FullScreen.

Quote:
Originally Posted by soguy
I doesn't happen when in 'Preferences > Video' I select:
- General: Remember Pan-Scan settings ONLY
- Video Rendereing: Wait for vertical blank
I'll try this when i get home! :)
Reply With Quote
  #7 (permalink)  
Old 18th October 2004
Junior Member
BS.Player Newbie
 
Join Date: Oct 2004
Posts: 2
Rep Power: 0
SchizoSirhc is an unknown quantity at this point
Default

doesnt work for me :(
soguy do you use overlay mode?
Reply With Quote
  #8 (permalink)  
Old 18th October 2004
Junior Member
BS.player Regular User
 
Join Date: Sep 2004
Location: Sweden
Posts: 21
Rep Power: 0
Dennis_Olof is an unknown quantity at this point
Default Hmmm

Soguy, I have this options enabled in BSplayer but I still have this problem. Now that I think of it, I cant remember any other program making the Nvidia Zoom Settings go wrong and zoom in. Only when I use BSplayer I get this problem sometimes.

Perhaps it IS a problem with BSplayer doing some bad things that makes Nvidia settings zoom in or somehow.

Now that you mentioned those settings I guess I need to experiment or find out what the functions do and try them and hope I can get rid of the problem..

Thanks for advice.

:)
Reply With Quote
  #9 (permalink)  
Old 20th October 2004
Junior Member
BS.player Regular User
 
Join Date: Sep 2004
Location: Sweden
Posts: 21
Rep Power: 0
Dennis_Olof is an unknown quantity at this point
Default Thanks SchizoSirhc for the advice on RGB

Here is what solves the problem for me as you said.

Works great now and CPU load ? I dont know of besides im on a 2.0Ghz system so dont care about it.

Anyway here is what happend.

http://forum.bsplayer.org/viewtopic.php?t=5868

It seems RBG aint as good quality as "overlay mode 1" but I have to live with it untill they fix it if they ever will. I hate when the picture on the TV zooms in.

Bah :/

Cheers mate
Reply With Quote
  #10 (permalink)  
Old 23rd October 2004
Junior Member
BS.player Regular User
 
Join Date: Sep 2004
Location: Sweden
Posts: 21
Rep Power: 0
Dennis_Olof is an unknown quantity at this point
Default This works too.

By using VRM-9 this option allso avoids the "zoom in bug" in BSplayer when in TV mode :]

Good to know, but seems BS Player team dont know about this problem.

Though all others should know

:?
Reply With Quote
  #11 (permalink)  
Old 3rd November 2004
Junior Member
BS.Player Newbie
 
Join Date: Sep 2004
Posts: 3
Rep Power: 0
soguy is an unknown quantity at this point
Default Sorry for not replying ...

I'm using VMR-9 renderless with the settings I mentioned above and it's working fine now.
Reply With Quote
  #12 (permalink)  
Old 4th January 2005
Joy Joy is offline
Junior Member
BS.Player Newbie
 
Join Date: Jan 2005
Posts: 4
Rep Power: 0
Joy is an unknown quantity at this point
Default

Did anybody find out how to fix this problem? Could this be a problem of Windows XP or DirectX 9.0c?

I didn't try to make tests on Windows 2000 with DX 9.0c yet, but i seems like with DX 8.1b everything works just fine - i haven't seen this problem before i started to use Windows XP SP2.
Reply With Quote
  #13 (permalink)  
Old 4th January 2005
Joy Joy is offline
Junior Member
BS.Player Newbie
 
Join Date: Jan 2005
Posts: 4
Rep Power: 0
Joy is an unknown quantity at this point
Default

Huh. Bug rides on a bug. Well, well, well.

Did you ever try to change "Video -> Color controls" while playing a video in a VMR-9 mode? Don't trust them all. Here's what i got:

BSplayer v1.02.812, Unhandled exception at EIP: 00512FE8
If you click 'Close' application will be terminated.
Please report this info to the author with description what were you doing.
Floating point division by zero
EZeroDivide
, 0x00542673, 0x00542871, 0x004553C3, 0x0044C70E, 0x77D38709, 0x77D387EB, 0x77D389A5, 0x77D3BCCC, 0x004550D8, 0x00544240, 0x7C816D4F

Bytes at EIP: DE F9 D9 9E 9C 01 00 00 9B 8B 83 F8 02 00 00 DB 80 10

That's pretty ridiculous. Hrrrrm, is BSPlayer team going to fix this or not?
Reply With Quote
  #14 (permalink)  
Old 10th January 2005
Joy Joy is offline
Junior Member
BS.Player Newbie
 
Join Date: Jan 2005
Posts: 4
Rep Power: 0
Joy is an unknown quantity at this point
Default

I regret to realize that "the zoom bug" is not related to BSPlayer. Recently i tried to play around with Windows Media Player and PowerDVD. The same behaviour.

I guess something wrong goes with nVidia drivers while working with DirectX 9.0 release.

Let's see what happens on W2K with DX9. Later ...

P.S. Hello, people, does any body hear me? :)
Reply With Quote
  #15 (permalink)  
Old 22nd November 2005
Junior Member
BS.Player Newbie
 
Join Date: Jul 2005
Posts: 4
Rep Power: 0
Guzo is an unknown quantity at this point
Default

I've found the solution!
And it works 100% sure!

First, open regedit (Start > Execute > Regedit or c:\windows\regedit.exe)
make a backup (file > exporting)

In regedit, search for "videoborder"

You'll find some keys like that :
NVZORAN.525@60Hz.videoborder
NV36ZORAN.525@60Hz.videoborder
NV36ZORAN.625@60Hz.videoborder
NVZORAN.625@50Hz.videoborder
....
(the name depends on your nvidia graphic card but it's always followed by ".videoborder")

The set number should be 01 00 00 00
But some of them have this number : 00 00 00 00
If so, modify the number and correct it so that a "1" appears on the second number : 01 00 00 00 like it should be.

once again the correct answer is for example...
NV36ZORAN.525@60Hz.videoborder = 01 00 00 00

Close regedit when every key has a one in it.
Reboot you're computer for the changing to take effect.

Then you can open your videos in full screen, it'll never zoom in like it used to!
It's fixed, finally!!!!
Good luck and happy viewing!
Reply With Quote
  #16 (permalink)  
Old 14th December 2005
Junior Member
BS.player Regular User
 
Join Date: Dec 2005
Posts: 12
Rep Power: 0
sagivlevi is an unknown quantity at this point
Default Great Solution !!!

It's the only solution that works and it's working great !!!
I had this problem for so long and I try almost everything besides smashing the computer / TV ...

Thanks a lot, your a life savers.
Reply With Quote
  #17 (permalink)  
Old 14th December 2005
Junior Member
BS.Player Newbie
 
Join Date: Dec 2005
Posts: 1
Rep Power: 0
sock58238 is an unknown quantity at this point
Default Good one

This is acctually a good idea, but I cant go along with it.. I'll PM you with my idea. ;)
__________________
free casino money blackjack news
Reply With Quote
Reply

Tags
adjustment, fullscreen, nvidia, screen

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 03:32 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20