Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 15th February 2006
Member
BS.player Regular User
 
Join Date: Aug 2005
Posts: 64
Rep Power: 0
speedtrap is an unknown quantity at this point
Default Subtitles

There are still some subtitle issues in version 1.38.828. Perhaps the devs don't have much clips to use as test samples. So I think that everyone should upload clips which have subtitle problems. Maybe then all these issues can finally be fixed.

My config:
BSplayer 1.38.828
K-Lite Codec Pack 2.70 Standard (so basically just Haali splitter + ffdshow)
VSFilter is not installed
Windows 2000 SP4

BSplayer settings:
Subtitles enabled, vobsub support enabled
Allow intermediate filters and adv. graph building enabled

Clips:
http://rapidshare.de/files/13317220/..._Subs.mp4.html
Menu shows the subtitle track, but no subs are displayed. Subs do show when using the internal renderer (overlay). But not when using Overlay mixer or VMR9.

http://rapidshare.de/files/13317685/...Subs_.mp4.html
Sub are shown, but contain weird characters.

http://rapidshare.de/files/13318006/...s-ssa.mkv.html
Menu shows the subtitle track, but no subs are displayed. No matter which renderer is used.

http://rapidshare.de/files/13319020/...-subs.mkv.html
Works ok with both internal renderer and Overlay mixer. However, there is a major bug: external subs (with different filename!) are given priority over the embedded subs.
Reply With Quote
  #2 (permalink)  
Old 15th February 2006
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 23
Tizio will become famous soon enough
Default

Well done speedtrap
As soon as I can, I will try on my machine the behaviour of theese files and I will post comments here.

I think that devs will be glad to have more material as possible when an issue is found, and I think that this is the right way to make the devs aware of the problems that users are experiencing :)
__________________
BSP SkinMaker (v1.07) the one and only Skin Editor for BSplayer
BSP Definitions Manager (v1.02)
BS.Player's FAQ (by BSPeter) | Italian language file (v2.57 build 1051)
Reply With Quote
  #3 (permalink)  
Old 15th February 2006
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 53
Posts: 5,196
Rep Power: 28
adicoto is on a distinguished road
Default

Just downloaded them. Can't wait to test them :)
Reply With Quote
  #4 (permalink)  
Old 15th February 2006
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 53
Posts: 5,196
Rep Power: 28
adicoto is on a distinguished road
Default

1. MewMew file. Seen it hundred of times :roll: . This file has 16 subtiles. Just one is working, the default english one. In wich you can see the parameters touse to launch the file with a specific subtitle as default (I think). When opening file in VirtualDubMod you get an error about all other subtitle streams about overlapping.

2. x264, can't open file, working on that.

3. No subtitles, nor displayed nor showed into subtitles list, but it may be 3ivX decoder fault not to identify them. What decoder do you use for MP4 files ?

MP4UI detect both MP4 files to have subtitles but can't export them in a readable format (for me).
Reply With Quote
  #5 (permalink)  
Old 15th February 2006
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 23
Tizio will become famous soon enough
Default

For the moment.. really strange behaviour when watching mewmew (mewmew :lol: )...
All my apps freeze until the end of the clip, except for BSplayer that runs perfectly and smoothly. Unfortunally I've no time now to test this, maybe tonight or tomorrow.. now it's almost time to go
__________________
BSP SkinMaker (v1.07) the one and only Skin Editor for BSplayer
BSP Definitions Manager (v1.02)
BS.Player's FAQ (by BSPeter) | Italian language file (v2.57 build 1051)
Reply With Quote
  #6 (permalink)  
Old 15th February 2006
Member
BS.player Regular User
 
Join Date: Aug 2005
Posts: 64
Rep Power: 0
speedtrap is an unknown quantity at this point
Default

BSplayer crashes (unhandled exception error) on the XviD+Mp3+Subs.mp4 file when subtitles are disabled in the options.


http://rapidshare.de/files/13347330/...pters.mkv.html
The first subtitle track (arabic) is displayed correctly with internal renderer. The other subtitle tracks only show weird black artifacts instead of text.

http://rapidshare.de/files/13347798/...rbis_.mkv.html
No subs are displayed. These subs have karaoke effect.
Reply With Quote
  #7 (permalink)  
Old 15th February 2006
Member
BS.player Regular User
 
Join Date: Aug 2005
Posts: 64
Rep Power: 0
speedtrap is an unknown quantity at this point
Default

I use Haali splitter for mkv and mp4 files. CoreAVC for decoding H.264 and ffdshow for all other audio/video formats.

All these files work correctly in WMP and MPC, using VSFilter for the subs.
Reply With Quote
  #8 (permalink)  
Old 15th February 2006
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 53
Posts: 5,196
Rep Power: 28
adicoto is on a distinguished road
Default

Neo :) fights OK in here, all subtitle (supported by the OS) displayed OK, with one problem. You must rewind the file a second to enable the change of the subtitle.
Filters in use:
real video decoder
3ivX audio decoder
Matroska splitter

THe other file, I just have to wait for 54 min to be able to download it. Tomorrow.
Reply With Quote
  #9 (permalink)  
Old 16th February 2006
Member
BS.player Regular User
 
Join Date: Aug 2005
Posts: 64
Rep Power: 0
speedtrap is an unknown quantity at this point
Default

The problems with the XviD+Mp3+Subs.mp4 file have been solved with 1.39.829 :D

Here is a screenshot from the Notebook clip:


And for the Matrix clip (ignore the black background):


As for the vsshort-vorbis-subs.mkv file:
When no external subs are present it plays correctly, displaying the embedded subs. However when I place a sub file called 'vsshort-vorbis-subs2.srt' (notice different filename) in the same directory, those subs are used. I guess this is because it has the same prefix as the movie file. So this more a feature than a bug. I now also noticed that the embedded sub tracks also show up in the subs menu. However, after selecting one of them bsplayer keeps showing the external sub. So that is a bug.
Reply With Quote
  #10 (permalink)  
Old 17th February 2006
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 53
Posts: 5,196
Rep Power: 28
adicoto is on a distinguished road
Default

Try to disable "auto load any subtitle from current directory". Normally it should not load any more external suvtitle if it does not have exactly the same name.
Reply With Quote
Reply

Tags
subtitles

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 01:18 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20