Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 30th October 2007
Junior Member
BS.player Regular User
 
Join Date: Jul 2007
Posts: 13
Rep Power: 0
estugarda is an unknown quantity at this point
Default [SOLVED] BSPlayer 2.24 problems after new GPU driver install

Since I installed NVIDIA 163.69 driver few days ago, I noticed that there is no hardware acceleration (pixels are visible, video is not so smooth as before) in BSplayer 2.24 build954 (when rendering is set to "Internal renderer Direct Draw surface" - which was the only 100% working solution for me on Vistax64, and which worked fine until 163.69). In Media Player acceleration works fine though, but it doesn't play some videos. I never used it much so I can't say if this was so before 163.69.

Interesting thing is that my DVB-S TV app has "Generic video renderer" as Video Render Mode, and there it works great. Acceleration is working there.

Before this new NVIDIA 163.69 driver I had 162.22 driver and it worked great for few months - since I had Vista x64. With the same hardware and codecs as I have now, none of these problems did show.
My first idea was to go back to 162.22 when I discovered the problems, and so I did, but pixels were still visible in BSplayer. Last night Windows has updated GPU driver back to 163.69, and the problem is still persistent.

What can I do?
Thank you in advance...
Reply With Quote
  #2 (permalink)  
Old 30th October 2007
Ico-man's Avatar
BS.Support
BS.Player Power User
 
Join Date: Sep 2006
Location: Slovenia
Posts: 1,459
Rep Power: 10
Ico-man is on a distinguished road
Default

At the moment, all you can do is change video renderer.

We are preparing improvements to EVR video renderer in future versions and also internal Direct3D video renderer is in the development, which will completely resolve this isues with Nvidia graphic cards and will enable BS.Player to fully exploit capabilities of the newer graphic cards.
Reply With Quote
  #3 (permalink)  
Old 30th October 2007
Junior Member
BS.player Regular User
 
Join Date: Jul 2007
Posts: 13
Rep Power: 0
estugarda is an unknown quantity at this point
Default

Thank you for an urgent reply...

Well I would change video renderer, but none will work, or will not work properly.

1. Internal renderer DirectDraw surface - no hardware acceleration
2. Internal renderer overlay (default) - no hardware acceleration
3. Internal renderer RGB mode - no hardware acceleration
4. Internal renderer RGB overlay - doesn't work at all
5. Overlay mixers - crashes Aero, no hardware acceleration
6. VRM7 - hardware acceleration working but only with ugly poorly controlable integrated subtitles which drive me mad, also colors are strange, some videos don't play at all
6. VRM7 renderless - hardware acceleration working but only with ugly poorly controlable integrated subtitles which drive me mad, also colors are strange, some videos don't play at all
7. VRM9 - hardware acceleration working but only with ugly poorly controlable integrated subtitles which drive me mad, also colors are strange, some videos don't play at all
8. VRM9 renderless - hardware acceleration working but only with ugly poorly controlable integrated subtitles which drive me mad, also colors are strange, some videos don't play at all
9. EVR - hardware acceleration working, colors fine but no subtitles at all...

None of this is acceptable for me.

Note that with Internal renderer DirectDraw surface rendrer, BSplayer was working great for more then a half year on 100% same hardware/software/codec with older GPU NVIDIA driver.

Why is that? And why doesn't it work anymore on the same old 162.22 driver on which it worked before?
Reply With Quote
  #4 (permalink)  
Old 2nd November 2007
Junior Member
BS.player Regular User
 
Join Date: Jul 2007
Posts: 13
Rep Power: 0
estugarda is an unknown quantity at this point
Default

300 people have seen the post. Including admins. Somebody has to know what caused this problem that I have. I have a feeling that it can be solved easy, but I don't see how...
It worked before, it should work now...
Someone...please...
Reply With Quote
  #5 (permalink)  
Old 4th November 2007
Junior Member
BS.player Regular User
 
Join Date: Jul 2007
Posts: 13
Rep Power: 0
estugarda is an unknown quantity at this point
Default

HOW WILL YOU EXPLAIN THIS:

Apparently, hardware video acceleration works only for DivX 3 (Div3) files on "Internal renderer DirectDraw Surface". Could it actually be a codec issue? And why would that happen out of nothing?

EDIT:
Looks like it was a CODEC PROBLEM. Deinstalled them, installed the same ones and everything works now like it used to. Just as I assumed, it was an easy-to-solve problem. I wonder why nobody here thought of this!?

It is not a direct BSplayer bug.

What I think happened;
Newest NVIDIA GPU driver somehow messed up all the codecs.
Reply With Quote
Reply

Tags
224, gpu

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 04:37 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19