Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Bug Reports And Codecs

Bug Reports And Codecs Report BS.Player bugs here - help us to improve BS.Player even further.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 22nd March 2008
Junior Member
BS.player Regular User
 
Join Date: Mar 2008
Posts: 10
Rep Power: 0
Maxy is an unknown quantity at this point
Default File association problems

I'm running Vista x86 and BS.Player 2.27.959 and I'm having some file association problems.

1. Every time I open and close preferences my default programs get all messed up. I'm not sure why this happens but I'm positive BS.Player causes it to happen. For example: I have Windows Live Mail set as my default E-mail client, Windows Live Photo Gallery as my default picture viewer and for .icl files Axialis IconWorkshop. But every time I open and close BS.Player preferences it all changes, Microsoft Office Outlook becomes my default E-mail client, Windows Photo Gallery my default picture viewer and as for .icl files, the default program for them changes to nothing (in other words no program is set as the default program for this files). I'm not sure if this happens with any other programs, I've noticed it to happen only with the aforementioned ones.

2. I can't seem to make BS.Player my default player for .mpa files. I open preferences, check the checkbox next to .mpa, close preferences but when I open them again the checkbox is unchecked and the file are not associated with BS.Player.
Reply With Quote
  #2 (permalink)  
Old 30th March 2008
Junior Member
BS.Player Newbie
 
Join Date: Mar 2008
Posts: 1
Rep Power: 0
Paoluzzo is an unknown quantity at this point
Default

Hello Maxy,

I encountered exactly the same problem as described by you.
All file associations get messed up. For examples associations for WinAmp and even my standard Webbrowser gets changed from Firefox to IE7.

Just as you I use BS.player 2.27. My OS is Vista Home Premium with SP1.

My problems started after I purchased BS.Player 2.27. Everything get's messed up every time I watch a movie with BS.player.

Regards,
Paul
Reply With Quote
  #3 (permalink)  
Old 5th April 2008
Junior Member
BS.Player Newbie
 
Join Date: Apr 2008
Location: UK
Posts: 2
Rep Power: 0
darena_x is an unknown quantity at this point
Default so you get similiar thing to me

i get my file associations messed up by bs player and on the top of everything i can't play amnyhting on it and itdoesn't display why i can't play that file.
Reply With Quote
  #4 (permalink)  
Old 6th April 2008
Junior Member
BS.player Regular User
 
Join Date: Mar 2008
Posts: 10
Rep Power: 0
Maxy is an unknown quantity at this point
Default

@Paoluzzo

I haven't noticed this earlier but my default web browser gets changed too. No matter what I set as the default, Firefox or Opera, the settings are always changed back to IE.
Reply With Quote
  #5 (permalink)  
Old 11th May 2008
Junior Member
BS.Player Newbie
 
Join Date: Sep 2007
Posts: 4
Rep Power: 0
Zanpakutou is an unknown quantity at this point
Default

Same problem, with both 2.26 & 2.27 on XP SP2.
Even with filetypes that have nothing to do with BS.Player (eg torrents get reassigned to nothing, instead of uTorrent) while other filetypes remain unaffected.
Only happens when i open preferences, just running BS.Player won't do it.

Definitely one of the more annoying bugs, so plz fix or give instructions on how to fix. thnx
Reply With Quote
  #6 (permalink)  
Old 12th May 2008
Ico-man's Avatar
BS.Support
BS.Player Power User
 
Join Date: Sep 2006
Location: Slovenia
Posts: 1,459
Rep Power: 10
Ico-man is on a distinguished road
Default Multimedia software player - BS.Player

@all users running Vista: File associations problem in Vista was fixed in BS.Player 2.28.
Please re-download an re-install BS.Player 2.28 to fix this problem.

@Zanpakutou : "Same problem, with both 2.26 & 2.27 on XP SP2. "
The bug described above by users in Vista OS can't happen in Windows XP, because Windows XP do not have this function at all. This may be different bug with similar results, please give us more info about the conditions under which this bug occurs in XP SP2.
Reply With Quote
  #7 (permalink)  
Old 19th May 2008
Junior Member
BS.Player Newbie
 
Join Date: Sep 2007
Posts: 4
Rep Power: 0
Zanpakutou is an unknown quantity at this point
Default

I can only think of two filetypes that are affected, mp3s and torrents.
Torrents go from uTorrent to nothing and mp3s go from XMPlay to Windows Media Player.
I don't have to actually change any settings for it to happen, just opening and closing the settings dialogue will do it.
'Register extensions on player start' is disabled.
The problem is still present in 2.28

Something odd i just noticed, so may only be with 2.28.
If i leave mp3s with WMP and reset torrents to uTorrent, then change a setting, torrents stay with uTorrent.
But if i reset mp3s to XMPlay and torrents to uTorrent, then change a setting, both lose their associations.
Reply With Quote
Reply

Tags
association

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 06:54 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19