Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > General Talk And Support

General Talk And Support General talk and peer-to-peer support about BS.Player and other video and audio multimedia players.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 15th June 2006
Junior Member
BS.Player Newbie
 
Join Date: Jun 2006
Posts: 6
Rep Power: 0
valkyrie5034 is an unknown quantity at this point
Default Problem with equalizer settings

Good day, i've just started using BSplayer recently and found it to be an excellent player.

However, i'm facing problem with the equalizer setting. After i save it, it's reset to default after i close the equalizer. The eq.xml file has been created in %appdata% directory and i've disabled read only access.

I tried moving or copying the file to where bsplayer.exe is located, hoping the player will read from the same folder but it will create another one in %appdata% instead.

Any idea how to fix this? Thanks in advance.
Reply With Quote
  #2 (permalink)  
Old 15th June 2006
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 21
Tizio will become famous soon enough
Default

I don't really know what can cause this problem, I can't reproduce it..
But what is your problem? You save a preset in the equalizer and it is not remembered, or the thing your equalizer doesn't remember are the bands' levels?
While presets are saved in EQ.xml file, bands levels are saved in BSplayer.xml (located in %appdata%).

If the problem is related to the not remembered presets:
Once the EQ.xml file is created, can you open it with a text editor? Are the presets added there at the bottom of the file?

If the problem is with bands levels, allow write access to BSplayer.xml file and if the problem persists then maybe try to delete that file (in case make a backup copy of it)..
__________________
BSP SkinMaker (v1.07) the one and only Skin Editor for BSplayer
BSP Definitions Manager (v1.02)
BS.Player's FAQ (by BSPeter) | Italian language file (v2.57 build 1051)
Reply With Quote
  #3 (permalink)  
Old 15th June 2006
Junior Member
BS.Player Newbie
 
Join Date: Jun 2006
Posts: 6
Rep Power: 0
valkyrie5034 is an unknown quantity at this point
Default

Yes, the presets are saved correctly in the EQ.xml file, opening it with notepad shows what i saved are there.

Each time i open equalizer, the band levels are reset to default. I can load the saved preset but closing the equalizer and reopen it, resets the value to 0 (default).

When i close BSplayer and check the BSplayer.xml, the band level is saved with my last used preset but after i run BSplayer again, this time without opening equalizer, their value becomes 0 again.
Reply With Quote
  #4 (permalink)  
Old 15th June 2006
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 21
Tizio will become famous soon enough
Default

I can't reproduce it? (using v2.0.0.937)
Which version are you using?
__________________
BSP SkinMaker (v1.07) the one and only Skin Editor for BSplayer
BSP Definitions Manager (v1.02)
BS.Player's FAQ (by BSPeter) | Italian language file (v2.57 build 1051)
Reply With Quote
  #5 (permalink)  
Old 16th June 2006
Junior Member
BS.Player Newbie
 
Join Date: Jun 2006
Posts: 6
Rep Power: 0
valkyrie5034 is an unknown quantity at this point
Default

I downloaded the free version so it's BSplayer v2.0.

I've tried it on my laptop and it's still the same. All player settings are remembered except the equalizer band level. Winamp DSP plugin works so i guess it will do for now.

Hope the developers can come up with an option to let users choose where to store settings instead of %appdata%.
Reply With Quote
  #6 (permalink)  
Old 16th June 2006
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 21
Tizio will become famous soon enough
Default

http://forum.bsplayer.org/viewtopic.php?p=24836#24836
__________________
BSP SkinMaker (v1.07) the one and only Skin Editor for BSplayer
BSP Definitions Manager (v1.02)
BS.Player's FAQ (by BSPeter) | Italian language file (v2.57 build 1051)
Reply With Quote
  #7 (permalink)  
Old 16th June 2006
Junior Member
BS.Player Newbie
 
Join Date: Jun 2006
Posts: 6
Rep Power: 0
valkyrie5034 is an unknown quantity at this point
Default

Well, i hope the developers implement this feature in the future. Thanks for the help, Tizio ^^
Reply With Quote
  #8 (permalink)  
Old 17th June 2006
Junior Member
BS.Player Newbie
 
Join Date: Jun 2006
Posts: 8
Rep Power: 0
uncpotato is an unknown quantity at this point
Default

I guess I have hit into the same problem.

I upgrade from V1.3x to V2, but then I found that the equalizer is not working at all.

While playing an MP3 file, I press Alt-G to invoke the equalizer settings, the default shows the :flat: settings (all in middle)
I pull some up/down but the sound doesn't seem to respond to them.
If I click close & alt-G again, the settings all return to middle.
same thing happen if I load the default from the presets list.

On the options-Preference-audio page, I check that the equalizer is ON, so it is possibly be a program bug.
The version I downloaded is v2 build 937.
Reply With Quote
  #9 (permalink)  
Old 18th June 2006
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 21
Tizio will become famous soon enough
Default

Quote:
Originally Posted by uncpotato
On the options-Preference-audio page, I check that the equalizer is ON, so it is possibly be a program bug.
The version I downloaded is v2 build 937.
Is the blue led (on the default BSP2 Equalizer skin) on?
__________________
BSP SkinMaker (v1.07) the one and only Skin Editor for BSplayer
BSP Definitions Manager (v1.02)
BS.Player's FAQ (by BSPeter) | Italian language file (v2.57 build 1051)
Reply With Quote
  #10 (permalink)  
Old 18th June 2006
Junior Member
BS.Player Newbie
 
Join Date: Jun 2006
Posts: 8
Rep Power: 0
uncpotato is an unknown quantity at this point
Default

I never like the new base skin of V2, so I set back to my fav. SC2
With SC2, equalizer settings doesn't have the EQ-ON/OFF, so I expect the EQ on/off should reflect on OPtions-Preference-Audio [X] EQUALIZER ON
But it appearantly NOT.

I return to the base skin, now I see the EQ ON/OFF on the equalizer settings page, it is OFF (which contradict with the options pref)
If I click ON, then the sound does respond to my new settings, it works even after I close it (but there is not a close button?!, nor it respond to ESC, I must click the same button on the main window)
However, if I click EQ to bring up the settings screen, the EQ are all return to flat.
Reply With Quote
  #11 (permalink)  
Old 18th June 2006
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 21
Tizio will become famous soon enough
Default

Quote:
Originally Posted by uncpotato
I never like the new base skin of V2, so I set back to my fav. SC2
With SC2, equalizer settings doesn't have the EQ-ON/OFF, so I expect the EQ on/off should reflect on OPtions-Preference-Audio [X] EQUALIZER ON
But it appearantly NOT.

I return to the base skin, now I see the EQ ON/OFF on the equalizer settings page, it is OFF (which contradict with the options pref)
If I click ON, then the sound does respond to my new settings, it works even after I close it (but there is not a close button?!, nor it respond to ESC, I must click the same button on the main window)
However, if I click EQ to bring up the settings screen, the EQ are all return to flat.
Thank you for the report, I'll add the problem to the bugs section
__________________
BSP SkinMaker (v1.07) the one and only Skin Editor for BSplayer
BSP Definitions Manager (v1.02)
BS.Player's FAQ (by BSPeter) | Italian language file (v2.57 build 1051)
Reply With Quote
Reply

Tags
equalizer, settings

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 06:15 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19