Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > General Talk And Support

General Talk And Support General talk and peer-to-peer support about BS.Player and other video and audio multimedia players.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #21 (permalink)  
Old 21st December 2007
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 22
Tizio will become famous soon enough
Default

Quote:
Originally Posted by adicoto
Reinstall Windows, your system it's .......
Quote!

[quote=BSPeter]
Quote:
Originally Posted by kimiraikkonen
Quote:
Originally Posted by 'Tizio'
Is it possible that your HDD is fragmented a lot or has bad sectors?
Try to defragment it[/quοte]....
Quote:
Originally Posted by kimiraikkonen earlier
BsPeter & adicoto, i knew how to disable....,
:?

This time I edited it again... who knows if he'll disable it next time (maybe I should had left it like it was :P )
__________________
BSP SkinMaker (v1.07) the one and only Skin Editor for BSplayer
BSP Definitions Manager (v1.02)
BS.Player's FAQ (by BSPeter) | Italian language file (v2.57 build 1051)
Reply With Quote
  #22 (permalink)  
Old 21st December 2007
Senior Member
BS.Player Power User
 
Join Date: Sep 2006
Posts: 231
Rep Power: 0
kimiraikkonen is an unknown quantity at this point
Default

[quote=BSPeter]
Quote:
Originally Posted by kimiraikkonen
Quote:
Originally Posted by 'Tizio'
Is it possible that your HDD is fragmented a lot or has bad sectors?
Try to defragment it[/quοte]....
Quote:
Originally Posted by kimiraikkonen earlier
BsPeter & adicoto, i knew how to disable....,
:?
What does it mean? From the first post, still i'm trying to find out why you got angry about my posts :roll: Could you explict the effect of "disabling HTMLs".
(I'm disabling in evey post). Here is a quote again and "disable HTML in this post" is checked. Is it wrong?
__________________
"Iceman" will never be melted...
Reply With Quote
  #23 (permalink)  
Old 21st December 2007
Senior Member
BS.Player Power User
 
Join Date: Sep 2006
Posts: 231
Rep Power: 0
kimiraikkonen is an unknown quantity at this point
Default

Quote:
Originally Posted by adicoto
Adicoto, 720p and 1080i samples were opened by Bsplayer with no problem and 720p sample used about %70-75 CPU and 1080i used about %75-80 CPU(nearly same).

720p sample is played with no major sync lost,almost smooth, but 1080i was horrible, there were a lot of sync losses and audio/transition(video) corruption/jitters and FPS were about 17-18fps for this(1080i, your sample) 30fps file. Also while running 1080i, HDD usage was very very excessive nearly was in 720p.

My system is old (looking for upgrade):
P4 2.4GHZ
Geforce4 MX440 64MB-DDR
C-Media CMI8738 on-board sound chip.
Latest drives.
7200RPM ATA-100(UDMA-5) Seagate drive.

However the interesting points are two:

1-If i move or remove this file elsewhere it's opened OK with Bsplayer Pro, otherwise only WMP9 opens it.(if i don't move or copy).

2-If the video file or hardware was faulty,either WMP couldn't have opened it. So, is there a kind of file PATH blacklist or cached user data resides in Bsplayer and how to fix it?

Thanks.

Note: "Disable HTML in this post" is checked as well.
__________________
"Iceman" will never be melted...
Reply With Quote
  #24 (permalink)  
Old 22nd December 2007
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 27
BSPeter is on a distinguished road
Default

Quote:
Originally Posted by kimiraikkonen
....
Note: "Disable HTML in this post" is checked as well.
That's it!
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #25 (permalink)  
Old 22nd December 2007
Senior Member
BS.Player Power User
 
Join Date: Sep 2006
Posts: 231
Rep Power: 0
kimiraikkonen is an unknown quantity at this point
Default

Hi :D I found and fixed the problem, it was too weird. The file was in a directory and this directory was containing a text file and a shortcut URL file (advertisement of uploader), i deleted that 2 files with only video remained, now it's opened OK with Bsplayer without location change.

So, that means Bsplayer Pro queries the directory structure and tries to connect the URL which is within in the same DIR with the video file. :evil:

No codec, no hardware.... Bsplayer :D
__________________
"Iceman" will never be melted...
Reply With Quote
  #26 (permalink)  
Old 22nd December 2007
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,155
Rep Power: 27
adicoto is on a distinguished road
Default

The purpose of the sample was for you to see how a real HD file look like. Your hardware it's close to the minimal requirements but your hard drive couldn't match the transfer rate requiered. That's why the stuttering. ANd the usage of 80 % CPU even the file waqsn't playng correctly. CPU was decoding in time the data transfered, but the HDD wasn't sending enough data to decode.
If you are looking for an upgrade, buy a videocard that is having HD support (BR and HD DVD)

Offtopic :lol: I do also have a lot of files in folders with a text file and an URL, but never had this problem. Weird, isn't it ? It's the option "load any subtitle in current folder" enabled ?
Reply With Quote
  #27 (permalink)  
Old 22nd December 2007
Moderator
BS.Player Master
 
Join Date: Nov 2003
Location: Italy
Posts: 3,037
Rep Power: 22
Tizio will become famous soon enough
Default

[quote=kimiraikkonen]
Quote:
Originally Posted by BSPeter
Quote:
Originally Posted by kimiraikkonen
Quote:
Originally Posted by 'Tizio'
Is it possible that your HDD is fragmented a lot or has bad sectors?
Try to defragment it[/quοte]....
Quote:
Originally Posted by kimiraikkonen earlier
BsPeter & adicoto, i knew how to disable....,
:?
What does it mean? From the first post, still i'm trying to find out why you got angry about my posts :roll: Could you explict the effect of "disabling HTMLs".
(I'm disabling in evey post). Here is a quote again and "disable HTML in this post" is checked. Is it wrong?
Finally it's ok!! Congrats for your fix too!
__________________
BSP SkinMaker (v1.07) the one and only Skin Editor for BSplayer
BSP Definitions Manager (v1.02)
BS.Player's FAQ (by BSPeter) | Italian language file (v2.57 build 1051)
Reply With Quote
  #28 (permalink)  
Old 22nd December 2007
Senior Member
BS.Player Power User
 
Join Date: Sep 2006
Posts: 231
Rep Power: 0
kimiraikkonen is an unknown quantity at this point
Default

Quote:
Originally Posted by adicoto
The purpose of the sample was for you to see how a real HD file look like. Your hardware it's close to the minimal requirements but your hard drive couldn't match the transfer rate requiered. That's why the stuttering. ANd the usage of 80 % CPU even the file waqsn't playng correctly. CPU was decoding in time the data transfered, but the HDD wasn't sending enough data to decode.
If you are looking for an upgrade, buy a videocard that is having HD support (BR and HD DVD)

Offtopic :lol: I do also have a lot of files in folders with a text file and an URL, but never had this problem. Weird, isn't it ? It's the option "load any subtitle in current folder" enabled ?
Hi :) , at first i surprised that 720p and 1080i samples were costing almost the same amount of CPU but it's not understandable that 7200RPM drive isn't enough, i bet most of drives in the world is 7200rpm(udma 5+) but my drive is 6736 hours old, young huh? (Smart data). 720p was quite smooth with no great satisfaction, 1080i was nightmare.
At this point i must ask: Although CPU usage wasn't %100, was the sluttering because of video card/HDD usage?

Also VGA card isn't enough in my opinion for HD files, 64MB video memory is definitely minimum at its limits.

About the problem, one of the weirdist problem in the world :D , if there wasn't a coincidence, after deleting that 5 lined advertisement and shortcut url file, it's opened well.

Maybe you can try:

http://rs1.rapidshare.com/files/6204...use_of_you.rar

Directly extract RAR into the folder with commanding "extract here", try to double click video(same folder video and text/url files). Highly possible that you may not have problem like me but you can try.
__________________
"Iceman" will never be melted...
Reply With Quote
  #29 (permalink)  
Old 22nd December 2007
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,155
Rep Power: 27
adicoto is on a distinguished road
Default

I've donloaded allready the video file, could you post just the txt and the url files ?
Reply With Quote
  #30 (permalink)  
Old 22nd December 2007
Senior Member
BS.Player Power User
 
Join Date: Sep 2006
Posts: 231
Rep Power: 0
kimiraikkonen is an unknown quantity at this point
Default

Quote:
Originally Posted by adicoto
I've donloaded allready the video file, could you post just the txt and the url files ?
Url and text files are included in the RAR archive which is on the link i've posted, currently i don't have them(deleted as a solution you know).

I also tried; Robotica Sample from MS Site(720p - 1280x720) with a very smooth playback. (cpu usage was about %45-50)
__________________
"Iceman" will never be melted...
Reply With Quote
  #31 (permalink)  
Old 22nd December 2007
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,155
Rep Power: 27
adicoto is on a distinguished road
Default

Sorry, I forgot. i still have the url and txt file :D in the folder where I've extracted your archive. That's the place where I did run the file in the first place, with no problems at all.
MS site provide WMV HD files, not MPEG2 nor x264/H264. Those files do have a small bitrate, so it's easy to stream the file from the HD. This codec it's used by the scene for HD porn and to re-encode files for MS consoles. VC1, an evolution of this codec (I wonder what "evolution" means in this context) it's used for HD material on optical support.
Reply With Quote
  #32 (permalink)  
Old 22nd December 2007
Senior Member
BS.Player Power User
 
Join Date: Sep 2006
Posts: 231
Rep Power: 0
kimiraikkonen is an unknown quantity at this point
Default

Quote:
Originally Posted by adicoto
Sorry, I forgot. i still have the url and txt file :D in the folder where I've extracted your archive. That's the place where I did run the file in the first place, with no problems at all.
MS site provide WMV HD files, not MPEG2 nor x264/H264. Those files do have a small bitrate, so it's easy to stream the file from the HD. This codec it's used by the scene for HD porn and to re-encode files for MS consoles. VC1, an evolution of this codec (I wonder what "evolution" means in this context) it's used for HD material on optical support.
Weird, IIRC(not so sure) the stranger thing, i moved video file another location, then also moved url/text elsewhere, then brought back video/url to the same (initial, first extracted) folder and opened from in it with no problem. :roll:
__________________
"Iceman" will never be melted...
Reply With Quote
  #33 (permalink)  
Old 22nd December 2007
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,155
Rep Power: 27
adicoto is on a distinguished road
Default

Quote:
Originally Posted by adicoto
Reinstall Windows, your system it's .......
Reply With Quote
  #34 (permalink)  
Old 22nd December 2007
Senior Member
BS.Player Power User
 
Join Date: Sep 2006
Posts: 231
Rep Power: 0
kimiraikkonen is an unknown quantity at this point
Default

I did further test, the hang (lock) doesn't occur if the advertisement text file isn't in the directory. If you remain video and URL file in the same directory, no problem but if you locate video+URL+text it gets locked. Really weird.

Also, if you create an empty text file named the same as advertisement text's name, no lock occurs, but if you copy the text content into your text file that you created, again it gets lock.

Shortly, if there's no this advertisement text file in the same DIR with video, it runs OK.
__________________
"Iceman" will never be melted...
Reply With Quote
  #35 (permalink)  
Old 22nd December 2007
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 27
BSPeter is on a distinguished road
Default

Quote:
Originally Posted by adicoto
Is the option "load any subtitle in current folder" enabled ?
You never replied this question
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #36 (permalink)  
Old 22nd December 2007
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,155
Rep Power: 27
adicoto is on a distinguished road
Default

I am 99,99 % sure.
Reply With Quote
  #37 (permalink)  
Old 23rd December 2007
Senior Member
BS.Player Power User
 
Join Date: Sep 2006
Posts: 231
Rep Power: 0
kimiraikkonen is an unknown quantity at this point
Default

Quote:
Originally Posted by BSPeter
Quote:
Originally Posted by adicoto
Is the option "load any subtitle in current folder" enabled ?
You never replied this question
Hi there, thanks for all the replies. :) I saw new. Yep, if i check preferences -> subtitles -> "subtitles disabled", the problem goes away, if it's unchecked(subtitles enabled) it gets hang.

At this point, it's a proof that it's a BSPLAYER bug or problem but currently my version is very old (1.41) maybe it's fixed or not in newers. Although the text file's extension is not ".srt" or ".sub", it shouldn't be recognized as subtitle and shouldn't hanged on opening.
__________________
"Iceman" will never be melted...
Reply With Quote
  #38 (permalink)  
Old 23rd December 2007
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 52
Posts: 5,155
Rep Power: 27
adicoto is on a distinguished road
Default

The extension is .txt, and this is a valid extension for subtiles.

LE: If you have this option enabled and in the folder you have a file with a valid subtitle extension, but the file isn't in fact a subtitle, BSPlayer hangs up with no error message. It does not detect that the subtitle file it's not what it claims to be. I think you can post this as a bug, in the apropiate section: better detection of the corrupted subtitle file (that counts for a non-subtitle :roll: subtitle file)
Reply With Quote
Reply

Tags
hang, opening

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules


All times are GMT +1. The time now is 08:59 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20