Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Answered And Solved Questions

Answered And Solved Questions A good place to check before you post your question. All answered / solved posts are archived here.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 3rd April 2010
Junior Member
BS.Player Newbie
 
Join Date: Apr 2010
Posts: 9
Rep Power: 0
cressy is on a distinguished road
Default [SOLVED] No sound in mp4's

I just started watching a mp4 file and was prompted to update to v2.52 build 1031. Before the update i had sound now after the update no sound. I still get sound in avi, mpg, wmv, mkv and divx files and in audio files.

Is there a fix for this? if not then a download link for the previous version would be helpful.

I need sound to watch my daily download of the independent news show called Democracy Now.
Reply With Quote
  #2 (permalink)  
Old 5th April 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Just downloaded FridayApril22010937.mp4 and tested.
No problem whatsoever!
With the file loaded, what info is shown if you click on "Source" under
(rightclick >) Options > Filters > Advanced ?
What other filters/codecs are shown there?
(Clicking on the small [+]-signs reveals further info and/or access to the filters/codecs)

P.S.:
Did you allow BS.Player upon its installation to internally install the filters/codecs it needs?
Did you perhaps install any codec-packs? (We generally advise against doing so!)
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #3 (permalink)  
Old 5th April 2010
Junior Member
BS.Player Newbie
 
Join Date: Apr 2010
Posts: 9
Rep Power: 0
cressy is on a distinguished road
Default

The only thing I did was update from build 1030 to build 1031. During this update it also updated 3 of the 5 codecs listed in the codec manager. I never installed any extra codecs just the ones that the player installs during installation, never needed to. That is why i like this player so much and have recommended it to many friends. Been using BSPlayer for a little over 2 years. Never had a problem with any files until it stopped playing sound in mp4's. I was playing a mp4 file and had sound while using build 1030. Immediately after the update to build 1031 I tried to continue watching the mp4 file but I no longer had sound. All other file types are unaffected and continue to work as they should.

I've never been into the Advanced settings before and i've never changed any settings under preferences except for the skin which i changed to mediaBOX V-1

ffdshow Video Decoder
Location: C:\Program Files\Webteh\BSplayer\FFDShow\
ffdshow.ax, Size: 3565056 bytes, Version 1.0.7.3135

CompanyName:
FileDescription: DirectShow and VFW video and audio decoding/encoding/processing filter
FileVersion: 1.0.7.3135
InternalName: ffdshow
LegalCopyright: Copyright © 2002-2008
LegalTradeMarks: GNU GPL
OriginalFilename: ffdshow.ax
ProductName: ffdshow
ProductVersion: 1.0.7.3135
Comments: 1.0.7.3135

Source
Location: C:\Program Files\Webteh\BSplayer\Haali media splitter\
splitter.ax, Size: 550400 bytes, Version 1.9.355.21

CompanyName:
FileDescription: Haali Media Splitter
FileVersion: 1.9.355.21
InternalName: 1.9.355.21
LegalCopyright: Copyright (C) 2004-2009 Mike Matsnev
LegalTradeMarks: Copyright (C) 2004-2009 Mike Matsnev
OriginalFilename: Copyright (C) 2004-2009 Mike Matsnev
ProductName: Haali Media Splitter
ProductVersion: 1.9.355.21
Comments: 1.9.355.21


Under Output
Use custom media type for H.254 No
Force fake 25 fps in media type No
SSA fontsize scale percentage 100
Decoder priority boost Off
Show file muxer version as rating tag No
Reply With Quote
  #4 (permalink)  
Old 5th April 2010
Junior Member
BS.Player Newbie
 
Join Date: Apr 2010
Posts: 2
Rep Power: 0
mazator is on a distinguished road
Default Same issue here

Quote:
Originally Posted by cressy View Post
I just started watching a mp4 file and was prompted to update to v2.52 build 1031. Before the update i had sound now after the update no sound. I still get sound in avi, mpg, wmv, mkv and divx files and in audio files.

Is there a fix for this? if not then a download link for the previous version would be helpful.

I need sound to watch my daily download of the independent news show called Democracy Now.
I have the same problem - after installing build 1031 no sound from several video formats - the source is OK, sounds plays correctly using other players - but I just like BSPLayer:-)
Reply With Quote
  #5 (permalink)  
Old 5th April 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

If you click on Source > About does Haali Media Splitter show both a video and audio graphic?
Further: AAC sound may be handled by either ffdshow filter or by CoreAAC (click here).
In ffdshow maybe verify that "AAC / libfaad2" is also listed under "Codecs" of "ffdshow audio" (and that it isn't disabled there).
(You can access though Filters > Advanced etc.)
Alternatively (also if ffdshow Audio Decoder doesn't show under filters) try installing CoreAAC Audio Decoder.

P.S.: I happen to have CoreAAC installed and BS.Player uses it.
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #6 (permalink)  
Old 5th April 2010
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 49
Posts: 5,118
Rep Power: 25
adicoto is on a distinguished road
Default

Seems ffdshow continues to create problems with BSPlayer.
I am not using it, just independent codecs. No problems whatsoever with AAC sound. Probably this build has some issues with ffdshow. Downgrade to a previous version or install CoreAAC.
Reply With Quote
  #7 (permalink)  
Old 5th April 2010
Junior Member
BS.Player Newbie
 
Join Date: Apr 2010
Posts: 1
Rep Power: 0
lidmon is on a distinguished road
Default

I had the same problem when playing mp4. Just video, no sound.
Thanks BSPeter, after installing CoreACC from your link, i have and sound.
Reply With Quote
  #8 (permalink)  
Old 5th April 2010
Junior Member
BS.Player Newbie
 
Join Date: Apr 2010
Posts: 9
Rep Power: 0
cressy is on a distinguished road
Default

The graph is showing only one line if that is what you are talking about.
Under advanced all there is is ffdshow video decoder and source, if there was more i would have pasted that too so you could see it.

Just installed CoreAAC and it was put in system32, i hope that is right place. It worked, now have sound again There are now two graphs under source/about.

Thanks a lot for the help, now i have to go fix a couple of my friends computers. They are having the same problems. And thanks again for the best media player.
Reply With Quote
  #9 (permalink)  
Old 5th April 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Glad I was able to help you.
But don't thank me for the best media player!
Instead thank Boris Voglar (and his team) for the Boris Software player.
Just like you I'm just a user (and a translator).
(Well maybe I have been around on the BS.Player scene a bit longer.)
Always trying to be of some help and assistance to my fellow users of BS.Player.
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #10 (permalink)  
Old 5th April 2010
Junior Member
BS.Player Newbie
 
Join Date: Apr 2010
Posts: 9
Rep Power: 0
cressy is on a distinguished road
Default

Oh I know that, lol. That was meant as a general thank you to those who deserve the praise
Reply With Quote
  #11 (permalink)  
Old 9th April 2010
Junior Member
BS.Player Newbie
 
Join Date: Apr 2010
Posts: 2
Rep Power: 0
mazator is on a distinguished road
Default Fixed

Quote:
Originally Posted by BSPeter View Post
Glad I was able to help you.
But don't thank me for the best media player!
Instead thank Boris Voglar (and his team) for the Boris Software player.
Just like you I'm just a user (and a translator).
(Well maybe I have been around on the BS.Player scene a bit longer.)
Always trying to be of some help and assistance to my fellow users of BS.Player.

I found that if I uninstall version of ffdshow which is part of the BSPlayer and install last version manually the problem is fixed - so probably the BSPlayer installer needs to be updated
Reply With Quote
Reply

Tags
mp4, sound

Thread Tools
Display Modes

Posting Rules

Similar Threads
Thread Thread Starter Forum Replies Last Post
[Vista] Upmixing of stereo sound drsnuggles General Talk And Support 6 31st December 2006 03:54 PM
I have a sound problem with BS player. Only video, no sound. jay911 General Talk And Support 8 21st October 2005 08:36 PM
I have no sound :-( ProDigit Bug Reports And Codecs 1 3rd September 2004 05:14 PM
AC-3 sound with Xvid - NO SOUND what General Talk And Support 1 22nd June 2003 04:44 PM
How can I play an external sound file with avi's own sound? Chunga-changa General Talk And Support 0 23rd January 2003 01:11 PM


All times are GMT +1. The time now is 11:37 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19