Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Answered And Solved Questions

Answered And Solved Questions A good place to check before you post your question. All answered / solved posts are archived here.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 24th May 2010
Junior Member
BS.player Regular User
 
Join Date: Nov 2009
Age: 36
Posts: 22
Rep Power: 0
Kiki is on a distinguished road
Default HD videos/codec ?

What about a CoreAVC codecs? I can't play HD movies without laging. I have solid MPU. And when i installed CoreAVC i cannot use it, becouse i can't see it anywhere :(
Which codecs for HD .264 videos?
Reply With Quote
  #2 (permalink)  
Old 24th May 2010
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

If you installed correctly CoreAVC codec you should find it in program files.
If you have also ffdshow, you must unasign H264 decoding from ffdshow and then CoreAVC will do the decoding.
Reply With Quote
  #3 (permalink)  
Old 24th May 2010
Junior Member
BS.player Regular User
 
Join Date: Nov 2009
Age: 36
Posts: 22
Rep Power: 0
Kiki is on a distinguished road
Default

Quote:
Originally Posted by adicoto View Post
If you installed correctly CoreAVC codec you should find it in program files.
If you have also ffdshow, you must unasign H264 decoding from ffdshow and then CoreAVC will do the decoding.
I'm. but when i disable libra..... in ffdshow pref., it wont stay that way. When i open Bsplayer and go to ffdshow pref. again, libra.... is on again. And i can't see CoreAVC anywhere
Reply With Quote
  #4 (permalink)  
Old 24th May 2010
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

START -> programs -> ffdshow video decoder -> H264 and disable.
Reply With Quote
  #5 (permalink)  
Old 24th May 2010
Junior Member
BS.player Regular User
 
Join Date: Nov 2009
Age: 36
Posts: 22
Rep Power: 0
Kiki is on a distinguished road
Default

Quote:
Originally Posted by adicoto View Post
START -> programs -> ffdshow video decoder -> H264 and disable.
It does not work. Every time i do so it's always do the same ''libravodec'' sh...t when i open movie.......
Reply With Quote
  #6 (permalink)  
Old 24th May 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

It is possible that you've more versions of ffdshow installed (i.e. a BS.Player "internal" and "external" version).
adicoto's "path" (via [Start] etc.) leads you to the "BS.Player-externally" installed version.
You should make sure to change settings in the ffdshow version as actually used by BS.Player.
In that connection please always use (with a file loaded) the "path" as mentioned by me (as second option) here (click here).
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #7 (permalink)  
Old 25th May 2010
Junior Member
BS.player Regular User
 
Join Date: Nov 2009
Age: 36
Posts: 22
Rep Power: 0
Kiki is on a distinguished road
Default

Thanks on advices!
Sometimes (about now :) ) i have a strange problem, i think is a bug.
When i play file and drop subtitles on it, my movie stop playing and than continue, and when subtitles again shows video is back on that position from begining , and so......... When subtitles is off, everything is fine.......
Is that a bug or i need some some kind of program?
Sorry on offtopic, and my english
Reply With Quote
  #8 (permalink)  
Old 25th May 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Is your first problem solved now?
Further you do not seem to give too much info away.
What is your OS?
What type of subtitles are you talking about?
Same result if you load the subtitle using [Ctrl]+[L] keycombination?
Is "Draw subtitles to Overlay surface" selected
under (rightclick >) Options > Preferences > Subtitles [Subtitle properties] ?
Are you using new or 'old' subtitle-engine "Use new subtitle parser/renderer"?
(under: as above)
What "Rendering mode" are you using
under (rightclick >) Options > Preferences > Video > [Video rendering] ?
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #9 (permalink)  
Old 25th May 2010
Junior Member
BS.player Regular User
 
Join Date: Nov 2009
Age: 36
Posts: 22
Rep Power: 0
Kiki is on a distinguished road
Default

After that you suggest me, HD video was playing fine until i drop subs into.
So i m not shure if it works or not. I think it will works........
For details i will answer afternoon. Cheers!
Reply With Quote
  #10 (permalink)  
Old 25th May 2010
Junior Member
BS.player Regular User
 
Join Date: Nov 2009
Age: 36
Posts: 22
Rep Power: 0
Kiki is on a distinguished road
Default

Quote:
Originally Posted by BSPeter View Post
Is your first problem solved now?
Further you do not seem to give too much info away.
What is your OS?
What type of subtitles are you talking about?
Same result if you load the subtitle using [Ctrl]+[L] keycombination?
Is "Draw subtitles to Overlay surface" selected
under (rightclick >) Options > Preferences > Subtitles [Subtitle properties] ?
Are you using new or 'old' subtitle-engine "Use new subtitle parser/renderer"?
(under: as above)
What "Rendering mode" are you using
under (rightclick >) Options > Preferences > Video > [Video rendering] ?

OS- W7
srt. file
Its the same problem with ctrl +L comb.
"Draw subtitles to Overlay surface" - enabled
enchanced video rendering
''Are you using new or 'old' subtitle-engine "Use new subtitle parser/renderer"?
(under: as above)''- i dont know
Reply With Quote
  #11 (permalink)  
Old 25th May 2010
Junior Member
BS.player Regular User
 
Join Date: Nov 2009
Age: 36
Posts: 22
Rep Power: 0
Kiki is on a distinguished road
Default

Now, when i changed video rendering, subtitles is ok
but, picture is laging (small but noticable ).
Reply With Quote
  #12 (permalink)  
Old 26th May 2010
Junior Member
BS.player Regular User
 
Join Date: Nov 2009
Age: 36
Posts: 22
Rep Power: 0
Kiki is on a distinguished road
Default

There some issues with that video rendering.........
Reply With Quote
  #13 (permalink)  
Old 26th May 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Quote:
Originally Posted by BSPeter View Post
....Is "Draw subtitles to Overlay surface" selected
under (rightclick >) Options > Preferences > Subtitles [Subtitle properties] ?
Are you using new or 'old' subtitle-engine "Use new subtitle parser/renderer"?
(under: as above)....
Quote:
Originally Posted by Kiki View Post
...."Draw subtitles to Overlay surface" - enabled
enchanced video rendering
''Are you using new or 'old' subtitle-engine "Use new subtitle parser/renderer"?
(under: as above)''- i dont know
If you "don't know" I must assume there (i.e. under (rightclick >) Options > Preferences > Subtitles [Subtitle properties]) isn't shown such option "Use new subtitle parser/renderer" (unless... no I won't assume that).
So, what version/build of BS.Player are you using?
I suggest you update to latest version first.
You also fail to mention which Rendering mode you've selected now.
I suggest to switch back to EVR (Vista's & Win7's "Enhanced Video Renderer").
Then check what happens if you deselect "Draw subtitles to Overlay surface"
and select "Enable drawing subtitles under image with EVR renderer"
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #14 (permalink)  
Old 29th May 2010
Junior Member
BS.player Regular User
 
Join Date: Nov 2009
Age: 36
Posts: 22
Rep Power: 0
Kiki is on a distinguished road
Default

Quote:
Originally Posted by BSPeter View Post
If you "don't know" I must assume there (i.e. under (rightclick >) Options > Preferences > Subtitles [Subtitle properties]) isn't shown such option "Use new subtitle parser/renderer" (unless... no I won't assume that).
So, what version/build of BS.Player are you using?
I suggest you update to latest version first.
You also fail to mention which Rendering mode you've selected now.
I suggest to switch back to EVR (Vista's & Win7's "Enhanced Video Renderer").
Then check what happens if you deselect "Draw subtitles to Overlay surface"
and select "Enable drawing subtitles under image with EVR renderer"

Bsplayer 2.53
All done, same problem :(
Reply With Quote
  #15 (permalink)  
Old 29th May 2010
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

And you're using new subtitle parser/renderer or ...?
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #16 (permalink)  
Old 30th May 2010
Junior Member
BS.player Regular User
 
Join Date: Nov 2009
Age: 36
Posts: 22
Rep Power: 0
Kiki is on a distinguished road
Default

Quote:
Originally Posted by BSPeter View Post
And you're using new subtitle parser/renderer or ...?
It work's!
After 10x
But problem is same. Lag, low framerate on wide scenes (forest, mountains...)
I figured that VMP, MPC, GOM, and other players have same issues. Can it be to MPU. It's ATI radeon 3200. Must i in BIOS change memory for video? So much to do, so little nerves left.......
Reply With Quote
  #17 (permalink)  
Old 30th May 2010
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

HD play it's cpu consuming and not GPU. So, in this case, your grafic card does not have any influence. BIOS memory allocation is for 3D texture (games) no use in this case.
So, at this moment, which decoder it's used ? CoreAVC or ffdshow ?
If you don't need AERO while watching a movie, my advice is to use old rendering engine and internal renderer (default) for video. Screen will flicker for a second when movie starts / ends.
By the way, what's the audio decoder ?
Reply With Quote
  #18 (permalink)  
Old 30th May 2010
Junior Member
BS.player Regular User
 
Join Date: Nov 2009
Age: 36
Posts: 22
Rep Power: 0
Kiki is on a distinguished road
Default

Quote:
Originally Posted by adicoto View Post
HD play it's cpu consuming and not GPU. So, in this case, your grafic card does not have any influence. BIOS memory allocation is for 3D texture (games) no use in this case.
So, at this moment, which decoder it's used ? CoreAVC or ffdshow ?
If you don't need AERO while watching a movie, my advice is to use old rendering engine and internal renderer (default) for video. Screen will flicker for a second when movie starts / ends.
By the way, what's the audio decoder ?

I have K-lite, CoreAVC, ffdshow, Haali media splitter, and audio is Ac3filter.
I did not try aero thing do.....
Reply With Quote
  #19 (permalink)  
Old 30th May 2010
Moderator
BS.Player Master
 
Join Date: Jan 2003
Location: Romania
Age: 50
Posts: 5,127
Rep Power: 25
adicoto is on a distinguished road
Default

Quote:
Originally Posted by Kiki View Post
I have K-lite, CoreAVC, ffdshow, Haali media splitter, and audio is Ac3filter.
I did not try aero thing do.....
If you are using windows 7, by default AERO is enabled. For windows 7, EVR it's considered to be the best rendering methode also because it does not disable AERO (main eyecandy windows interface). On the other hand, in terms of capabilities, internal rendered (default) as video rendering methode I personally consider to be the best. My advice, turn to it and tell us if it works better.
On the other hand, it's important not which filters are installed on your PC, but the filters BSPlayer uses to decode the streams. So, open an HD file, rightclick -> options -> filters ->advanced, and post here all the info, names of the filter used and also the paths to them.
Thank you.
Reply With Quote
  #20 (permalink)  
Old 31st May 2010
Junior Member
BS.player Regular User
 
Join Date: Nov 2009
Age: 36
Posts: 22
Rep Power: 0
Kiki is on a distinguished road
Default

here:

\FFDShow\
ffdshow.ax, Size: 3565056 bytes, Version 1.0.7.3135

CompanyName:
FileDescription: DirectShow and VFW video and audio decoding/encoding/processing filter
FileVersion: 1.0.7.3135
InternalName: ffdshow
LegalCopyright: Copyright © 2002-2008
LegalTradeMarks: GNU GPL
OriginalFilename: ffdshow.ax
ProductName: ffdshow
ProductVersion: 1.0.7.3135
Comments: 1.0.7.3135

CompanyName:
FileDescription: ac3filter
FileVersion: 1.63b
InternalName: ac3filter
LegalCopyright: Copyright c 2002-2007 by Alexander Vigovsky
LegalTradeMarks: Copyright c 2002-2007 by Alexander Vigovsky
OriginalFilename: ac3filter.ax
ProductName: AC3Filter
ProductVersion: 1.63b
Comments: Direct show audio decoder and processor filter

CompanyName: Microsoft Corporation
FileDescription: DirectShow Runtime.
FileVersion: 6.6.7600.16385 (win7_rtm.090713-1255)
InternalName: Quartz.dll
LegalCopyright: © Microsoft Corporation. All rights reserved.
LegalTradeMarks: © Microsoft Corporation. All rights reserved.
OriginalFilename: Quartz.dll.mui
ProductName: Microsoft® Windows® Operating System
ProductVersion: 6.6.7600.16385
Comments: 6.6.7600.16385

CompanyName: Microsoft Corporation
FileDescription: Enhanced Video Renderer DLL
FileVersion: 6.1.7600.16385 (win7_rtm.090713-1255)
InternalName: Enhanced Video Renderer DLL
LegalCopyright: © Microsoft Corporation. All rights reserved.
LegalTradeMarks: © Microsoft Corporation. All rights reserved.
OriginalFilename: evr.dll.mui
ProductName: Microsoft® Windows® Operating System
ProductVersion: 6.1.7600.16385
Comments: 6.1.7600.16385

CompanyName: MONOGRAM Multimedia, s.r.o.
FileDescription: AMR Filter Pack
FileVersion: 1, 0, 1, 0
InternalName: mmamr
LegalCopyright: Copyright (C) 2008
LegalTradeMarks: Copyright (C) 2008
OriginalFilename: mmamr.ax
ProductName: MONOGRAM AMR Filter Pack
ProductVersion: 1, 0, 1, 0
Comments: 1, 0, 1, 0

AVI Splitter
Location: C:\Windows\system32\
quartz.dll, Size: 1328640 bytes, Version 6.6.7600.16490

CompanyName: Microsoft Corporation
FileDescription: DirectShow Runtime.
FileVersion: 6.6.7600.16385 (win7_rtm.090713-1255)
InternalName: Quartz.dll
LegalCopyright: © Microsoft Corporation. All rights reserved.
LegalTradeMarks: © Microsoft Corporation. All rights reserved.
OriginalFilename: Quartz.dll.mui
ProductName: Microsoft® Windows® Operating System
ProductVersion: 6.6.7600.16385
Comments: 6.6.7600.16385

ource
Location: C:\Windows\system32\
quartz.dll, Size: 1328640 bytes, Version 6.6.7600.16490

CompanyName: Microsoft Corporation
FileDescription: DirectShow Runtime.
FileVersion: 6.6.7600.16385 (win7_rtm.090713-1255)
InternalName: Quartz.dll
LegalCopyright: © Microsoft Corporation. All rights reserved.
LegalTradeMarks: © Microsoft Corporation. All rights reserved.
OriginalFilename: Quartz.dll.mui
ProductName: Microsoft® Windows® Operating System
ProductVersion: 6.6.7600.16385
Comments: 6.6.7600.16385
Reply With Quote
Reply

Tags
videos or codec

Thread Tools
Display Modes

Posting Rules


All times are GMT +1. The time now is 05:44 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19