Official BS.Player forums  

Go Back   Official BS.Player forums > Main forum > Answered And Solved Questions

Answered And Solved Questions A good place to check before you post your question. All answered / solved posts are archived here.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 5th August 2011
Junior Member
BS.Player Newbie
 
Join Date: Aug 2011
Posts: 4
Rep Power: 0
Mugsy is on a distinguished road
Question [SOLVED] Badly distorted audio with FLV?

When I play FLV (Flash Video) files, the sound using BS Player Free (2.57) is just awful. Sounding distorted and over-amped.

In the Options, the only audio settings are to "Don't use Vorbis codec"... which does nothing... and to change codec for AC3 files (which also has no effect with FLV files.)

No other player has this problem when playing FLV clips. Is there any way to tweak BSP so the sound on FLV videos isn't so bad?
Reply With Quote
  #2 (permalink)  
Old 6th August 2011
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Quote:
Originally Posted by Mugsy View Post
...In the Options, the only audio settings are to "Don't use Vorbis codec"... which does nothing... and to change codec for AC3 files (which also has no effect with FLV files.)
If these really are the only settings under Options>>Preferences>>Audio, then we're not talking about BS.Player! Also BS.Player has no setting "Don't use Vorbis codec" (though it has a setting "Use internal Vorbis decoder"). So, could you please try to be more precise?
If sound is distorted and over-amped you could have a look at the settings of BS.Player's equalizer (pre-amp) and or any filter(s) or plugin(s) used by BS.Player.
I suppose you know how to activate equalizer window. I also suppose you know if you have any plugins installed and how to access their settings, so I leave it at that.
With respect to the (audio)filters actually used by BS.Player upon playback of specific files, this may differ depending on the type of file played and on the codecs/filters which BS.Player finds installed on your system.
Therefore, when playing such flv-files, could you please check what filters/codecs are indicated under
rightclick > Options > Filters > Advanced?
When doing so please make sure to also click on the small [+]-signs in front of the filters/codecs shown.
This will reveal further information and access, so you should also be able to alter the audiofilter's settings there.
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #3 (permalink)  
Old 6th August 2011
Junior Member
BS.Player Newbie
 
Join Date: Aug 2011
Posts: 4
Rep Power: 0
Mugsy is on a distinguished road
Default Picky picky

Quote:
Originally Posted by BSPeter View Post
If these really are the only settings under Options>>Preferences>>Audio, then we're not talking about BS.Player! Also BS.Player has no setting "Don't use Vorbis codec" (though it has a setting "Use internal Vorbis decoder"). So, could you please try to be more precise?
If sound is distorted and over-amped you could have a look at the settings of BS.Player's equalizer (pre-amp) and or any filter(s) or plugin(s) used by BS.Player.
I suppose you know how to activate equalizer window. I also suppose you know if you have any plugins installed and how to access their settings, so I leave it at that.
With respect to the (audio)filters actually used by BS.Player upon playback of specific files, this may differ depending on the type of file played and on the codecs/filters which BS.Player finds installed on your system.
Therefore, when playing such flv-files, could you please check what filters/codecs are indicated under
rightclick > Options > Filters > Advanced?
When doing so please make sure to also click on the small [+]-signs in front of the filters/codecs shown.
This will reveal further information and access, so you should also be able to alter the audiofilter's settings there.
Picky picky.

I was going off memory, so pardon me if my description was not a word-for-word match with the actual program dialog.

Under "Audio" in the Options, the only "decoder" option is (Actual wording) "Use internal Vobic decoder". BSP defaults to "checked", but unchecking the option has no effect. Other options on Audio menu, including "Use Dedynamic filter", also have no impact on FLV audio quality.

Submenus below Audio include "WinAmp2 DSP Plugins", of which I have none, the "InterVideo AC3" menu, of which nothing I select stays selected, the (numeric) equalizer is unchecked, and "Output" is set to "System default" (though I've tried adjusting both).

Yes, I've tried using the graphic equalizer. But this clearly is not an equalizer problem, as the only audio affected is in FLV video files.

I'll repeat that other players (like RealPlayer14 or WMP12) don't have this problem (though I did find "MPC-HC" appears to have the same issue), so the fault is either the audio codec BSP uses to play FLV files, or BSP itself. And since there is no apparent way to determine which audio codec BSP uses with FLV, there is no way for me to check/adjust that codec's settings. And the fact there appears to be no way to specify a different codec for FLV audio in BSP, there is no "obvious" fix.

Sorry. Not a newbie here. I know what player I'm using and "nitpiks" are not helpful.
Reply With Quote
  #4 (permalink)  
Old 6th August 2011
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Quote:
Originally Posted by Mugsy View Post
.... so the fault is either the audio codec BSP uses to play FLV files, or BSP itself. And since there is no apparent way to determine which audio codec BSP uses with FLV, there is no way for me to check/adjust that codec's settings. And the fact there appears to be no way to specify a different codec for FLV audio in BSP, there is no "obvious" fix....
You may call me picky or a "nitpicker" (an opinion is anyone's free right and privilege) but in spite that your first post maybe did confuse me (being a "picky reader"), I have to correct you as, in fact, I already did indicate the way to determine which audio codec BS.Player actually uses when playing any particular file. Could you please follow my indications this time?
Quote:
Originally Posted by BSPeter View Post
....With respect to the (audio)filters actually used by BS.Player upon playback of specific files, this may differ depending on the type of file played and on the codecs/filters which BS.Player finds installed on your system.
Therefore, when playing such flv-files, could you please check what filters/codecs are indicated under
rightclick > Options > Filters > Advanced?
When doing so please make sure to also click on the small [+]-signs in front of the filters/codecs shown.
This will reveal further information and access, so you should also be able to alter the audiofilter's settings there.
Look forward to your info.

P.S.:
Note, though I surely wouldn't call myself an expert, I'm not entirely a newbe either. In this connection I feel obliged to observe that your statement that there appears to be no way to specify a different codec for FLV audio in BSP isn't correct either as you can actually do that using BS.Player's "Filter management".
(This is to be found under rightclick > Options > Preferences > Filter management.)
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #5 (permalink)  
Old 6th August 2011
Junior Member
BS.Player Newbie
 
Join Date: Aug 2011
Posts: 4
Rep Power: 0
Mugsy is on a distinguished road
Default

Quote:
Originally Posted by BSPeter View Post
P.S.:
Note, though I surely wouldn't call myself an expert, I'm not entirely a newbe either. In this connection I feel obliged to observe that your statement that there appears to be no way to specify a different codec for FLV audio in BSP isn't correct either as you can actually do that using BS.Player's "Filter management".
(This is to be found under rightclick > Options > Preferences > Filter management.)
Clicking "Filters" on the Options menu does nothing except close the Menu dialog.

From the Preferences window, on the Filter Manger tab, you can see the codecs used for "DirectShow" FLV filters for "Source", "Splitter" and "Video Decoder", but not audio. In the "Audio" section, "FLV" is not specified.
Reply With Quote
  #6 (permalink)  
Old 6th August 2011
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Quote:
Originally Posted by Mugsy View Post
Clicking "Filters" on the Options menu does nothing except close the Menu dialog.
That happens if no file is loaded:
Quote:
Originally Posted by BSPeter View Post
...With respect to the (audio)filters actually used by BS.Player upon playback of specific files, this may differ depending on the type of file played and on the codecs/filters which BS.Player finds installed on your system.
Therefore, when playing such flv-files, could you please check what filters/codecs are indicated under
rightclick > Options > Filters > Advanced?
When doing so please make sure to also click on the small [+]-signs in front of the filters/codecs shown.
This will reveal further information and access, so you should also be able to alter the audiofilter's settings there.
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
  #7 (permalink)  
Old 6th August 2011
Junior Member
BS.Player Newbie
 
Join Date: Aug 2011
Posts: 4
Rep Power: 0
Mugsy is on a distinguished road
Default

Quote:
Originally Posted by BSPeter View Post
That happens if no file is loaded:
Ah, okay. Definitely more cumbersome than need be and not particularly intuitive.

Loading an FLV file and then checking the "FFdshow audio decoder", I found that the "Volume" box was checked, boosting volume to "128%". Unchecking the box returned the audio to normal.

Why the program defaults to over-amping the audio is a mystery, and if you don't know what is causing the problem (like I didn't), the chances of figuring it out yourself are pretty slim.

But that seems to have fixed it. Thanks for the help.
Reply With Quote
  #8 (permalink)  
Old 6th August 2011
BSPeter's Avatar
Moderator
BS.Player Master
 
Join Date: Nov 2002
Location: The Netherlands
Posts: 5,463
Rep Power: 25
BSPeter is on a distinguished road
Default

Quote:
Originally Posted by Mugsy View Post
Ah, okay. Definitely more cumbersome than need be and not particularly intuitive.
Loading an FLV file and then checking the "FFdshow audio decoder", I found that the "Volume" box was checked, boosting volume to "128%". Unchecking the box returned the audio to normal.
Why the program defaults to over-amping the audio is a mystery, and if you don't know what is causing the problem (like I didn't), the chances of figuring it out yourself are pretty slim.
But that seems to have fixed it. Thanks for the help.
Maybe it seems more cumbersome than need be to you, but - as I already mentioned - the (audio)filters actually used by BS.Player upon playback of specific files ....may differ depending on the type of file played and on the codecs/filters which BS.Player finds installed on your system. (Needless to say that sometimes users have installed a real abundance of filters and codecs, thinking "more is better" which really doesn't help to find the actual culprit.)
So if you don't know what's causing the problem it is indeed necessary to load the "problematic file" in order to first find out what filter/codec is handling the actual decoding. So that is also the reason why I always ask users (and I'm rather "picky" in that) to check under Filters > Advanced while playing the "problematic file".
Anyhow, I'm glad you've found this forum when you couldn't figure it out yourself (that's one of the reasons for the forum's existance) and even more that you've now been able to fix the problem with just a little help from this "nitpicker". Thanks for sharing for the possible benefit of other users.
__________________
Help2Help (click) BSplayer: simply the best & most versatile (Build 1072 Dutch language here!)
When posting always mention your computer's OS and the version and build number(!) of BS.Player as used by you,
as well as - if applicable and especially when encountering problems - the type(s) of the file(s) mentioned in your post.
Private messages/Visitor messages are NOT for seeking personal help with respect to BS.Player! Instead use the forums!
Reply With Quote
Reply

Tags
audio, badly, distorted, flv

Thread Tools
Display Modes

Posting Rules

Similar Threads
Thread Thread Starter Forum Replies Last Post
external audio loading fails / autoloading external audio: cannot switch audio djboss General Talk And Support 2 15th March 2010 02:55 PM
AC3 5Ch Audio NOT working in BSPlayer..? General Talk And Support 3 12th March 2003 10:09 PM


All times are GMT +1. The time now is 08:46 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Ad Management plugin by RedTyger

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19